Bug 448604 (whistler)

Can't get out of Whistler

VERIFIED WORKSFORME

Status

mozilla.org
Miscellaneous
--
blocker
VERIFIED WORKSFORME
9 years ago
2 years ago

People

(Reporter: davida, Assigned: beltzner)

Tracking

(16 keywords)

Details

(Whiteboard: If you are flying the Google Jet, please see comment #53, URL)

Attachments

(7 attachments)

(Reporter)

Description

9 years ago
Someone should do something about the rocks on the road.

Comment 1

9 years ago
Are you volunteering to shovel?  :)

Comment 2

9 years ago
Oh, and I think this is a blocker... literally ;)
Severity: normal → blocker
Let's tunnel under them using a proxy
Hardware = stone
Operating system = Sea-to-Sky Highway
OS: Mac OS X → Other
Hardware: PC → Other

Comment 5

9 years ago
I thought they had awesome bears here?!
OS: Other → Mac OS X
Hardware: Other → PC
OS: Mac OS X → Other
Hardware: PC → Other
This is the tentative solution we came up with at lunch:

1. Take a bus down from Whistler to rock slide.
2. Get out of bus.
3. Walk over rock slide (may require additional walkways).
4. Get into waiting bus.
5. Get to Vancouver.

Those who drove themselves will have to take the long way.
Severity: blocker → normal
OS: Other → Mac OS X
Hardware: Other → PC

Comment 7

9 years ago
We shall ride bears to Vancouver. Rocks can't stop bears.
As long as we ride atop the bears instead of in their hungry bellies.

Comment 9

9 years ago
So we have patch now? Should Hasham roll it, then?
Severity: normal → blocker
OS: Mac OS X → Other
Hardware: PC → Other

Comment 10

9 years ago
OS -> Whistler
OS: Other → Windows XP

Comment 11

9 years ago
Mmh, btw: those rocs changed layout of the highway... ;-)
Severity: blocker → normal
OS: Windows XP → Mac OS X
Hardware: Other → PC

Updated

9 years ago
Severity: normal → blocker
OS: Mac OS X → Windows XP
Hardware: PC → Other
The rocks didn't change the layout as much as the dynamite will.
Severity: blocker → normal
OS: Windows XP → Mac OS X
Hardware: Other → PC
Severity: normal → blocker
OS: Mac OS X → Windows XP
Hardware: PC → Other

Comment 13

9 years ago
having fun with the hardware/OS fight? lol
why not driving to the rock slide and every Mozillian carries away one stone :) ..should make fix this bug very soon ;) 
If you're willing to exchange your money for your time, you can always look into things like http://www.whistler.com/float_plane/

(In reply to comment #14)
> why not driving to the rock slide and every Mozillian carries away one stone :)
> ..should make fix this bug very soon ;) 

Sadly, I don't know if the "all bugs are shallow" maxim works in this particular case.
If we project a Firefox logo on to the clouds, a giant robot will come and carry us to safety.  
Assignee: nobody → dportillo

Comment 18

9 years ago
This bug blocks for sure.  Where are the flags?
Created attachment 331811 [details]
a possible patch
Based on comment 15, it looks like beltzner is going to arrange for us all to take float planes.  Hurray!

Beltzner - please let us know when you have all our flights booked.
Assignee: dportillo → beltzner
We need to get more people to vote this bug up if we want it fixed.

Updated

9 years ago
Alias: whistler

Updated

9 years ago
Keywords: helpwanted
Soon, the food will run out and we will be forced to eat one another. Luckily, we have interns...
Priority: -- → P1
Marking dogfood, as bearfood was unavailable.
Keywords: dogfood
Priority: P1 → --

Comment 24

9 years ago
Created attachment 331812 [details]
Testcase

Attaching testcase to help fix the bug.
I am arranging for the 74 bears. However, it will be rather short notice, and
people are the best bait, so I am thinking of using IE developers, but they are
in short supply, due to this weird upstart browser with a very weird name
Fire...something, oh yeah, firefox.
Also running into issues with PETA.
Flags: blocking1.9.0.2+
Damn, we could go away before, so this is a bad regression!
Keywords: regression
Bears, where?!??!

Food, where?!?!

Rocks... they are good to cut human meat... Slurm...

Comment 28

9 years ago
This is what we get for holding a meeting at a Windows code name.

(i.e., clearly, it's Microsoft's fault)
Note that rock climbing is usually not a very accessible way to pass a road, unless you happen to have a guide like Roc.
Keywords: access
Flags: blocking-road+
I want to remember to all that there will be a "i cannot go out of whistler party" in the Shawn Wilsher's room, so feel free to ask his room number at the reception and go knockin at his door at every time of the day or the night, he has beer and a good wifi signal to share with everyone :D
Adding jp-critical keyword, because the Japanese guys probably want to get home, too. 
Keywords: jp-critical
According to Kai, Blackcomb, Longhorn, and Vienna are off the chart.

@Tyler: I happen to know where IE developers work:
http://maps.google.com/maps?f=q&ll=47.646811,-122.13303&spn=0.001782,0.004399
Feel free to obtain them for your bear arrangements.
I hate the Spurs.
(In reply to comment #32)
> According to Kai, Blackcomb, Longhorn, and Vienna are off the chart.
> 
> @Tyler: I happen to know where IE developers work:
> http://maps.google.com/maps?f=q&ll=47.646811,-122.13303&spn=0.001782,0.004399
> Feel free to obtain them for your bear arrangements.
> 
Thanks

(In reply to comment #30)
> I want to remember to all that there will be a "i cannot go out of whistler
> party" in the Shawn Wilsher's room, so feel free to ask his room number at the
> reception and go knockin at his door at every time of the day or the night, he
> has beer and a good wifi signal to share with everyone :D
> 
Exercise, the new weight management program. Simply go climb a blocked road.
Since this bug effects only a small portion of Firefox users, proposing this as WONTFIX.

Perhaps interested parties can create an extension?
We've got an acceptable workaround (bears!) but to prevent recurrences, recommend scheduling all future summits in locations that have good routes to at least two major airports.
Who says WONTFIX? Mike has volunteered to get Float planes for everyone.
And, I hope to have about 10 IE devs for the bait, so we will have two workarounds for this.
Of course I hope the IE folks coperate. And you wont get any more cakes for FF4.
Created attachment 331814 [details]
Workaround

Workaround.

I know it is difficult to understand but, yes, could be the best option. You know, Mozilla is not the guilty, is the Earth...

[Taken from ext3-mozilla-sqlite problems]
Oh, I forgot: 449 km – aprox. 5h 56 min

"It'll be fun!"
Keywords: testcase
(In reply to comment #38)
> Of course I hope the IE folks coperate. And you wont get any more cakes for
> FF4.
Sad, but true. And after this if anyone claims we'll get another IE cake for Fx 4, it'll be a lie.

Also, there's only 13 votes as of now; vote, people!
Enjoy the view.
(In reply to comment #35)
> Since this bug effects only a small portion of Firefox users, proposing this as
> WONTFIX.

Grammar nazi to the rescue! ;) (reminds me of http://xkcd.com/326/)
Safe to say that this causes some international problems, and is also high risk. I mean, more of the road could cave in...
Keywords: highrisk, intl

Comment 45

9 years ago
conversion: I can't convert my friends to using Firefox while not drinking beer with them.

crash: This bug would also cause a bus crash if not fixed or worked around.

possibly should add mobile too...
Keywords: conversion, crash, mobile
A someone spending the day in NYC with a grid layout... I laugh at Whistler's lack of redundancy.

Grid Commuting for the win!

I propose replacing the maple leaf as the official symbol of Canada with a Fail Whale.

Comment 47

9 years ago
@Rimas : If there is a bus crash, there will be a data loss

Comment 48

9 years ago
(In reply to comment #47)
> @Rimas : If there is a bus crash, there will be a data loss
> 

Though the dataloss keyword is defined as "For bugs which that do not crash, but do cause critical data loss."
This might be a buffer-overflow of the mountain, didn't someone detect this with using valgrind?
Can't we wen't back to a previous revision of the mountain??

I always say... "Make backups!!"
s/wen't/went

Comment 52

9 years ago
zt4newcrash too, perhaps?

Comment 53

9 years ago
So I propose that Asa and Polvi setup a campaign to get the google guys to send their jet up to fly us all out. If anyone can do it, they can!
(In reply to comment #53)
> So I propose that Asa and Polvi setup a campaign to get the google guys to send
> their jet up to fly us all out. If anyone can do it, they can!
> 

Where would it land?
This bug is definitely caused by rocks coming from above the street! So it should be a topcrash. And why is it set to Windows only? If you have a look to the back of the Emerald room I always see OS X users => All/All.
Keywords: topcrash
OS: Windows XP → All
Hardware: Other → All
Created attachment 331820 [details]
A plan inspired by Cww (Sumo Livechat)

Comment 57

9 years ago
(In reply to comment #54)
> (In reply to comment #53)
> > So I propose that Asa and Polvi setup a campaign to get the google guys to send
> > their jet up to fly us all out. If anyone can do it, they can!
> > 
> 
> Where would it land?

On TRUNK first, then on BRANCH
OS: All → Windows XP
Hardware: All → Other

Comment 58

9 years ago
Henrik, it's Whistler-specific.
Keywords: zt4newcrash
Created attachment 331828 [details]
here's a stack from the crash

courtesy of Enn
A roadmap is needed :-)

Next summit : flatest place on earth, nice summer weather, no bear :-)
added my *important* vote.

please, please (please) don't wait 4 years to fix this bug that the entire world needs resolved

Updated

9 years ago
Keywords: qawanted
Whiteboard: If you are flying the Google Jet, please see comment #53

Comment 62

9 years ago
It seems that Canadian government has dedicated a team of professionals to solve this problem. They say they'll be done in five days.

Perhaps the change to the mountains should be backed out for the time being?
Keywords: qawanted
Whiteboard: If you are flying the Google Jet, please see comment #53

Comment 63

9 years ago
(wow, I didn't know I can remove other peoples comments just like that...)
Keywords: qawanted
Whiteboard: If you are flying the Google Jet, please see comment #53
Priority: -- → P1

Updated

9 years ago
Priority: P1 → --

Updated

9 years ago
Priority: -- → P1
Why is this a blocker when there's a known workaround?  See
http://maps.google.com/maps?f=d&saddr=Whistler,+BC&daddr=50.025388,-121.530762+to:Vancouver,+BC&via=1&ie=UTF8
(In reply to comment #64)
> Why is this a blocker when there's a known workaround?

The workaround hasn't been proven yet.
(In reply to comment #57)
> On TRUNK first, then on BRANCH

I think that we all agreed today that we cannot recognize the TRUNK from the BRANCH in Mozilla...

Comment 67

9 years ago
(In reply to comment #66)
> (In reply to comment #57)
> > On TRUNK first, then on BRANCH
> 
> I think that we all agreed today that we cannot recognize the TRUNK from the
> BRANCH in Mozilla...

Not in Mercurial, no. Right, it should be landed there first.
Priority: P1 → --
This also breaks the "road is ok" NS_ASSERTION. 
Keywords: assertion
(In reply to comment #64)
> Why is this a blocker when there's a known workaround?

It should get review- because it's more like a _walk_around than a _work_around.

Comment 70

9 years ago
(In reply to comment #35)
> Since this bug effects only a small portion of Firefox users, proposing this as
> WONTFIX.
> 
> Perhaps interested parties can create an extension?
> 

The interested parties have created an extension of 5 hours, does that work for you? I too vote for a WONTFIX
I will buy anyone who reviews the _walk_around (by actually conducting one) a small drink.

Comment 72

9 years ago
No doubt someone is using firefox 2 there and the mountain got a huge leak. Roll the update to 2.0.0.x :)
So the next firefox codename is "whistler", right ?-)

Comment 74

9 years ago
The whole hotel's power is down for > 1/2 hour,
is it a dupe or should I report another one?

Updated

9 years ago
Duplicate of this bug: 448640
Great hotel! WOW.
(In reply to comment #73)
Please do NOT! "Whistler" or  or "Poteau Cove"(where rocks slide) or somewhere...
DO-SO brings heavily bad things to the codenamed release. :) such as "share slide"...

Comment 78

9 years ago
Uhm after few days someone have to take a view+ or superview+ to make sure the patch did not regress the nearest tree.

Comment 79

9 years ago
(In reply to comment #62)
> It seems that Canadian government has dedicated a team of professionals to
> solve this problem. They say they'll be done in five days.

5 F**cking days!
(In reply to comment #30)
> I want to remember to all that there will be a "i cannot go out of whistler
> party" in the Shawn Wilsher's room, so feel free to ask his room number at the
> reception and go knockin at his door at every time of the day or the night, he
> has beer and a good wifi signal to share with everyone :D
Even when the hotel doesn't have power apparently!
definitely a regression now :) 

Comment 82

9 years ago
Bear with us! ;-)
I think we need to explore the possibilities that 3rd party applications are interfering. Seems like something external may be blocking us.
Comment on attachment 331820 [details]
A plan inspired by Cww (Sumo Livechat)

Is that chofmann flying the helicopter?
Update on the bears:
http://www.rumblingedge.com/2008/07/29/bear-with-me-while-you-sleep-at-whistler/

Comment 86

9 years ago
Due to the unfortunate laundry truck incident and our friendly neighborhood transformer being down my alarm decided not to wake me up this morning. Was probably for the better anyway since lights are out and I can't see a thing in my bathroom to take a shower. Who's idea was it again to come to Whistler? ;) 
So, is this going to cause a delay on Firefox 3.0.2?
Adding dataloss keyword, since the safes in the rooms apperantly lock up due to the power outage.

-> http://antennasoft.net/robcee/2008/07/31/fear-and-loathing-in-whistler/
Keywords: dataloss

Comment 89

9 years ago
Anyone see this truck http://www.microsoft.com/presspass/images/press/2004/10-05MSAcrossAmerica_lg.jpg around the hotel around near the time the transformer was hit?
(In reply to comment #88)
> Adding dataloss keyword, since the safes in the rooms apperantly lock up due to
> the power outage.
> 
> -> http://antennasoft.net/robcee/2008/07/31/fear-and-loathing-in-whistler/
> 

(In reply to comment #89)
> Anyone see this truck
> http://www.microsoft.com/presspass/images/press/2004/10-05MSAcrossAmerica_lg.jpg
> around the hotel around near the time the transformer was hit?
> 
Maybe M$ stole the docs from the safes, hit the transformer so you would not
know, and had planned the rockslide to delay your exit. I know there is some
type of CONSPIRACY here (not that there was not before) of evil world
denomination by M$.
Eh, Microsoft gave cakes to lure us into a sense of false security, and now see what happens!  They'll continue giving cakes and act like none of this is there fault.  Who knows, they might even try to 'help' the situation.
What else did you expect. Surprised the cake wasn't poisoned with a special chemical to turn you into IE using zombies. 

Comment 93

9 years ago
(In reply to comment #88)
> Adding dataloss keyword, since the safes in the rooms apperantly lock up due
> to the power outage.

Hm, that was totally WORKSFORME, all through the outage.

(In reply to comment #91)
> Eh, Microsoft gave cakes to lure us into a sense of false security, and now
> see what happens!

They have jagged spies in here. ;-)

> Who knows, they might even try to 'help' the situation.

Well, my lunch's fortune cookie truly said: "you will get help from unexpected sources"...
The first mozillian has down...

Johnathan Nightingale [:johnath] <johnath@mozilla.com> changed:

          What    |Removed                     |Added
----------------------------------------------------------------------------
                CC|johnath@mozilla.com         |

It has begun...

Updated

9 years ago
Blocks: 448763
(In reply to comment #89)
> Anyone see this truck
> http://www.microsoft.com/presspass/images/press/2004/10-05MSAcrossAmerica_lg.jpg
> around the hotel around near the time the transformer was hit?

I was wondering why the hotel was serviced by the "Across America" laundry service. Hmmm. Suspicious!

Comment 96

9 years ago
(In reply to comment #87)
> So, is this going to cause a delay on Firefox 3.0.2?
> 

maybe 1 day more(?)

Comment 97

9 years ago
Fixed for me :)

Comment 98

9 years ago
WFM.  I'm typing this from the Vancouver airport.  :)
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME

Comment 99

9 years ago
Steps to reproduce please.
(In reply to comment #55)
> If you have a look to the back of the Emerald room I always see OS X users =>
> All/All.

Dunno, I saw lots of MacBooks, but a sizable chunk of them were running Ubuntu or Fedora on them if you actually looked.
Verified WORKSFORME, the workaround in attachment 331814 [details] works fine, as I just used it and am now in the Vancouver airport. :)
Status: RESOLVED → VERIFIED

Comment 102

9 years ago
Verified WFM.

Thank you to Dan & everyone who made the Firefox Plus Summit amazing!
WFM, as I have already arrived in Seattle.
Thanks to Dan for choosing Whistler in the first place, then making the Summit an awesome event.

Comment 104

9 years ago
I'd like to also give mad props to the bus company for making the workaround possible.
Verified too. Thanks dan!!

Comment 106

9 years ago
Nope, doesn't work for me. Tried the other workaround with the float plane but wasn't able to make the flight, and the flight after that was full (Jay got the last seat). I am trying the other work-around now (fly into LA on the last Alaska-Airlines seat, drive up to SF!).
There was also a regression for us while using the workaround with on of the nightly buses: Mozilla/5.0 (Windows; U; Windows Whistler; en-CA; rv:1.9.1a2pre) Gecko/2008080104 Minefield/3.1a2pre ID:2008080103.

Nightly testers recognized a hang at the airport for several hours because of delayed flights. But after a lot of team work @mozcamp we were able to identify the cause and hopefully everyone was able to leave Vancouver.

But anyway, the performance of the workaround was brilliant. Solving it has only taken 6.5 hours instead of the estimated 8 hours - even it was a bit risky sometimes. Thanks to anyone who has worked on that!
Workaround of the 11am bus worked brilliantly, but now still transiting at an airport, only 6 of a 36 hour total journey left to go!
Keywords: fixed1.9.0.2
The road has been reopened:

http://www.theglobeandmail.com/servlet/story/RTGAM.20080803.wrockslide0802/BNStory/National/home

"The Sea-to-Sky Highway reopened at 10 p.m. Saturday night, putting an end to the chaos caused by a massive rockslide five days ago."
It seems most of people could escape from this trap. So is it fixed right now? Is there people in Whistler yet? (I guess this bug must be assigned to Dan Portillo. It's reason not to be fixed.
Created attachment 332164 [details]
Nightly testers in Mozilla Airport Camp

Nightly build testers in YVR to track how many people can escape from this trap. http://flickr.com/photos/seokchanyun/2722904170/

Comment 112

9 years ago
Does the issue with PETA arise from using the bears, generally, or has it been found that feeding them IE developers is bad for the system?

(In reply to comment #25)
> I am arranging for the 74 bears. However, it will be rather short notice, and
> people are the best bait, so I am thinking of using IE developers,
....
> Also running into issues with PETA.
OS: Windows XP → BeOS
Hardware: Other → PocketPC
Damn bears are messing with the OS/Platform fields. This is your last warning, Snuggles!
OS: BeOS → Windows XP
Hardware: PocketPC → Other
(In reply to comment #113)
> Damn bears are messing with the OS/Platform fields. This is your last warning,
> Snuggles!

Actually, this problem *did* appear on BeOS/PocketPC for me.

Updated

9 years ago
Keywords: fixed1.9.0.2 → verified1.9.0.2
(In reply to comment #112)
> Does the issue with PETA arise from using the bears, generally, or has it been
> found that feeding them IE developers is bad for the system?
> 
> > Also running into issues with PETA.
> 
From using bears. They said, "Use the IE devs, it will reduce world population."

Comment 116

9 years ago
So, we can use the IE devs to bait the bears, but we can't use the bears.... That pretty much breaks this solution.
  (thankfully a better (open course) solution was implemented).
(In reply to comment #116)
> So, we can use the IE devs to bait the bears, but we can't use the bears....
> That pretty much breaks this solution.
>   (thankfully a better (open course) solution was implemented).
> 

That is the mindset of PETA.

Comment 118

9 years ago
(In reply to comment #91)
> Eh, Microsoft gave cakes to lure us into a sense of false security, and now see
> what happens!  They'll continue giving cakes and act like none of this is there
> fault. 

Those weren't cakes, they were tracking cookies.
Workaround: http://support.mozilla.com/en-US/kb/Cookies#Accepting_and_Blocking_Cookies
Product: mozilla.org → Mozilla Corporation
Group: mozilla-corporation-confidential
Group: mozilla-corporation-confidential
Component: Facilities Management → Miscellaneous
Flags: blocking1.9.0.2+
Product: Mozilla Corporation → mozilla.org
QA Contact: facilities-mgmt → miscellaneous

Comment 119

6 years ago
Created attachment 600715 [details]
This device will instantaneously transport us from one destination to another

GUYS GUYS GUYS!  My friend invented a teleporter so we don't even need the bears

Updated

6 years ago
Attachment #600715 - Attachment is patch: false

Updated

6 years ago
Attachment #600715 - Attachment mime type: text/plain → image/jpeg

Comment 120

6 years ago
I think that some commenters were stuck in 2008.

Comment 121

6 years ago
I think that that fix has bugs of it's own (fly in the ointment, so to speak) which could cause serious regression problems.

Comment 122

4 years ago
If anyone would like to share their memories of the landslide at the Summit in 2008, please comment on the history blog post at:

https://blog.mozilla.org/community/2013/07/22/milestone-landslide-at-the-mozilla-summit-in-whistler/

This is part of an effort for the 2013 Summit to create a history of Mozilla that is told by Mozillians.
You need to log in before you can comment on or make changes to this bug.