Get Thunderbird L10N builds working on comm-central

RESOLVED FIXED in Thunderbird 3.0a3

Status

Thunderbird
Build Config
P1
normal
RESOLVED FIXED
9 years ago
7 years ago

People

(Reporter: standard8, Assigned: gozer)

Tracking

Trunk
Thunderbird 3.0a3
Dependency tree / graph
Bug Flags:
blocking-thunderbird3.0b1 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [looking promising])

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Bug 434289 is working on setting up L10N builds for mozilla-central. I'm going to track the work that we need to do on Thunderbird here.

Some of this will be tracking what Robert is doing for SeaMonkey in bug 446119.
Flags: blocking-thunderbird3.0b1?
(Reporter)

Updated

9 years ago
Depends on: 449367
(Reporter)

Comment 1

9 years ago
Created attachment 332685 [details] [diff] [review]
[checked in] Fix paths in mail/locales/Makefile.in

This patch does what Robert did for SM in bug 446119 - corrects some paths in the locales Makefile.in so that "make langpack-ab-CD" (with other appropriate set up) will work correctly in comm-central.
Attachment #332685 - Flags: review?(mkmelin+mozilla)

Comment 2

9 years ago
Comment on attachment 332685 [details] [diff] [review]
[checked in] Fix paths in mail/locales/Makefile.in

Looks good to me, fwiw.
Attachment #332685 - Flags: review+
(Reporter)

Comment 3

9 years ago
As we are releasing l10n builds with alpha 2, we definitely need to be able to do so again with beta 1.
Flags: blocking-thunderbird3.0b1? → blocking-thunderbird3.0b1+
(Reporter)

Updated

9 years ago
Attachment #332685 - Flags: review?(mkmelin+mozilla) → review?(bienvenu)

Updated

9 years ago
Attachment #332685 - Flags: review?(bienvenu) → review+
(Reporter)

Comment 4

9 years ago
Comment on attachment 332685 [details] [diff] [review]
[checked in] Fix paths in mail/locales/Makefile.in

Checked in, changeset id: 81:2e80f8bdd1cc
Attachment #332685 - Attachment description: Fix paths in mail/locales/Makefile.in → [checked in] Fix paths in mail/locales/Makefile.in
(Reporter)

Updated

9 years ago
Priority: -- → P1
(Reporter)

Updated

9 years ago
Assignee: bugzilla → gozer
Switching for b1 flags to target milestones, to avoid flag churn.
Target Milestone: --- → Thunderbird 3.0b1
(Assignee)

Updated

9 years ago
Duplicate of this bug: 453340

Updated

9 years ago
Whiteboard: [looking promising]
(Assignee)

Comment 7

9 years ago
Got the first successful l10n build up on ftp.mozilla.org : http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-central/thunderbird-3.0b1pre.ga-IE.win32.installer.exe

More should trickle in as l10n repos are changing, and the real churn will be tonight, after the nightlies. I'll wait and see how that goes.
(Reporter)

Comment 8

9 years ago
So we've had some more popup overnight. What I've just realised is that they are going into:

ftp://ftp.mozilla.org/pub/thunderbird/nightly/latest-comm-central/

and not:

ftp://ftp.mozilla.org/pub/thunderbird/nightly/latest-trunk-l10n/

which was the original location, is there any way we could fix that? There we're keeping things in the same structure.

Comment 9

9 years ago
latest-trunk* should not be used any more for uploading, but it should be easy to make it latest-comm-central-l10n and symlink latest-trunk-l10n to it (AFAIK, this is what FF does).
gozer, this would mean changing self.mainBranch to self.localesBranch in the MozillaStageUpload step of mozl10n.py.

I did make the upload fo to latest-comm-central as SeaMonkey always had them in latest-trunk and I don't really know why L10n files should be treated so differently and go into a separate directory when they are equal in what code the contain and are equal in releases. I think though that whatever way we go, we should be consistent at least between SeaMonkey and Thunderbird as to how we treat that.
(Assignee)

Comment 10

9 years ago
I've moved latest-trunk-l10n content to the newly created latest-comm-central-l10n directory, and made the suggested symlink
(Assignee)

Comment 11

9 years ago
Changed where the l10n builds are uploaded, as suggested in comment #9

changeset:   290:36e699d20f74
tag:         tip
user:        Philippe M. Chiasson <gozer@mozillamessaging.com>
date:        Fri Sep 05 12:03:55 2008 -0400
summary:     Bug 449202. Upload l10n builds to comm-central-l10n/
(Assignee)

Comment 12

9 years ago
We have now localized builds in quite a few locales:
de
en-GB
en-US
es-AR
es-ES
fr
ga-IE
it
lt
sk

The other ones are failing because they have not yet adjusted to the change in bug 450257.

Apart from that, it's now working as expected.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.