Add a "Tools > Downloads" menu item and Ctrl+J to open the Download Manager window (saved files are completely inaccessible via UI)

RESOLVED FIXED in Thunderbird 3.1a1

Status

Thunderbird
Mail Window Front End
RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: Brian S. Craigie, Assigned: Phil Lacy)

Tracking

unspecified
Thunderbird 3.1a1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 9 obsolete attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16
Build Identifier: 

Request for enhancement: To make it easy to access the files that have just been saved I would like to request to have a menu option to turn on the Download Manager window.  This would mirror the way Firefox works.

Reproducible: Always

Steps to Reproduce:
1. Locate an email with an attachment
2 [review]. Save the attachment
3 [review]. Download manager window opens and then disappears.
Actual Results:  
Now try to find the download manager window

Expected Results:  
Have a menu option to show the download manager window like in Firefox where it's on Tools -> Downloads.

This is related to 408647 and had been filed as a separate request as per the instructions in that bug (RFE).

Updated

10 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Add a UI option to open the Download Manager window → Add a menu item to open the Download Manager window

Updated

9 years ago
Flags: wanted-thunderbird3+
Duplicate of this bug: 501056
There's currently no way to access the download manager, at all, without changing hidden prefs (cf. bug 408647). I. e. existing functionality is inaccessible via the UI. This isn't just enhancement --> bug.

Is it very hard to add "Downloads" menu option to the Tools menu? Say more than 5 lines of code?
Severity: enhancement → normal
Summary: Add a menu item to open the Download Manager window → Add a "Tools > Downloads" menu item to open the Download Manager window (download manager is completely inaccessible via UI)
Don't forget to add a keyboard shortcut key for this as well, preferrably ctrl+j as in FF, if that's still available.
(Assignee)

Comment 4

9 years ago
Created attachment 400435 [details] [diff] [review]
bring up thunderbird's own download window

works on windows XP.
Assignee: nobody → philbaseless-firefox
Status: NEW → ASSIGNED
Attachment #400435 - Flags: review?(mkmelin+mozilla)

Comment 5

9 years ago
Comment on attachment 400435 [details] [diff] [review]
bring up thunderbird's own download window

>+  <key id="key_downloads"
>+       key="&downloads.key;"
>+       modifiers="accel"
>+       oncommand="Components.classes['@mozilla.org/download-manager-ui;1']
>+                            .getService(Components.interfaces.nsIDownloadManagerUI)
>+                            .show(window);"/>

Please put that in a function in appropriate js file (mailcore.js?)
And use that function in the other place too.


>+<!ENTITY downloads.tooltip "Display the progress of ongoing downloads">

Unused, no?

Should also get clarkbw to ui-r this. Seems to work fine though!

Comment 6

9 years ago
Comment on attachment 400435 [details] [diff] [review]
bring up thunderbird's own download window

Minusing per above
Attachment #400435 - Flags: review?(mkmelin+mozilla) → review-
Adding bryan to the list, for his ui input.  I sure want it =)
Seems like a good addition except that we should call it something other than "downloads".  I worry that most users don't think of their attachments as downloading as much as saving...  Something as simple as "Attachments" or "Saved Attachments" might work.  Any other ideas?
Is "Saved Attachments" actually accurate, or do we mean "Saved Or Opened Attachments," or do we mean "Saved Or Opened Attachments That Took More Than 100 Milliseconds And Thus None Of Yours At All Ever, Dirty POP User"?
(Assignee)

Comment 10

9 years ago
I save mp3 or other files that are on an RSS feeds which aren't really attachments.

Also I'd like to someday utilize this window in drag and drop which currently is kind of whacky with large dnd's.

I say "Saved Files", dnd or save of complete messages should go into here.
(Assignee)

Comment 11

9 years ago
Also the list of downloads doesn't survive the app like FF. So someone needs to make that particular config setting 2 by default and change the docs

https://developer.mozilla.org/en/Download_Manager_preferences

browser.download.manager.retention
philor: how realistic is it to get POP downloaded attachments there too?
Been so long since the last go-round, I forgot which way the problem works: we already do put "downloaded" POP attachments there - when you double-click "don'tletpatfindoutaboutthis.foo" and open it in the Foo application, we already do put it in the download manager and keep it there through the session, without ever showing the window at all (and I'd forgotten that whether or not to show was no longer under our control - there used to be a pref for minimum dl time before it's shown, but that's gone).

In the current scheme that's a problem only during the current session (since we clear on quit) and only if later in the session Pat saves a remote attachment or link that's slow enough to show the window; in the proposed scheme it's a problem because you might never know that attachments wind up there, until Pat goes to Tools - Foopied Thingies and finds all the attachments you've ever opened since the dawn of time, without having once saved one.

We can solve the "you have no idea opening an attachment lists it in the 'download' manager" thing by setting browser.download.manager.closeWhenDone to false, which then opens it (or maybe more accurately, doesn't close it in the same millisecond it opens), but that's massively annoying since it will getAttention to tell you that your millisecond-long download has finished.
(In reply to comment #8)
> Seems like a good addition except that we should call it something other than
> "downloads".  I worry that most users don't think of their attachments as
> downloading as much as saving...  Something as simple as "Attachments" or
> "Saved Attachments" might work.  Any other ideas?

We've also the possibility that extensions will use it with content tabs to save files...
(Assignee)

Comment 15

9 years ago
ok, beside adding the function, I'll change the title of the window to "Saved Files" or is there still discussion going on.
Attachments that you just open for viewing are only temporarily saved in some temp folder. Maybe they should even be deleted by TB after use. Therefore, "Saved Files" might create the wrong impression that the files in download manager have all been safely saved for later use. But it might be ok to call them "saved files" anyway. I think menu caption and window title should be the same. Maybe "saved files" is actually quite good.
(Assignee)

Comment 17

9 years ago
(In reply to comment #16)
> temp folder. Maybe they should even be deleted by TB after use. Therefore,

lets not complicate it in this bug. So far this is pretty much FF code and has the advantage of UI consistentcy and familiarity.
If the file is non existent the rt click context menu is grayed out appropriately.

> same. Maybe "saved files" is actually quite good.

Waiting for Bryan to decide then. I'd still say the familiarity of FF's 'Downloads' title is a UI plus.
Phil, I'm comfortable with "Saved Files"

Comment 19

9 years ago
With string freeze coming up tuesday time is running short on getting this in for tb3. Got an updated patch?
(Assignee)

Comment 20

9 years ago
Created attachment 403180 [details] [diff] [review]
per review comments

the files have lots of untrimmed lines and openActivityMgr() needs reformatting.

Let me know if you want me to fix those nits.
Attachment #400435 - Attachment is obsolete: true
Attachment #403180 - Flags: review?(mkmelin+mozilla)
(Assignee)

Comment 21

9 years ago
Created attachment 403186 [details] [diff] [review]
'd' access key was taken using 'l'

see further comments on previous submitted patch
Attachment #403180 - Attachment is obsolete: true
Attachment #403186 - Flags: review?(mkmelin+mozilla)
Attachment #403180 - Flags: review?(mkmelin+mozilla)
+<!ENTITY savedFiles.label "Saved Files">
+<!ENTITY savedFiles.accesskey "l">

Why not take "s" (initial letter of *S*aved files) as access key? It's still free, and much more intuitive (for English, that is).

Did you add a keyboard shortcut command for showing Download / saved files manager? Ctrl+J is still available, and would match existing Firefox shortcut for download manager.
http://www.mozilla.org/support/thunderbird/keyboard#
(Assignee)

Comment 23

9 years ago
(In reply to comment #22)
> Why not take "s" (initial letter of *S*aved files) as access key? It's still
> free, and much more intuitive (for English, that is).

taken by account settings menu

> 
> Did you add a keyboard shortcut command for showing Download / saved files
> manager? Ctrl+J is still available, and would match existing Firefox shortcut
> for download manager.
> http://www.mozilla.org/support/thunderbird/keyboard#

yes, shortcut is the next line down noted as '.key'
(Assignee)

Updated

9 years ago
Attachment #403186 - Attachment description: 'd' access key was taken using 'l' → 'd' access key was taken using 'l' see further comments on previous submitted patch

Comment 24

9 years ago
Comment on attachment 403186 [details] [diff] [review]
'd' access key was taken using 'l'

see further comments on previous submitted patch

>diff --git a/mail/base/content/mailCore.js b/mail/base/content/mailCore.js
>--- a/mail/base/content/mailCore.js
>+++ b/mail/base/content/mailCore.js
>@@ -290,16 +290,34 @@ function openAddonsMgr()
> }
> 
> function openActivityMgr()
> {
>   Components.classes['@mozilla.org/activity-manager-ui;1'].
>     getService(Components.interfaces.nsIActivityManagerUI).show(window);
> }
> 
>+function openSavedFilesWnd()
>+{
>+  Components.classes['@mozilla.org/download-manager-ui;1']
>+            .getService(Components.interfaces.nsIDownloadManagerUI)
>+            .show(window);
>+  setTimeout(changeTitle, 5);

Why the timeout? And if 5ms is ok isn't 0 ok too?

Anyway, this isn't really /the/ way to change the title. You should overlay the download dialog with a different title. Something like https://bug509044.bugzilla.mozilla.org/attachment.cgi?id=403113 but overlaying the actual window.

>+# savedFiles UI window. Same as FireFox downloads window

Nit: Firefox, single capital f
(Assignee)

Comment 25

9 years ago
(In reply to comment #24)
> Why the timeout? And if 5ms is ok isn't 0 ok too?

show() returns before window gets created. 1ms worked but I didn't know if other systems would work the same, so it's just padding.

> Anyway, this isn't really /the/ way to change the title. You should overlay the

I figured there must be a trick with overlay but I couldn't find anyone this weekend on IRC who knew what I wanted and the docs on overlay indicated manifest files were necessary. I'll look into your example.
(Assignee)

Comment 26

9 years ago
Created attachment 404171 [details] [diff] [review]
changed to overlay

changed to overlay. thanks for review.
Attachment #403186 - Attachment is obsolete: true
Attachment #404171 - Flags: review?(mkmelin+mozilla)
Attachment #403186 - Flags: review?(mkmelin+mozilla)

Comment 27

9 years ago
Comment on attachment 404171 [details] [diff] [review]
changed to overlay

> toolkit.jar:
> % overlay chrome://global/content/customizeToolbar.xul chrome://messenger/content/customizeToolbarOverlay.xul
>+% overlay chrome://mozapps/content/downloads/downloads.xul chrome://messenger/content/downloadsOverlay.xul

It's probably best to make the scheme match what you override, i.e. chrome://messenger/content/downloads/downloadsOverlay.xul

While it's just one string, i think also savedFiles.title should be in a downloadsOverlay.dtd
As such it's an l10n bug.  As we're past string freeze, that can't land until branch w/o a strong claim.  If there was a version of this patch that didn't require a new string, we could take it.
Whiteboard: [has l10n impact]
(Assignee)

Comment 29

9 years ago
the browser.dtd has the menu labels and access key but I don't see where we use that and I'm not sure how to incorporate it since it has other strings that may be named in other dtd files. Any suggestion on using the browser.dtd?
(In reply to comment #29)
> the browser.dtd has the menu labels and access key but I don't see where we use
> that and I'm not sure how to incorporate it since it has other strings that may
> be named in other dtd files. Any suggestion on using the browser.dtd?

We can't. browser.dtd is part of Firefox specific code (it is in mozilla/browser) and as such we don't touch or package those files.
(Assignee)

Comment 31

9 years ago
Created attachment 404436 [details] [diff] [review]
patch with no strings

this is same as Firefox version and uses the browser.dtd strings. We can customize TB version after branch.

But please review consequences of bringing in browser.dtd. I don't know what problems might happen with strings that are the same in our other dtd files used.
Attachment #404171 - Attachment is obsolete: true
Attachment #404436 - Flags: review?(mkmelin+mozilla)
Attachment #404171 - Flags: review?(mkmelin+mozilla)
(Assignee)

Updated

9 years ago
Attachment #404436 - Flags: review?(mkmelin+mozilla)
(Assignee)

Comment 32

9 years ago
Comment on attachment 404436 [details] [diff] [review]
patch with no strings

sorry didn't have the comment when I uploaded the patch. I'll remove flag
(Assignee)

Comment 33

9 years ago
Comment on attachment 404436 [details] [diff] [review]
patch with no strings

can't use browser strings
Attachment #404436 - Attachment is obsolete: true
(Assignee)

Comment 34

9 years ago
Created attachment 406841 [details] [diff] [review]
with with overlay files

changed files to more relevant location in jar and added separate dtd file. Please check the files are in the right tree. I'm not sure if they need to be moved or if review comment was only for chrome:// location.
Attachment #406841 - Flags: review?(mkmelin+mozilla)
Flags: wanted-thunderbird3+
Target Milestone: --- → Thunderbird 3.1a1

Comment 35

9 years ago
Created attachment 406931 [details] [diff] [review]
reviewed fix

I guess the downloads/ mapping idea wasn't all that great. I originally meant the whole dir structure should be mapped over... but maybe this is better after all. Also made you the initial developer of the code.
Attachment #406841 - Attachment is obsolete: true
Attachment #406931 - Flags: review+
Attachment #406841 - Flags: review?(mkmelin+mozilla)

Updated

9 years ago
Attachment #406931 - Flags: review?(philbaseless-firefox)

Comment 36

9 years ago
Comment on attachment 406931 [details] [diff] [review]
reviewed fix

If this works for you, also get ui-r
(Assignee)

Updated

9 years ago
Attachment #406931 - Flags: ui-review?(clarkbw)
Attachment #406931 - Flags: review?(philbaseless-firefox)
Attachment #406931 - Flags: review+
(Assignee)

Comment 37

9 years ago
Comment on attachment 406931 [details] [diff] [review]
reviewed fix

thanks for review. Let me know how to flag it for checkin with the string freeze and all.
(In reply to comment #37)
> (From update of attachment 406931 [details] [diff] [review])
> thanks for review. Let me know how to flag it for checkin with the string
> freeze and all.

I've added [needs branch] as a flag as it won't be until Thursday that we officially branch. After we've fully branched, add checkin-needed and a note in the whiteboard that it is for trunk only.
Whiteboard: [has l10n impact] → [has l10n impact][needs branch]

Comment 39

9 years ago
Came to mind, perhaps the menu item should be above Add-ons, to match ff? Possibly with a separator above.
(Assignee)

Comment 40

9 years ago
Created attachment 407405 [details] [diff] [review]
changed layout look

changed tools location, also have a screen shot.
above separator will not be in mac.
Attachment #406931 - Attachment is obsolete: true
Attachment #407405 - Flags: ui-review?(clarkbw)
Attachment #407405 - Flags: review?(mkmelin+mozilla)
Attachment #406931 - Flags: ui-review?(clarkbw)
(Assignee)

Comment 41

9 years ago
Created attachment 407406 [details]
layout picture
(Assignee)

Comment 42

9 years ago
Comment on attachment 407405 [details] [diff] [review]
changed layout look

forgot to make Magnus changes on chrome location and author note. I'll wait till this is ok'd.

Comment 43

9 years ago
Comment on attachment 407405 [details] [diff] [review]
changed layout look

Sure, but don't forget to base it on the other patch
Attachment #407405 - Flags: review?(mkmelin+mozilla) → review+
Attachment #407405 - Flags: ui-review?(clarkbw) → ui-review+
Comment on attachment 407405 [details] [diff] [review]
changed layout look

looks ok to me.  thanks for the screenshot.
(Assignee)

Comment 45

9 years ago
Created attachment 407866 [details] [diff] [review]
ready for checkin
Attachment #407405 - Attachment is obsolete: true
(Assignee)

Comment 46

9 years ago
Comment on attachment 407866 [details] [diff] [review]
ready for checkin

forward mkmelin+mozilla=r+
clarkbw=r+
Attachment #407866 - Flags: review+
(Assignee)

Comment 47

9 years ago
Created attachment 412352 [details] [diff] [review]
trunk-ready

forward +=mkmelin ui+=clarkbw
Attachment #407866 - Attachment is obsolete: true
Attachment #412352 - Flags: ui-review+
Attachment #412352 - Flags: review+
(Assignee)

Updated

9 years ago
Keywords: checkin-needed
Whiteboard: [has l10n impact][needs branch] → [has l10n impact][needs branch][for trunk only]
Checked in: http://hg.mozilla.org/comm-central/rev/c44932faa22f
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [has l10n impact][needs branch][for trunk only]
(Reporter)

Comment 49

9 years ago
Thank you.

I still don't see the menu option in Thunderbird 3.  Where is it, or how do I add it?

Thanks

Brian
(In reply to comment #49)
> I still don't see the menu option in Thunderbird 3.  Where is it, or how do I
> add it?

The patch was too late to be included in Thunderbird 3 (as it affected strings and the freeze date is earlier in that case) and therefore the menu option will be available in Thunderbird 3.1.
Summary: Add a "Tools > Downloads" menu item to open the Download Manager window (download manager is completely inaccessible via UI) → Add a "Tools > Downloads" menu item and Ctrl+J to open the Download Manager window (saved files are completely inaccessible via UI)
Duplicate of this bug: 551464
Duplicate of this bug: 574436
You need to log in before you can comment on or make changes to this bug.