Closed Bug 454810 Opened 12 years ago Closed 12 years ago

theme the "browser tools" section

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set
normal

Tracking

(fennec1.0+)

VERIFIED FIXED
fennec1.0a2
Tracking Status
fennec 1.0+ ---

People

(Reporter: madhava, Assigned: mfinkle)

References

Details

(Keywords: meta, uiwanted)

Attachments

(2 files)

The Browser Tools section of the UI (home to add-ons, prefs, and downloads) should be themed.  Attached are sliced images for the buttons and the frame around the individual sections.
Whiteboard: UI polish
Assignee: nobody → mark.finkle
Duplicate of this bug: 456061
Depends on: 456645
Depends on: 436077
This patch adds the code needed to theme the buttons and background of the tools screen. It does *not* theme the actual tool panels. Those are not completely ready to land and should be done individually.

This patch adds a "radio" like behavior to the buttons to indicate which tool panel is active.

Requesting review since it would be very nice to land part of a themed tool panel instead of having no theme at all.

The only issue with this patch is the background gradient. The "glare" strip extends below the corresponding "glare" strip in the browser navtoolbar. Madhava is aware and thinking about a solution.
Attachment #340695 - Flags: review?(gavin.sharp)
Attachment #340695 - Flags: review?(gavin.sharp) → review+
landed this unbitrotted patch

http://hg.mozilla.org/mobile-browser/rev/0df6af453de5

I won't mark this bug FIXED yet. During the unbitrotting, another button was adding to the browser tools: shortcuts

Madhava, we need an image added to panel_buttons.png to support it.
Keywords: uiwanted
Whiteboard: UI polish
Depends on: 474480
Depends on: 474492
Depends on: 474496
Blocks: 477628
tracking-fennec: --- → 1.0+
Keywords: meta
Not sure if shortcuts will ship with fennec or as an extension. Marking fixed
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
No longer depends on: 474496
verified as fixed...great job on the new theme work guys
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.