Closed Bug 457186 Opened 13 years ago Closed 13 years ago

Prepare Thunderbird 3 Alpha 3 Release Notes

Categories

(www.mozilla.org Graveyard :: Thunderbird, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: standard8, Assigned: standard8)

References

Details

I have started preparing the release notes, as I get things up I'll post them here. Please ensure any bugs that should be referenced on the release notes have the relnote keyword.
Flags: blocking-thunderbird3+
(wording not polished)

* Thunderbird 3b1 will have problems with mail servers which use self-signed certificates.  There are workarounds available for some situations (point to web page explaining it), but not for wildcard self-signed certs or certs which don't match the domain of the mail servers.  This will be addressed in subsequent releases.

* message syncing for imap folders to allow for faster message loading, and better offline operation.  Needs to be enabled per folder, or for all folders in an account via Account Settings / Sync & ... preferences.
Bug #430614 [GSoC] Thunderbird integration into Windows Vista/Windows Search indexer

On first start of Beta 1 on a Vista system an Installer prompt for indexing by Vista will happen.
I have now put the first version of the release notes on the staging site at: 

http://stage.mozillamessaging.com/en-US/thunderbird/early_releases/

(See the Thunderbird 3 beta 1 link)

Things I've still got to do:

* Fix Release Dates
* Release Announcement (or just use the 3.0b1 index page?)
* Update file sizes of builds for l10n, and final list of builds (behind the scenes item, in case we use it later)
* Installation directory check - I'm waiting for the dry run builds to check what happens here.
* Early Releases page needs text fixing as it references Shredder where we don't want to.

Other Thoughts:

- I'm tempted to entirely drop the links to Shredder Alpha 1 & 2 builds, and just have links to the release notes. We could update the download links in the release notes just to point to ftp site, as old releases.

- The new downloads page is meant to be updated for each early release as we go. Hence we can re-use it for beta 2 etc. The links are automatically generated, we just have to fill in a table of locales versus file sizes (the files sizes are for download buttons that I expect we may get later).

- The http://stage.mozillamessaging.com/en-US/thunderbird/3.0b1/ page (now I've written it) feels more like a beta release announcement page - should I just turn it into the news page that will announce the release?

See bug 430762 for the start page info.
Needs some spellcheck for WRONG word useage, ex: 'Mew Features' should be New ...

Redundant word use is not best grammar. Suggest 'improvements to improve' be revised to 'improvements to refine'.

No warnings of known issues such as Davids remarks about Certs.  I see value in such notes to reduce filing of duplicate bugs by those who would think the issues were fixed if not restated in the notes. 

" Other Thoughts:

- I'm tempted to entirely drop the links to Shredder Alpha 1 & 2 builds, and
just have links to the release notes. We could update the download links in the
release notes just to point to ftp site, as old releases."

I assume this quote refers to the "Early Releases" page. If so, I agree, that would clean up that page nicely
FWIW, list of confirmed trunk regressions since 500 days http://tinyurl.com/3gqz5l  - I don't see anything on the list that bears adding to the release notes except perhaps bug 455229 Import from Outlook Express fails to import messages
(In reply to comment #5)
> FWIW, list of confirmed trunk regressions since 500 days
> http://tinyurl.com/3gqz5l  - I don't see anything on the list that bears adding
> to the release notes except perhaps bug 455229 Import from Outlook Express
> fails to import messages

Importing from Outlook (Express) has been having its fair share of problems for quite some time, I believe.
Summary: Prepare Thunderbird 3 Beta 1 Release Notes → Prepare Thunderbird 3 Alpha 3 Release Notes
I should have mentioned, per status meeting tonight, we're now renaming beta 1 to alpha 3 see http://weblogs.mozillazine.org/dmose/archives/2008/09/thunderbird_30b1_renamed_to_30.html for more info.
(In reply to comment #4)
> No warnings of known issues such as Davids remarks about Certs.  I see value in
> such notes to reduce filing of duplicate bugs by those who would think the
> issues were fixed if not restated in the notes. 

I think you're commenting about the http://stage.mozillamessaging.com/en-US/thunderbird/3.0a3/ page. If so, I've extended the paragraph about the release notes to reference the known issues on my local copy, I'll push a new version later today.
I've done a set of updates today. The main ones are the beta 1 to alpha 3 transition.

I've got rid of the old download links on the early releases page, the older release notes now direct the user to the current downloads page (for the latest early release). Hence we won't need to worry about maintaining old links.

I have also done some changes on the What's New section, and the Installing section in the release notes. The Installing section changes were because the latest version of Shredder doesn't install over the top of Thunderbird on Windows or Mac (and linux it depends on where you extract it).

This brings the currently list of todo to:

# Release Dates
# Release Announcement (or just use the 3.0b1 index page?)
# Update file sizes of builds for l10n, and final list of builds.
# Update bug list links.
Minor glitch in release notes FAQ #5

Where's the Shredder Alpha 3 source code?
The latest development code can be obtained by cvs. 

Is not Shredder 3.0a3 in the Hg comm-central repository?
"This is part of a series of improvements to refine the message reading experience; the first stage bringing email controls closer to area in which the user is operating"  might read better as 

- This is the first stage of a series of ...; the first stage brings email controls closer to the area in which the user is operating
I've addressed comments 10 & 11 and updated the staging site. I also added a few links to make getting to the known issues a bit easier and fixed a couple of formatting issues.
good changes. 

"There were over XXX bug fixed" needs completion. 

Do we want link to gary's "fixed" lists?  Which would be
 http://www.rumblingedge.com/2008/08/17/2008-08-16-thunderbird-trunk-builds/
 http://www.rumblingedge.com/2008/08/30/2008-08-30-thunderbird-trunk-builds/
 http://www.rumblingedge.com/2008/09/11/2008-09-11-thunderbird-trunk-builds/
 http://www.rumblingedge.com/2008/09/21/2008-09-21-thunderbird-trunk-builds/
It would be informative without adding labor for us. Plus, it gives deserved exposure to rumbling.


(In reply to comment #6)
> (In reply to comment #5)
> > FWIW, list of confirmed trunk regressions since 500 days
> > http://tinyurl.com/3gqz5l  - I don't see anything on the list that bears adding
> > to the release notes except perhaps bug 455229 Import from Outlook Express
> > fails to import messages
> 
> Importing from Outlook (Express) has been having its fair share of problems for
> quite some time, I believe.

Supposedly bug 455229 is a trunk regression. However, probably only impacts litmus testers running FFT, which I don't expect to see given this is still an alpha release.  

which reminds me, I should probably be including trunk regression queries  http://tinyurl.com/3gqz5l in our instructions to QA testers.
(In reply to comment #13)
> good changes. 
> 
> "There were over XXX bug fixed" needs completion. 
> 
> Do we want link to gary's "fixed" lists?  Which would be
>  http://www.rumblingedge.com/2008/08/17/2008-08-16-thunderbird-trunk-builds/
>  http://www.rumblingedge.com/2008/08/30/2008-08-30-thunderbird-trunk-builds/
>  http://www.rumblingedge.com/2008/09/11/2008-09-11-thunderbird-trunk-builds/
>  http://www.rumblingedge.com/2008/09/21/2008-09-21-thunderbird-trunk-builds/
> It would be informative without adding labor for us. Plus, it gives deserved
> exposure to rumbling.

I have dedicated release note changelog pages (linked to from each release note) since version 1.0.5, more than 3 years ago...

http://www.rumblingedge.com/2005/06/05/thunderbird-release-changelogs/
Also, mozillaZine forums should now redirect here rather than the old link:

http://forums.mozillazine.org/viewforum.php?f=50

(it changed due to the migration to phpBB 3)
I've addressed the last few comments (13-15). The rumbling edge link will be added in a few days once we're a bit closer to the release.

Now up on the staging site. I think these are starting to get towards the final versions now.

http://stage.mozillamessaging.com/en-US/thunderbird/3.0a3/
(In reply to comment #16)
> I've addressed the last few comments (13-15). The rumbling edge link will be
> added in a few days once we're a bit closer to the release.

Done up here: (link URL is fixed; title on actual page is still (not yet) released and will be updated once the actual release is out)

http://www.rumblingedge.com/2008/10/07/shredder-alpha-3-released/
one more nit; we can safely say "more than 250 changes have gone into this release over the previous alpha".
"Integrated Vista Search"

That second line "On first start Windows Vista will prompt to install Thunderbird's indexing system into Windows Vista." is inaccurate. It should read "On first start Thunderbird will prompt to install its indexing system into Windows Vista."
relnote? Bug 455947 - subscribe dialog gives broken expression 

partly for it's severity (it is severe for news ppl) and partly because it normally works on trunk + happened so close to the release
of note, all locales have been at least spot checked, and all PASS
https://wiki.mozilla.org/Thunderbird3/TestResults/Alpha3/L10N
Comments 17 - 19 are now on staging site. Still need to look at comment 20.
I've now fixed comment 20 and pushed it to svn, gozer will hopefully be pushing it to stage later today.

This is now the LAST CALL for any more comments on the release notes. Please get them here by the end of the day if you have any more.
Staging site is now at revision 19040.
(In reply to bug 457709 comment #48)
> spelling nit on download page, last word of "It is being made avaiable"
> 
> otherwise looks good

Fixed, will be pushed to staging when staging is updated to 19056.
Alpha 3 is now officially released. This bug is therefore fixed.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Product: Websites → www.mozilla.org
Product: www.mozilla.org → www.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.