Closed Bug 430762 Opened 12 years ago Closed 11 years ago

Start page for Alpha/Beta builds

Categories

(Thunderbird :: Mail Window Front End, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0a3

People

(Reporter: ronkillmer1, Assigned: rebron)

References

Details

(Whiteboard: [post freeze work remaining][code and prototype pages ready])

Attachments

(3 files, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: 

This is a UI issue for users who will be testing the Alpha and Beta builds.  The page concept is to provide links to feedback and trouble shooting resources in place of the normal Welcome content. If a codename is assigned the artwork should coordinate. A link to MozillaZine KB topics and the Tb Forum.  The newsgroups for discussion and feedback. The Bugzilla reporting Wizard. Any other relevant links.

Reproducible: Always

Steps to Reproduce:
1. 
2.
3.
Actual Results:  
If the test build is started with the stock Startup link the standard Welcom to Thunderbird page will display in the Message Pane.

Expected Results:  
On first startup the Start Page is a Thank You for helping test this Alpha build. These are resources that can be useful for feedback, etc.

The assumption is We will have new people participating for the first time in testing and they will not be familiar with where some of the resources are.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: wanted-thunderbird3.0a2?
Does anyone know where the start pages are in the tree?
This is the URL of the Tb2 start page:
http://en-US.www.mozilla.com/en-US/thunderbird/2.0.0.12/start/
I consists of one XHTML, One CSS, and Three JPEG files.

The Start Page of the Tb 3.0a1Pre nightly builds is an internal chrome URI:
chrome://messenger/content/start.xhtml
I believe it is in the messanger.jar located in program folder/chrome; however that relates to the tree.
Where they are is a rather slippery question, depending on what level you mean. 

The default for the pref mailnews.start_page.url is branded, so for official branding http://mxr.mozilla.org/mozilla/source/other-licenses/branding/thunderbird/thunderbird-branding.js#2 on the trunk, http://mxr.mozilla.org/mozilla1.8/source/other-licenses/branding/thunderbird/thunderbird-branding.js#2 for the remote branch start page.

Then there's http://mxr.mozilla.org/mozilla/source/mail/base/content/mailWindow.js#439 - if you start up offline (and if my memory serves, we'll detect that you're offline on at least two, if not all three, platforms), then no matter whether your start page is local or remote, default or your own, the start page is about:blank.

If you're online, then the source either lives at http://svn.mozilla.org/projects/mozilla.com/trunk/en-US/thunderbird/2.0.0.12/start/index.html or at http://mxr.mozilla.org/mozilla/source/mail/base/content/start.xhtml depending.
So, if you use the preview pane at all, then
chrome://messenger/content/start.xhtm will show a very outdated page whose links
BTW are redirected to mozzilazine knowledgebase pages.

At one time there was a "splash screen" that showed at startup, maybe in lew of
a remote sourced page, we could redo the chrome page, and re-invent the splash
screen embedding it at chrome://messenger/content/start.xhtm

At the very least we should add to the links and reference something more current.
 
Here is a page that needs review before it is linked through the proposed Alpha 
Start Page.
http://www.mozilla.org/support/thunderbird/bugs
Since there is no longer a Mozilla Suite, I wonder about the references to Mozilla in the pages content. It is a decent Bug Reporting guide for a new tester to read before visiting Bugzilla.
In the Tb2 Start page the link 'Mozilla' is to this URL:
http://en-us.www.mozilla.com/en-US/firefox/about/
Where the 'Community' link leads to this page.
http://en-us.www.mozilla.com/en-US/firefox/community/

This comment is more about developing a Mozilla Messaging themed variant on these  pages as elements of Our Community website. We can strengthen our identity as the team building the Thunderbird trademark.
I suspect I own this bug for now.
Assignee: nobody → david.ascher
Flags: wanted-thunderbird3.0a2? → wanted-thunderbird3.0a2+
Depends on: 431917
Initial draft of hosted start page for Shredder a1 is in SVN:

http://svn.mozilla.org/projects/mozillamessaging.com/trunk/en-US/thunderbird/3.0a1/start/index.php

You can see it on reed's staging server:

http://messaging-trunk.localgho.st/en-US/thunderbird/3.0a1/start/

(username: messaging, pw: m355)


Feedback welcome.
"developer preview release" should just be "developer preview".

on "our bug server" should be on "Bugzilla".

it's mozillaZine not Mozillazine.

Should be mozillaZine's forums for -link-Thunderbird Builds-end link-.

Change the link to Thunderbird Builds forum to end with "f=29" , everything including and after "&" is redundant.
Since we can subscribe by news protocol to */mozilla.feedback.thunderbird.prerelease I propose that it also be included as a discussion destination.  If that is also mirrored by Mailman to a mailing list, these choices will offer alternatives to those who do not like a web forum format.

I know I have bashed the Hendrix interface to the news group, but direct subscription permits bypassing that web interface.  Plus we can adequately filter news to not show the [Hendrix] postings. This can facilitate Shredder dialog without annoying users of Thunderbird support or dev.apps groups who use the mailing list. 
After viewing the Release Notes page preview I suggest the banner head from that page be used for the Shredder Start Page header.
(In reply to comment #9)
> on "our bug server" should be on "Bugzilla".

Or "in our bug tracker".


So, what we need to know is:

* What will be the URL on the mozillamessaging.com?
* Presumably self-built and nightlies/betas will default to that page.
* Do we even want to maintain the old chrome page.

We want this for beta 1.
Flags: blocking-thunderbird3.0b1+
For en-US at least:

* http://www.mozillamessaging.com/en-US/thunderbird/3.0b1/start/ (http://www.mozillamessaging.com/en-US/thunderbird/3.0a1/start/ is live)

For localized pages, that's still TBD, but I would code it for the structure above, and if we need redirects, we can do that.
 
* yes

* re: chrome pages -- IIRC, there's a special chrome page when Tb is offline, is that right?  Can we use the browser cache instead?
I've just investigated what Firefox does for their start page:

Default Home Pages:

- Minefield (nightly builds): http://www.mozilla.org/projects/minefield/
- Shiretoko (3.1 alphas): http://www.mozilla.org/projects/shiretoko/
- Firefox (official releases + betas): http://__AB_CD__.start2.mozilla.com/firefox?client=firefox-a&rls=__MOZ_DISTRIBUTION_ID_UNQUOTED__:__AB_CD__:official (which redirects to google search)

Welcome Home Page
* Displayed when a fresh profile is first run

- Minefield: http://www.mozilla.org/projects/%APP%/%VERSION%/firstrun/ (actual URL is 404)
- Shiretoko: http://www.mozilla.org/projects/firefox/3.1a1/firstrun/
- Firefox: http://en-us.www.mozilla.com/en-US/firefox/3.0/firstrun/

Override Home Page
* Displayed when the version of the application changes (e.g. upgrades)

- Minefield: http://www.mozilla.org/projects/%APP%/%VERSION%/whatsnew/ (acutal URL is 404)
- Shiretoko: http://www.mozilla.org/projects/firefox/3.1a1/firstrun/
- Firefox: http://en-us.www.mozilla.com/en-US/firefox/3.0/whatsnew/

In Firefox 3, the Welcome and Override pages are the same thing.

Dev Notes: Prefs are named startup.homepage_*_url and browser.startup.homepage

More coming in a mo...
Depends on: 451236
Depends on: 451238
For Thunderbird the start page URLs will be:

- Default start Page: http://live.mozillamessaging.com/%APP%/start?locale=%LOCALE%version=%VERSION%&os=%OS%&buildid=%APPBUILDID%
- Welcome URL (aka first run): http://live.mozillamessaging.com/%APP%/firstrun?locale=%LOCALE%version=%VERSION%&os=%OS%&buildid=%APPBUILDID%
- Override URL (aka whats new): http://live.mozillamessaging.com/%APP%/whatsnew?locale=%LOCALE%version=%VERSION%&os=%OS%&buildid=%APPBUILDID%

The relevant prefs are:

- Default start page: mailnews.start_page.url
- Welcome URL: mailnews.start_page.welcome_url
- Override URL: mailnews.start_page.override_url

Found in the branding files here:

http://mxr.mozilla.org/comm-central/find?text=&kind=text&string=thunderbird-branding.js

What needs doing
----------------

We'd like some help for getting the changes done, here's what needs doing:

1) in mailWindow.js change loadStartPage/startPageUrlPref to work the same way as Firefox.
- I think these are already pretty similar, but certainly need the result passing through the nsIURLFormatter like FF does (see comment 15 for pointers to prefs)

2) Update the preferences, this should probably be done after bug 451236 and bug 451238 OR in time to get this bug fixed by Sept 9th (code freeze for beta 1).
Assignee: david.ascher → nobody
Keywords: helpwanted
Whiteboard: [has plan: comment 16][needs owner]
Blocks: 451246
Depends on: 451247
Depends on: 386853
Depends on: 433630
Bug 433630 doesn't block this, it may block bug 451238.
No longer depends on: 433630
Do we need a Litmus test for smoke testing the links as we go forward?
Switching for b1 flags to target milestones, to avoid flag churn.
Target Milestone: --- → Thunderbird 3.0b1
Assignee: nobody → rebron
Priority: -- → P1
Whiteboard: [has plan: comment 16][needs owner] → [has plan: comment 16]
We can also change the background image for later Betas once we settle on a design for the main web site.
Option 1 looks good for a Tb RC release.  However the unofficial brand for the Alpha/Beta previews is Shredder.

Am upgrading importance to Blocker to be consistent with Flags.
Severity: enhancement → blocker
Version: unspecified → Trunk
I too prefer door #2 (without what's new) for beta. The message needs to focus on articulating feedback.  Release notes can list/point to what's new. 

But for either choice the start page could also list an item of "other ways to help/contribute", to encourage greater participation - which needs to be a constant, gentle message.
I'll update the branding to reflect Shredder.  I was using the Tb 2.0 start page as my template.

I prefer 2 as well.

Links:

Should link for newsgroup be:
 news://news.mozilla.org/mozilla.feedback.thunderbird.prerelease

or:
http://groups.google.com/group/mozilla.feedback.thunderbird/topics

and will also add link to bug filing instructions:
http://developer.mozilla.org/en/Bug_writing_guidelines
(In reply to comment #22)
> Option 1 looks good for a Tb RC release.  However the unofficial brand for the
> Alpha/Beta previews is Shredder.

This is incorrect. Shredder was the unofficial branding in use for ALPHA builds only. For beta builds we will be using the Thunderbird offical branding (in the same manner as firefox releases).

> Am upgrading importance to Blocker to be consistent with Flags.

The importance of a bug is different to the flags. Please read https://bugzilla.mozilla.org/page.cgi?id=fields.html#bug_severity to find out what the importance really relates to.
Severity: blocker → normal
(In reply to comment #24)
> I'll update the branding to reflect Shredder.  I was using the Tb 2.0 start
> page as my template.

See Comment #25 for brand name policy I was not up to date on.
 
> Links:
> 
> Should link for newsgroup be:
>  news://news.mozilla.org/mozilla.feedback.thunderbird.prerelease

This one plus: news://news.mozilla.org.mozilla.support.thunderbird
The support group has a wider audience and is more open to discussion.

To comment #23
I agree that Trunk releases need a focus on the QA mission.  Perhaps a link to Litmus to introduce it's guided testing plan. 

To Comment #25
I overlooked reading Staff Call minuets the past few weeks to catch the Branding decision. The Importance change was a case of second guessing my initial instinct to set normal.
The generic "how to help" links are
https://wiki.mozilla.org/Thunderbird:Testing (not so pretty, but expansive)
and http://www.mozillamessaging.com/en-US/getinvolved/

As for newsgroup, FF strictly speaking does not provide a newsgroup for "user" discussion/assistance:
* there is mozilla.feedback.<something> as a 1-way submission if info - FF alphas point to http://www.mozilla.org/projects/shiretoko/ which submit via hendrix (the html is easy enough to follow)
* afaik don't encourage discussion of alphas in m.support.firefox. not sure about betas

It would be nice to something like http://www.mozilla.org/projects/shiretoko/ for thunderbird alpha/trunk.  

I don't have a strong opinion on utilizing m.support.thunderbird 
- on the plus side non-testing users will see testers getting excited/helping/complaining/etc and maybe get interested themselves
- on the negative side, it could get messy if testers don't clearly identify themselves as not-using-branch-release
Some quick thoughts after a few minutes of reading:

Definitely option 2. What's new should be in release notes or elsewhere, as previously mentioned.

Little nits that don't really matter:
- "Thanks" or "Thank you"?
- "Email" or "email"? (in the main sentence)
- "bugzilla" or "Bugzilla"? (near the end)

Some QA links will be useful too, besides Bugzilla. I think Wayne has mentioned that in comment #27.
3.0b1 flag is going away in favour of 3.0 flag and milestone combination.
Flags: blocking-thunderbird3.0b1+ → blocking-thunderbird3+
(In reply to comment #27)
> The generic "how to help" links are

What about adding a link to Litmus, or should that defer to the Test Day announcement? I prefer the Start Page since the Beta release is a snapshot, then we are back to trunk nightlies. 

> As for newsgroup, FF strictly speaking does not provide a newsgroup for "user"
> discussion/assistance:
> * there is mozilla.feedback.<something> as a 1-way submission if info ->
> hendrix (the html is easy enough to follow)

I see the Hendrix web page as a "Oneway Street" for feedback and its value diminishes from Users not provideing a useful e-mail address for followup. The benefit of a news group is easier followup to begin confirmation of bugs. Providing the Hendrix news interface can fulfill the concept.

> * afaik don't encourage discussion of alphas in m.support.firefox. not sure
> about betas

I agree about Alphas and say yes to Betas, as we are closing in on RC's and release, with approaching closure of the feature set.

> It would be nice to something like http://www.mozilla.org/projects/shiretoko/
> for thunderbird alpha/trunk.  
> 
> I don't have a strong opinion on utilizing m.support.thunderbird 
 
The Fx support group dealt with this all through the Fx B1 to RC2 sequence of testing builds. The worst posters to support tend to be the Google Groupers who post "Twitter" sized questions without details. This is one reason I do not support use of GG for testing feedback.
(In reply to comment #30)
> (In reply to comment #27)
> > The generic "how to help" links are
> 
> What about adding a link to Litmus, or should that defer to the Test Day
> announcement? I prefer the Start Page since the Beta release is a snapshot,
> then we are back to trunk nightlies.

We should not link to Litmus from the start page - certainly in its current state, just looking at it is confusing and there's no clear information there. Its not too bad once the user has decided this is what they want to do, but its not good for semi-random clicking.

We need to keep the start page information/pointers sufficient, but limited. http://www.mozillamessaging.com/en-US/getinvolved/ is a good example for a web page, but way to much for a TB start page IMO.
Since the target audience is all different, the start page for alpha/beta/nightly could be made very different from the release builds IMHO, with more focus on how to get involved and what's going on in the community. (In the spirit of the link from comment 31.)
With the proposed URL format change, we're going need to format the URLs via the url formatter. This code passes the start page URLs through the formatter.

I'll do a separate patch for changing the URLs, but I don't want to push that into hg until we've got some content on the site for nightly builds.
Attachment #339236 - Flags: review?(bienvenu)
Attached patch Change the start page urls. (obsolete) — Splinter Review
This patch will change the urls as has been previous discussed, once we've got the website content up, I'll push it through.
Comment on attachment 339236 [details] [diff] [review]
[checked in] Support URL Pref Formatting.

could you remove the added dump statement before landing?
Attachment #339236 - Flags: review?(bienvenu) → review+
Whiteboard: [has plan: comment 16] → [code ready][waiting final versions]
Comment on attachment 339236 [details] [diff] [review]
[checked in] Support URL Pref Formatting.

Checked in, changeset id: 375:6b07197e218d
Attachment #339236 - Attachment description: Support URL Pref Formatting. → [checked in] Support URL Pref Formatting.
Whiteboard: [code ready][waiting final versions] → [code and prototype pages ready][post freeze work remaining
Whiteboard: [code and prototype pages ready][post freeze work remaining → [code and prototype pages ready][post freeze work remaining]
No longer depends on: 451247
Duplicate of this bug: 451247
Comment on attachment 339237 [details] [diff] [review]
Change the start page urls.

I got review and checked this patch in on bug 451238 (having forgot I posted it here).

Current status is that nightly builds will now point to the new start page on mozillamessaging.com.

This bug will remain open until we've settled on the page for beta 1.
Attachment #339237 - Attachment is obsolete: true
Keywords: helpwanted
Whiteboard: [code and prototype pages ready][post freeze work remaining] → [post freeze work remaining][code and prototype pages ready]
Blocks: 457186
The initial version of the start page for beta 1 is up on the staging site at http://stage.mozillamessaging.com/en-US/thunderbird/3.0b1/start/

Rafael mentioned he may have a slightly different background to come.
Today was the first time I used a news:// protocol web link that correctly appended a subscription to an existing news account. My "Bread and Butter" Tb 2.0.0.17 added the mozilla.feedback.... group. 

I expect the 404 to the release notes page is just a transitory glitch.

"For the latest product information, visit the" <link>, suggest revision to state this is the current shipping product, not the "Preview" in which this page is being displayed.
link for "the latest product information" isn't, unless you consider the last *released* info to be the latest
The new Alpha 3 start page is now available for preview here: http://stage.mozillamessaging.com/en-US/thunderbird/3.0a3/start/
Alpha 3 is now officially released. This bug is therefore fixed.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.