Last Comment Bug 457411 - [1.8 branch] Crash while uploading files to MediaFire.com [@ nsXMLHttpRequest::ConvertBodyToText]
: [1.8 branch] Crash while uploading files to MediaFire.com [@ nsXMLHttpRequest...
Status: RESOLVED DUPLICATE of bug 390219
: crash, regression, verified1.8.1.18
Product: Core
Classification: Components
Component: General (show other bugs)
: 1.8 Branch
: All Mac OS X
: -- critical (vote)
: ---
Assigned To: Boris Zbarsky [:bz] (Out June 25-July 6)
:
Mentors:
http://www.mediafire.com
Depends on:
Blocks: 445890
  Show dependency treegraph
 
Reported: 2008-09-27 05:01 PDT by R P Mozley
Modified: 2011-06-09 14:58 PDT (History)
9 users (show)
dveditz: blocking1.8.1.18+
dveditz: wanted1.8.1.x+
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Firefox crash log (30.50 KB, text/plain)
2008-09-27 07:14 PDT, R P Mozley
no flags Details
Camino crash log (26.45 KB, text/plain)
2008-09-27 07:15 PDT, R P Mozley
no flags Details
SeaMonkey crash log (22.93 KB, text/plain)
2008-09-27 07:16 PDT, R P Mozley
no flags Details
debug build apple crash report (46.15 KB, text/plain)
2008-09-29 05:55 PDT, Carsten Book [:Tomcat]
no flags Details
Fairly small crashtest (361 bytes, text/html)
2008-09-29 12:14 PDT, Boris Zbarsky [:bz] (Out June 25-July 6)
no flags Details
Fix (701 bytes, patch)
2008-09-29 12:15 PDT, Boris Zbarsky [:bz] (Out June 25-July 6)
no flags Details | Diff | Review

Description R P Mozley 2008-09-27 05:01:17 PDT
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-GB; rv:1.8.1.17) Gecko/20080916 Camino/1.6.4 (like Firefox/2.0.0.17)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-GB; rv:1.8.1.17) Gecko/20080904 Firefox/2.0.0.17

If you try to upload a file or files to MediaFire.com using their "basic uploader" Firefox 2.0.0.17 will crash. It also crashes in SeaMonkey 1.1.12 and Camino 1.6.4
This leads me to believe that it is a core Gecko bug in the 1.8.1 branch. On testing with previous builds in the Gecko 1.8.1.16 family MediaFire.com does not crash.
There for the bug must have been introduce within the code changes of Gecko 1.8.1.17
One possiblilty is Bug 439034 [https://bugzilla.mozilla.org/show_bug.cgi?id=439034]

Reproducible: Always

Steps to Reproduce:
1. Switch to MediaFire's "basic uploader"
2. Try uploading a few files of medium size (10MB+)
3. Uploader will run for a few moments, then Firefox crashes
Actual Results:  
Firefox-bin crashes, writing to crash log

Expected Results:  
Files get uploaded to MediaFire.com

Here is a crash log of Firefox 2.0.0.17:
http://pastebin.mozilla.org/542614

And of Camino 1.6.4:
http://pastebin.mozilla.org/542572
Comment 1 philippe (part-time) 2008-09-27 06:12:11 PDT
Can you attach teh crash log(s) to this bug (use the 'Add and attachment' link) so that they don't get lost ? Thanks.
Comment 2 R P Mozley 2008-09-27 07:14:44 PDT
Created attachment 340724 [details]
Firefox crash log
Comment 3 R P Mozley 2008-09-27 07:15:24 PDT
Created attachment 340725 [details]
Camino crash log
Comment 4 R P Mozley 2008-09-27 07:16:14 PDT
Created attachment 340726 [details]
SeaMonkey crash log
Comment 5 Carsten Book [:Tomcat] 2008-09-27 07:41:23 PDT
I can confirm this crash , 2.0.0.16 is fine with the steps to reproduce, 2.0.0.17 crashs.

I will search for the Regression Window
Comment 6 Henrik Skupin (:whimboo) 2008-09-27 08:08:38 PDT
Does it also happen on Windows and Linux? Similar to bug 456705?
Comment 7 Smokey Ardisson (offline for a while; not following bugs - do not email) 2008-09-27 12:03:56 PDT
Nominating since this is a crash-regression on the branch.
Comment 8 Carsten Book [:Tomcat] 2008-09-27 12:19:03 PDT
Same regression range as in Bug 456705 - 

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.17pre) Gecko/2008082603 BonEcho/2.0.0.17pre -> works

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.17pre) Gecko/2008082703 BonEcho/2.0.0.17pre -> crashs

also i got Error: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIXMLHttpRequest.status]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: http://www.mediafire.com/upload_timer.html :: anonymous :: line 2"  data: no]
Source File: http://www.mediafire.com/upload_timer.html
Line: 2

in the Firefox Error Console.
Comment 9 Daniel Veditz [:dveditz] 2008-09-27 12:44:40 PDT
bz: see comment 8
Comment 10 Boris Zbarsky [:bz] (Out June 25-July 6) 2008-09-28 19:21:59 PDT
Huh.  Odd.  The patch in bug 445890 should not have affected either .status or ConvertBodyToText.

Does one need a MediaFire account to reproduce this bug?  If so, is there any chance of a breakpad incident id or some other stack that actually has line numbers?
Comment 11 Smokey Ardisson (offline for a while; not following bugs - do not email) 2008-09-28 22:46:01 PDT
Boris, it looks like anyone can reproduce this by visiting the site in a 1.8.1-branch build and following the steps in comment 0 (the "switch to basic uploader" link is on the right side underneath the big green "Upload Files to MediaFire" button).  In Camino 1.6.4, made the uploader start to upload the latest Camino.dmg and the uploader crashed Camino.  (Unfortunately, I can't get you a crash log with line numbers because my 1.8.1-branch debug build crashes with some JS_Assert failure just loading the mediafire page.)
Comment 12 Henrik Skupin (:whimboo) 2008-09-29 01:22:30 PDT
(In reply to comment #10)
> Does one need a MediaFire account to reproduce this bug?  If so, is there any
> chance of a breakpad incident id or some other stack that actually has line
> numbers?

Boris, what I've seen is that you have to upload at least two or three files at once. When I had selected only one file I wasn't able to crash Firefox. Sadly *Talkback* doesn't come up on my system. So I cannot offer any line numbers. I even don't have a debug build.

Tomcat, do you have a 1.8 branch debug build?
Comment 13 Carsten Book [:Tomcat] 2008-09-29 02:38:22 PDT
(In reply to comment #10)
> Does one need a MediaFire account to reproduce this bug?  If so, is there any
> chance of a breakpad incident id or some other stack that actually has line
> numbers?

Hi Boris, you don't need a mediafire account. Just go to the mediafire site -> choose the basic uploader and and upload a (one! file is enough) file bigger then 10MB and you crash.

Unfortunately my Mac Debug Build crash with the same stack as bug 457062.

 (In reply to comment #12)
> Boris, what I've seen is that you have to upload at least two or three files at
> once. 

thats not true, see the steps to reproduce from comment #0 ..one file (10MB+) is enough to trigger the crash
Comment 14 Carsten Book [:Tomcat] 2008-09-29 05:55:38 PDT
Created attachment 340912 [details]
debug build apple crash report

Note: on the Debug Build you see :

###!!! ASSERTION: You can't dereference a NULL nsCOMPtr with operator->().: 'mRawPtr != 0', file ../../dist/include/xpcom/nsCOMPtr.h, line 849
Break: at file ../../dist/include/xpcom/nsCOMPtr.h, line 849

before Firefox Crashs
Comment 15 Henrik Skupin (:whimboo) 2008-09-29 06:35:47 PDT
Carsten, can you use gdb to get the stack? The Apple crash report doesn't contain line numbers as Boris has already mentioned. Thanks.
Comment 16 Boris Zbarsky [:bz] (Out June 25-July 6) 2008-09-29 07:55:10 PDT
Carsten, thanks for actual steps to reproduce!  I'll see what I can dig up here.
Comment 17 Boris Zbarsky [:bz] (Out June 25-July 6) 2008-09-29 12:14:20 PDT
Created attachment 340967 [details]
Fairly small crashtest
Comment 18 Boris Zbarsky [:bz] (Out June 25-July 6) 2008-09-29 12:15:29 PDT
Created attachment 340968 [details] [diff] [review]
Fix

We're basically running into bug 457746 here, so mChannel is null when it shouldn't be.  I have no idea why the website calls abort/send on a single XHR object in more or less a loop, but whatever.
Comment 19 Boris Zbarsky [:bz] (Out June 25-July 6) 2008-09-29 13:00:16 PDT
Gah.  This is actually just bug 390219 (which is in fact a regression from the bug that we backported to branch).  Why don't we take that more complete patch instead?

*** This bug has been marked as a duplicate of bug 390219 ***
Comment 20 Boris Zbarsky [:bz] (Out June 25-July 6) 2008-10-08 10:02:03 PDT
Fixed by landing of the patch in bug 390219.
Comment 21 [On PTO until 6/29] 2008-10-21 14:34:45 PDT
I just tried to repro this with 2.0.0.17 on both Windows XP and OS X and I can upload with the basic uploader without any crash. Did something change on the site? Can anyone still reproduce the problem?
Comment 22 [On PTO until 6/29] 2008-10-21 15:15:52 PDT
After talking to Sam, I tried this with a 10+ MB file (15 MB) and still had no crash. This was on OS X.
Comment 23 Smokey Ardisson (offline for a while; not following bugs - do not email) 2008-10-21 22:22:31 PDT
(In reply to comment #21)
> I just tried to repro this with 2.0.0.17 on both Windows XP and OS X and I can
> upload with the basic uploader without any crash. Did something change on the
> site? Can anyone still reproduce the problem?

Possibly; I believe comments in related bugs sounded like Gecko got in this crash-condition because of sites doing stupid things, so MediaFire may have been able to fix their code to not do stupid things faster than we can turn around a Gecko release ;)

To support that theory, I've just checked with Camino 1.6.4, and I got 25%/several minutes through a 15 MB upload with no problem, whereas last month it would reliably crash a few seconds into the upload.

OTOH, Boris's crashtest in comment 17 still crashes 1.6.4 but does not crash the latest Camino 1.6.5pre nightly, so you could potentially use that if you're looking for a verification testcase.
Comment 24 R P Mozley 2008-10-23 04:36:21 PDT
MediaFire still crashes for me. I don't think anything has changed too much. Tested with Firefox 2.0.0.17 and Camino 1.6.4 and with two files uploading.
Comment 25 Henrik Skupin (:whimboo) 2008-10-23 05:10:19 PDT
(In reply to comment #24)
> MediaFire still crashes for me. I don't think anything has changed too much.
> Tested with Firefox 2.0.0.17 and Camino 1.6.4 and with two files uploading.

Can you please provide a crash report? You can find it by typing "about:crashes" into the location bar. Thanks.
Comment 26 philippe (part-time) 2008-10-23 05:30:48 PDT
(In reply to comment #25)
> (In reply to comment #24)
> > MediaFire still crashes for me. I don't think anything has changed too much.
> > Tested with Firefox 2.0.0.17 and Camino 1.6.4 and with two files uploading.
> 
> Can you please provide a crash report? You can find it by typing
> "about:crashes" into the location bar. Thanks.
That doesn't work on the Gecko 1.8.1 branch.

the crash in comment 24 is probably the same as the ones that led to the creation of this bug...  those reports are already attached.

I don't crash with Fx 2.0.0.17 and Camino 1.6.4, although with Camino, I get an error: ERROR: Invalid key state, no status, after uploading, during the verification process.
Comment 27 [On PTO until 6/29] 2008-10-23 14:38:07 PDT
(In reply to comment #24)
> MediaFire still crashes for me. I don't think anything has changed too much.
> Tested with Firefox 2.0.0.17 and Camino 1.6.4 and with two files uploading.

Since it still crashes for you, can you try the same steps with a nightly 1.8 build? You can get it at ftp://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla1.8/. If it doesn't crash there, then we have gotten it fixed for 2.0.0.18.
Comment 28 R P Mozley 2008-10-24 15:06:21 PDT
Yesterday's nightly of Firefox 2.0.0.18pre does not crash for me.
Seems to be fixed.
Comment 29 [On PTO until 6/29] 2008-10-24 15:09:36 PDT
Thanks for the note. I'll mark this as verified since it isn't crashing for either of us.

Note You need to log in before you can comment on or make changes to this bug.