Closed Bug 457601 Opened 11 years ago Closed 11 years ago

Update SimpleTest

Categories

(addons.mozilla.org Graveyard :: Administration, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: wenzel, Assigned: wenzel)

References

Details

We are using an alpha version for simpletest, while version 1.0.1 was released a while ago.

Our current version has some trouble with mock objects (http://mlblog.osdir.com/php.simpletest.general/2006-04/msg00039.shtml), so we need to update SimpleTest in order to write proper tests.

This blocks bug 454938, which is supposed to use mock objects.
Depends on: 457602
No longer blocks: 454938
Target Milestone: --- → 4.0.4
Assignee: nobody → fwenzel
Blocks: 454938
I updated it in r20169. A lot of tests are broken, but that is neither the scope of nor caused by this bug.

In fact, only really with the new version, we are able to fix the tests and write new ones that work well.
Status: NEW → RESOLVED
Closed: 11 years ago
Keywords: push-needed
Resolution: --- → FIXED
Keywords: push-needed
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.