Expose anti virus and scam preferences in the MailNews Preferences UI

RESOLVED FIXED in seamonkey2.0

Status

SeaMonkey
Preferences
--
enhancement
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: Philip Chee, Assigned: Philip Chee)

Tracking

({fixed-seamonkey2.0})

Trunk
seamonkey2.0
fixed-seamonkey2.0
Bug Flags:
wanted-seamonkey2.0 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [l10n impact], URL)

Attachments

(3 attachments, 2 obsolete attachments)

(Assignee)

Description

9 years ago
In Thunderbird 2.0 There is an item in their Options dialog Tools->Options->Privacy->Anti-Virus that controls this pref "mailnews.downloadToTempFile" i.e. "Allow anti-virus clients to quarantine individual incoming messages". We should expose this preference in our Preferences dialog.

This is assuming that /mailnews/local/src/nsPop3Sink.cpp is shared and that we build with this of course.
(Assignee)

Updated

9 years ago
Blocks: 360488
I'd much rather they only Quarantine the attachments to messages; the messages themselves are unlikely to contain a virus.

But given [current] constraints of platform, I can see this is probably worth it.
(Assignee)

Comment 2

8 years ago
Karsten: where would be a good place in the Preferences window to put this UI?
(Assignee)

Comment 3

8 years ago
We don't seem to have UI for turning the (mail) pishing detector on and off either. Thunderbird puts these two items under the Privacy pane. Since these two are specific to mailnews I don't think it is appropriate to put this on our Privacy & Security branch.

So should we create a new pane under Mail & Newsgroups or what?
(In reply to comment #3)
> We don't seem to have UI for turning the (mail) pishing detector on and off
> either. Thunderbird puts these two items under the Privacy pane. Since these
> two are specific to mailnews I don't think it is appropriate to put this on our
> Privacy & Security branch.

Well, none of the existing panes there match and putting those on the P&S pane itself sounds like a bad idea, especially since the list of checkboxes on that pane looks like it could grow in the future or by extensions' additions. Thus the only real option there would be to add a new pane but in that case we could just as well put it under M&N.

> So should we create a new pane under Mail & Newsgroups or what?

Either that (none of the existing panes there match either) or add a groupbox on the main M&N pane. With a bit of luck after adding the two extra checkboxes the pane content would still fit. But if you ask me, yes, it'd be a new pane under M&N.

Oh, and referring to your news posting: Surely not Advanced (IMO of course). This is clearly MailNews.
(Assignee)

Updated

8 years ago
Assignee: nobody → philip.chee
Status: NEW → ASSIGNED
Summary: Expose anti virus pref [mailnews.downloadToTempFile] in the Preferences UI → Expose anti virus and scam preferences in the MailNews Preferences UI
(Assignee)

Comment 5

8 years ago
Created attachment 402553 [details] [diff] [review]
Patch v1.0 UI for Scam Mail and Mail AV Scan preferences.

First draft.
Attachment #402553 - Flags: ui-review?(neil)
Attachment #402553 - Flags: review?(iann_bugzilla)
(Assignee)

Updated

8 years ago
Flags: wanted-seamonkey2.0?

Updated

8 years ago
Attachment #402553 - Flags: ui-review?(neil) → ui-review+

Comment 6

8 years ago
Comment on attachment 402553 [details] [diff] [review]
Patch v1.0 UI for Scam Mail and Mail AV Scan preferences.

>     </groupbox>
>+    <groupbox>
Nit: blank lines please.

Updated

8 years ago
Flags: wanted-seamonkey2.0? → wanted-seamonkey2.0+

Comment 7

8 years ago
Comment on attachment 402553 [details] [diff] [review]
Patch v1.0 UI for Scam Mail and Mail AV Scan preferences.

>--- a/suite/locales/en-US/chrome/mailnews/pref/mailPrefsOverlay.dtd
>-<!ENTITY junk.label                       "Junk Mail">
>+<!ENTITY junk.label                       "Junk &amp; Scam Mail">
You've changed the label in the pref tree but not at the top of the pref pane (in pref-junk.dtd)
Perhaps "Junk &amp; Suspect Mail"?
Then a single groupbox "Suspect Mail" for both Scams and AV?

>--- a/suite/locales/en-US/chrome/mailnews/pref/pref-junk.dtd
>+<!-- Phishing Detector -->
>+<!ENTITY pref.phishing.caption            "E-mail Scams">
>+<!ENTITY phishingDetector.intro           "&brandShortName; can analyze messages for suspected email scams by looking for common techniques used to deceive you.">
I'm not sure we need this intro, better off in help.
>+<!ENTITY enablePhishingDetector.label     "Tell me if the message I'm reading is a suspected email scam">
>+<!ENTITY enablePhishingDetector.accesskey "T">

>--- a/suite/locales/en-US/chrome/mailnews/pref/pref-offline.dtd
>@@ -27,8 +27,14 @@
>+<!-- Anti Virus -->
>+<!ENTITY pref.antivirus.caption           "Anti-Virus">
>+<!ENTITY antiVirus.intro                  "&brandShortName; can make it easy for anti-virus software to analyze incoming mail messages for viruses before they are stored locally.">
"..can make it easier..."?
Saying that I'm not sure we need so much information in the pref pane, it should go in help.
>+<!ENTITY antiVirus.label                  "Allow anti-virus clients to quarantine individual incoming messages">
"Allow anti-virus clients more easily scan incoming messages" perhaps?
I think this pref might be better suited in "Junk & Suspect Mail" pref pane.

You will need to update help to reflect the finalised version.
Attachment #402553 - Flags: review?(iann_bugzilla) → review-

Comment 8

8 years ago
(In reply to comment #7)
> Perhaps "Junk &amp; Suspect Mail"?
How about "Unwanted Mail"?

> I'm not sure we need this intro, better off in help.
We have intros in a few other panels which gives people a chance of understanding the checkbox label.
(Assignee)

Comment 9

8 years ago
Just FYI, with the introductions I couldn't fit everything into the Junk prefpane. That's why I moved to AV pref to Network and Storage. Well actually I could just since I'm on WindowsXP; but I think Linux users won't. I'll come up with a version with both prefs in the Junk prefpane and someone with a Linux box can test it.
(Assignee)

Comment 10

8 years ago
Created attachment 402811 [details]
Screenshot: Groupbox with Intro
Attachment #402811 - Flags: ui-review?(neil)
Attachment #402811 - Flags: review?(iann_bugzilla)
(Assignee)

Comment 11

8 years ago
Created attachment 402812 [details]
Screenshot: Groupbox without Intro
Attachment #402812 - Flags: ui-review?(neil)
Attachment #402812 - Flags: review?(iann_bugzilla)
(Assignee)

Comment 12

8 years ago
Before spending more time on this could I get some feedback on the preferred UI?

Updated

8 years ago
Attachment #402811 - Flags: ui-review?(neil) → ui-review-
Comment on attachment 402811 [details]
Screenshot: Groupbox with Intro

I don't think two intros in one group box works well, even if we make space...
Comment on attachment 402812 [details]
Screenshot: Groupbox without Intro

This looks OK. Nit: we're not the Enterprise, so we want "to scan incoming messages more easily".
Attachment #402812 - Flags: ui-review?(neil) → ui-review+

Comment 15

8 years ago
Comment on attachment 402812 [details]
Screenshot: Groupbox without Intro

These are the continuing adventures... ;)
Attachment #402812 - Flags: review?(iann_bugzilla) → review+

Updated

8 years ago
Attachment #402811 - Flags: review?(iann_bugzilla) → review-
(Assignee)

Comment 16

8 years ago
Created attachment 403016 [details] [diff] [review]
Patch v1.1 Fix Nits; all-in-one groupbox.

> >     </groupbox>
> >+    <groupbox>
> Nit: blank lines please.
Fixed.

> You've changed the label in the pref tree but not at the top of the pref pane
> (in pref-junk.dtd)
> Perhaps "Junk &amp; Suspect Mail"?
Fixed.

> Then a single groupbox "Suspect Mail" for both Scams and AV?
Fixed.

> I'm not sure we need this intro, better off in help.
[...]
> Saying that I'm not sure we need so much information in the pref pane, it
> should go in help.

I've moved the intros into tooltips.

> >+<!ENTITY antiVirus.intro                  "&brandShortName; can make it easy for anti-virus software to analyze incoming mail messages for viruses before they are stored locally.">
> "..can make it easier..."?
Fixed.

> (Comment #8 From neil)
> 
> (In reply to comment #7)
> > I'm not sure we need this intro, better off in help.
> We have intros in a few other panels which gives people a chance of
> understanding the checkbox label.

I agree. New preferences, or newly exposed preferences, should have additional descriptions for better understandability.

> (Comment #14 From  neil)
> This looks OK. Nit: we're not the Enterprise, so we want "to scan incoming
> messages more easily".
> 
> (Comment #15 From Ian Neal)
> These are the continuing adventures... ;)
Made it so!
Attachment #402553 - Attachment is obsolete: true
Attachment #403016 - Flags: superreview?(neil)
Attachment #403016 - Flags: review?(iann_bugzilla)

Comment 17

8 years ago
So all that is missing now are the changes to help...
(Assignee)

Comment 18

8 years ago
> So all that is missing now are the changes to help...
The tooltips aren't enough? I'll file a followup bug.
(Assignee)

Updated

8 years ago
Blocks: 423281

Comment 19

8 years ago
Comment on attachment 403016 [details] [diff] [review]
Patch v1.1 Fix Nits; all-in-one groupbox.

Yes, help will need patching too for definite.
Attachment #403016 - Flags: review?(iann_bugzilla) → review+

Comment 20

8 years ago
(In reply to comment #18)
> > So all that is missing now are the changes to help...
> The tooltips aren't enough? I'll file a followup bug.

When you file that bug, please make it block bug 423281.
No longer blocks: 423281
Philip, can you verify that this bug covers bug 502363 and bug 513815 and resolve them as duplicates of this one if that's the case please?
Comment on attachment 403016 [details] [diff] [review]
Patch v1.1 Fix Nits; all-in-one groupbox.

Sorry, but I don't like the idea of tooltiptext. sr=me with it removed.
Attachment #403016 - Flags: superreview?(neil) → superreview+
(Assignee)

Comment 23

8 years ago
Created attachment 403171 [details] [diff] [review]
Patch v1.2 sans tooltips
[Checkin: Comment 25]

Carrying forward r=iann_bugzilla sr=neil

> Sorry, but I don't like the idea of tooltiptext. sr=me with it removed.
Gone!
Attachment #403016 - Attachment is obsolete: true
Attachment #403171 - Flags: superreview+
Attachment #403171 - Flags: review+
(Assignee)

Updated

8 years ago
Keywords: checkin-needed
Whiteboard: [l10n impact]
(Assignee)

Updated

8 years ago
Duplicate of this bug: 513815
Attachment #403171 - Attachment description: [for checkin] Patch v1.2 sans tooltips. r=iann_bugzilla sr=neil → Patch v1.2 sans tooltips [Checkin: Comment 25]
Comment on attachment 403171 [details] [diff] [review]
Patch v1.2 sans tooltips
[Checkin: Comment 25]


http://hg.mozilla.org/comm-central/rev/f359f8092a4e
No longer blocks: 360488
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Keywords: checkin-needed → fixed-seamonkey2.0
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Blocks: 519228
You need to log in before you can comment on or make changes to this bug.