Deleting folder with a folder with the same name in trash produces an IMAP error

RESOLVED DUPLICATE of bug 66763

Status

MailNews Core
Networking: IMAP
P3
normal
RESOLVED DUPLICATE of bug 66763
18 years ago
9 years ago

People

(Reporter: Henrik Gemal, Assigned: Scott MacGregor)

Tracking

Trunk
Future
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
If you delete a folder named "Test" it's moved to the Trash. Now if you delete 
another folder also named "Test", you'll get an IMAP error saying There's 
already an object with this name.
The folder is removed from the folderlist, but is actually not deleted!

In Netscape 4.7 if you delete a folder with a name that already exist in the 
Trash you'll get a Warning:
The Trash already contains a folder named "Test". Please either empty the Trash 
or rename this folder.

Mozilla should support this!

Updated

18 years ago
QA Contact: lchiang → huang

Comment 1

18 years ago
Nominate nsbeta3.
Keywords: nsbeta3
(Assignee)

Comment 2

18 years ago
marking future. we're not going to get to this in beta3 and it doesn't meet our
beta3 criteria.

Just for kicks, how did you get in a state where you got folders with the same
name? the protocol is supposed to prevent you from doing that.
Target Milestone: --- → Future

Comment 3

18 years ago
Are you sure this will be in Future?
After users delete a named "Test" folder to Trash folder, users are allowed to 
create the "Test" folder again, but if users tried to delete the 2nd created 
"Test" folder to Trash folder again in one session(and unchecked Empty Trash on 
exit), the error should display: "The Trash already contains a folder named 
"Test". Please either empty the Trash 
or rename this folder" instead of "There's already an object with this name".
I am thinking if 4.x can support this -- Mozilla should support this, isn't it?
(Assignee)

Comment 4

18 years ago
I think it's an edge case and I don't think it meets our beta3 criteria. It
isn't one of the areas we are focusing on for beta3 (see selmer's email the
other day on determing beta3 criteria). And it isn't important enough to warrant
falling into the common sense says this needs to be fixed for beta3 regardless
of the criteria case....

Comment 5

18 years ago
OK. Remove nsbeta3 based on beta3 criteria which mentioned from the previous 
comment.
Keywords: nsbeta3
(Reporter)

Comment 6

18 years ago
Loads of people have IMAP folders with the same name. People could have a folder 
named "important" under multiple folders so the IMAP folderlayout could look 
something like this:
Private\important
Work\important
Mozilla\important

So when you delete the "important" folder under Mozilla it's moved to the trash. 
Now try to delete the folder "important" under Work. Error.

Comment 7

17 years ago
I think this is a side effect of bug 37454, maybe even dupe?

Comment 8

17 years ago
*** Bug 98970 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
For the record: this bug is not IMAP-specific. It happens in mailnews regardless
of the protocol. You can't delete two folders with the same name, because they
can't be in the trash at once. 

Comment 10

16 years ago
Nominating nsbeta1 based on PRD p1 for better error handling.
Keywords: nsbeta1

Comment 11

16 years ago
*** Bug 97849 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Summary: Deleting an folder with an folder with the same name already in trash produces an IMAP error → Deleting folder with a folder with the same name in trash produces an IMAP error

Updated

16 years ago
Keywords: nsbeta1 → nsbeta1-

Comment 12

16 years ago
*** Bug 124583 has been marked as a duplicate of this bug. ***

Comment 13

16 years ago
there is also bug 66763 about this

Comment 14

16 years ago
*** Bug 123209 has been marked as a duplicate of this bug. ***

Comment 15

16 years ago
For current trunk and branch builds, an IMAP alert displays: "The current 
command did not succeed. The mail server responded: Mailbox already exist."

Comment 16

16 years ago
I hope to see this fixed soon. As stated in comment #9 it happens really
everwhere, e.g. I had the problem with a POP account on Linux.
For a quick fix I suggest renaming the folder in the trash in such a way that
you can guess where it was before in the directory tree. If you still have
duplicates, add numbers or delete dates to them. Tnx.

Updated

15 years ago
QA Contact: huang → gchan

Comment 17

15 years ago
There's a patch in bug 73404 which would clean up Mozilla's behaviour a bit WRT
filesystem representation od moved/deleted folders.

Patch is waiting for a review.
Depends on: 73404

Comment 18

15 years ago
Hope this won't be redundant. 

My Mozilla is 'Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3)
Gecko/20030312'

I can not delete folder in similar situation. When I try to delete folder, it
seems that Mozilla tries to change name of folder-to-be-deleted to
my-trash-folder name instead of moving folder-to-be-deleted inside trash folder.
So I got message 'Can't create mailbox node ... : Folder exists'.

Comment 19

15 years ago
Same problem here I must use OE for deleting folders on all my IMAP accounts. :(

This drives my crezy and does not let use Mozilla on all our computers.

Comment 20

14 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b) Gecko/20031122
folder is not removed from list but I'm not using IMAP.
Product: MailNews → Core
Is this a dupe of bug 66763? (Chronologically the other way around, I assume, but the other one seems more active.)

Comment 22

10 years ago
Same problem, yep. Duping.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 66763
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.