Closed Bug 465860 Opened 13 years ago Closed 13 years ago

"From" address is not selected from multiple identities correctly anymore

Categories

(Thunderbird :: Message Compose Window, defect)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b1

People

(Reporter: jack, Assigned: standard8)

References

Details

(Keywords: regression)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081119 Minefield/3.1b2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081119 Shredder/3.0b1pre

I have three identities attached to one of my accounts.  I have more than one account, but I doubt that matters.  In the past, whenever I click on a message that was sent to one of the addresses associated with any of the identities, and clicked "Reply," the correct (matching) address would be set in the "From" drop down menu of the compose window.

Reproducible: Always

Steps to Reproduce:
1.  Create an account
2.  Create an additional identity
2.  Select an email in this account which had been addressed to the 2nd identity
3.  click "reply"
Actual Results:  
The "From" address is set to the first identity (the reply is coming from an address that the other person never sent an email to).

Expected Results:  
The "From" address should be set to the same address that the received email was sent to.  This is the way it worked until a shredder nightly some time before this Saturday.


I was able to reproduce this with a fresh new profile.
> This is the way it worked until a shredder nightly some time before this 
> Saturday.

Can you give a more specific time frame? (How often do you update?)
Keywords: regression
Version: unspecified → Trunk
I do usually update daily.  I don't send mail from all identities every day, but the oldest mail I can find that was addressed incorrectly was at Sat, 15 Nov 2008 19:12:47 -0500.  I didn't notice it was doing the wrong thing until the other person's reply came into the wrong folder.

The headers show that I was using this at that time:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081115 Shredder/3.0b1pre

Unfortunately, I use this other identity so rarely that the last time I sent a reply from it before 11/15 was with
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080901032335 Shredder/3.0b1pre
 . . . I do not have any specific memory of manually setting the identity at that time, but it appears to have worked correctly.  Of course I wasn't paying attention back then, though.


I just tested again with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081123 Shredder/3.0b1pre
 . . . and it's still using the wrong identity on replies.  2.0.0.17 and 2.0.0.18 are doing it correctly, though.
Attached patch The fixSplinter Review
I found the cause, we have a loose nsIMsgIdentity without any Components.interfaces or const causing a reference error. Attaching patch, we should fix get this in for b1.
Assignee: nobody → bugzilla
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #349732 - Flags: review?(bienvenu)
Attachment #349732 - Flags: review?(bienvenu) → review+
Checked in http://hg.mozilla.org/comm-central/rev/30dfde405046 this will be fixed from tomorrow's nightlies.
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.0b1
(This was fallout from bug 414038.)
Blocks: 414038
OS: Windows XP → All
Hardware: PC → All
Duplicate of this bug: 466926
This is not fixed.

I have one account which receives pop mail in the usual way.

I have another account which does not receives pop mail directly but via message filters set up in account #1 (ie i have one pop mailbox to receive mail for 2 separate domain names) This set-up works very well because I can send email from an account of my choice and have 2 distinct sending identities.

So both accounts are identical with the only difference that #2 does not receive pop mail, but mail sent on via message filters.

if I create a new mail in account #2, the reply-to address is set correctly.

if I reply to a mail that has been *forwarded via message filters*, it sets the reply-to address to that of account #1 which is wrong, so I have to manually change it each time.  Annoying because if i forget, i have just sent an email from the wrong mailbox which confuses the hell out of the recipient.

the filter is very simple: 'if to or cc contains <pattern> move to Inbox on account #2'  or 'if Envelope-to contains <pattern> do the same'.  These filters work like a dream as they also catch mail which has been bcc'd to account #2 as well as to or cc.

this happens every time on every mail which has been handled via message filters
i'm using 2.0.0.19 on winxp

ta marcus
(In reply to comment #7)
> This is not fixed.
...
> i'm using 2.0.0.19 on winxp

This is fixed in Thunderbird 3 beta 1 and later which is what the Fixed (and milestone) is signifying. We won't be back porting the fix because we'd have to find it (the code has changed a lot) and generally the 2.x releases are for stability and security only.
Hi again,

This bug is bugging me so much, that I uninstalled 2.0.0.19 and installed Thunderbird 3 beta 2 just now.  The problem is still there exactly as I described in my previous post (comment #7).  What other info can I provide to help?  Thanks, Marcus
(In reply to comment #9)
> Hi again,
> 
> This bug is bugging me so much, that I uninstalled 2.0.0.19 and installed
> Thunderbird 3 beta 2 just now.  The problem is still there exactly as I
> described in my previous post (comment #7).  What other info can I provide to
> help?  Thanks, Marcus

Just having had another quick look at your comment, it isn't this bug. Its a separate issue.

However I'm not even sure its a bug - you've chosen to forward your email from account 1 to account 2. Therefore that's *exactly* the same as you clicking the forward button and doing it manually. So it *will* want to respond to account 1 as that's where the forwarded message came from. Why not just use the filter to copy it between accounts?
Hi,
I may have misled with the term 'forwarded'.  No, the messages are indeed copied via the filters. Well they are not even copied as there is no copy remains in account 1, they simply end up in account 2.

Without any filters, mail addressed to marcus@account1 and marcus@account2 (different domains) both end up in the Inbox of account 1 as expected.  I have it this way so I receive mail addressed to 2 separate domains without paying for 2 separate pop services.

Once the filters are in place, mail addressed to marcus@account2 is transferred via the filters to the Inbox of account 2.  Replying to this sets the From address to that of account 1 and there's the problem, as this incorrect From address has nothing to do with the mail whatsoever.

I am new to bugzilla, so bear with me.  What happens, do I need to open a new bug?  Thanks Marcus
I might be mixing up two different problems I had, but when I had a very similar sounding problem, I think it was fixed by manually pruning a bad entry out of the prefs.js/about.config.  I had an account which was deleted (quite some time before I started having problems), and that had been in the config as "account4" but there were no records defining account4. In one of the preferences, there was a list of accounts like "account1,account2,account4,account5".  Changing that to "account1,account2,account5" fixed it.  Sorry to be so vague - this doesn't really come close to being step-by-step instructions for analysis or correction, but hopefully if you take a look at that config, it will make sense.

The pref was either mail.accountmanager.accounts, and I have a vague recollection that there might have been the same kind of problem with a mail.account.account(x).identities entry.  I never found out how it got broken, but the fix was straightforward.
I just moved my old profile directory out of the way and set up the 2 accounts again from scratch, so no possible old config getting in the way.

Same problem.  

It seems to set the From address to that of the account where the mail initially *landed* (ie before it was moved on by the filters), rather than setting it to the From address of the account where it *ended up*.

Logic would dictate that if I ask a filter to move a message to another account, (as opposed to another folder on the same account), I would wish to reply to that mail from the second account, not the one it was forwarded from.

So replying to any message that happens to be in the Inbox of Account 2 should surely always set the From: to the email address associated with account 2, why would it ever need to examine the headers of the mail itself?

cheers,
marcus
(In reply to comment #13)
> So replying to any message that happens to be in the Inbox of Account 2 should
> surely always set the From: to the email address associated with account 2, why
> would it ever need to examine the headers of the mail itself?

Example: I have two email addresses, one is the account on my server, the second is a redirected email address. I have two identities - one for each of the addresses.

They come into the same inbox. So when I reply, I want to reply with the identity that matches who it was sent to.

Anyway, yours is a different issue to this bug. Thunderbird is doing what it should be doing, although it clashes with your use case. The only other bug that I can see that might help you would be bug 444652, if you don't think it will feel free to file a bug, though I'm not sure how we'd fix it at this stage.
You need to log in before you can comment on or make changes to this bug.