Set-up l10n merge for Thunderbird l10n nightly builds.

RESOLVED FIXED

Status

Mozilla Messaging
Release Engineering
P2
normal
RESOLVED FIXED
9 years ago
7 years ago

People

(Reporter: stef, Assigned: gozer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.9.0.5) Gecko/2008122108 Firefox/3.0.5 Flock/2.0.3
Build Identifier: 

We need to test l10n nightly builds against missing strings to avoid yellow screens of death after update and similar problems.

If there is sth missing we should change the build status to testfailed, provide info about what is missing in the log file and not upload such build to ftp.

IIRC this is broken since mercurial-migration.

Reproducible: Always
(Reporter)

Updated

9 years ago
Blocks: 470669
(Reporter)

Updated

9 years ago
OS: Linux → All
Hardware: x86 → All
A missing string should turn the build red, not orange.
this bug depends on having compare-locales on the build machines: bug 458938
Depends on: 458938

Updated

9 years ago
Blocks: 470672
Getting l10n merge is a better solution than to stop builds being published. Therefore morphing this bug into implementing l10n merge on the Thunderbird l10n builds.

Once bug 494577 and bug 496368 are fixed, Robert tells me we should just have to pick up the new factories with any config changes that are necessary.
Status: UNCONFIRMED → NEW
Component: General → Release Engineering
Depends on: 494577, 496368
No longer depends on: 458938
Ever confirmed: true
Product: Thunderbird → Mozilla Messaging
QA Contact: general → release
Summary: Test l10n nightlies for translation completeness → Set-up l10n merge for Thunderbird l10n nightly builds.
Version: unspecified → other
Blocks: 465585
gozer, can you do this when you get time after/during b3?

KaiRo tells me that hopefully all that is needed is to pick up the new CCNightlyRepackFactory/CCBaseRepackFactory code that landed in bug 496368.
Assignee: nobody → gozer
Priority: -- → P2
Blocks: 490151

Comment 5

8 years ago
We just had merike trying to figure out why her sunbird builds are broken on ftp on #l10n.

We should really get this fixed ASAP.
(In reply to comment #5)
> We should really get this fixed ASAP.

gozer is actually already working on it. We currently have the new code working on a staging buildbot.

The last I heard is that gozer will probably set this up on "trunk" first, and then do the added bits for 1.9.1 - the 1.9.1 is harder because we have the Sunbird/Lightning builds set up there as well and I believe Lightning causes a few issues with how things are done.
(Assignee)

Comment 7

8 years ago
(In reply to comment #6)
> (In reply to comment #5)
> > We should really get this fixed ASAP.
> 
> gozer is actually already working on it. We currently have the new code working
> on a staging buildbot.

That's correct, and I am moving that stuff over to the production buildbot master today.

> The last I heard is that gozer will probably set this up on "trunk" first, and
> then do the added bits for 1.9.1 - the 1.9.1 is harder because we have the
> Sunbird/Lightning builds set up there as well and I believe Lightning causes a
> few issues with how things are done.

Actually, depending on how things go, I might just go ahead and make it so for both branches.
(Assignee)

Comment 8

8 years ago
changeset:   1404:3633b62ae64c
tag:         tip
user:        Philippe M. Chiasson <gozer@mozillamessaging.com>
date:        Thu Aug 06 23:37:06 2009 -0400
summary:     Bug 470673. Setup and enable l10n-merge for the comm-central buildbot.

This enabled l10n-merge for:
- Thunderbird comm-1.9.1
- Thunderbird comm-central
- Sunbird comm-1.9.1
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 9

8 years ago
... plus the corresponding nightly builders? I just switched scraping on for those on http://tinderbox.mozilla.org/showbuilds.cgi?tree=Mozilla-l10n, once a few more builds have cycled, you might want to verify that that's what you expect.
You need to log in before you can comment on or make changes to this bug.