Last Comment Bug 471561 - Change search/start defaults to Yandex in ru builds
: Change search/start defaults to Yandex in ru builds
Status: VERIFIED FIXED
[bug 480598 covers getting this into b3]
: verified1.9.1
Product: Firefox
Classification: Client Software
Component: Search (show other bugs)
: 3.5 Branch
: All All
: P2 major (vote)
: Firefox 3.1b3
Assigned To: Kev Needham [:kev]
:
: Florian Quèze [:florian] [:flo]
Mentors:
Depends on: 479240
Blocks: 480598
  Show dependency treegraph
 
Reported: 2008-12-30 12:41 PST by Kev Needham [:kev]
Modified: 2009-05-21 16:17 PDT (History)
29 users (show)
mbeltzner: blocking‑firefox3.5+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Modified Yandex Search Plugin (4.18 KB, text/xml)
2008-12-30 12:41 PST, Kev Needham [:kev]
no flags Details
proposed patch for search plugin and region.properties (1.56 KB, patch)
2009-01-13 06:38 PST, Kev Needham [:kev]
no flags Details | Diff | Splinter Review
proposed patch for search plugin and region.properties (5.97 KB, patch)
2009-01-13 07:35 PST, Kev Needham [:kev]
l10n: review+
stas: review+
unghost: review+
Details | Diff | Splinter Review

Description Kev Needham [:kev] 2008-12-30 12:41:58 PST
Created attachment 354864 [details]
Modified Yandex Search Plugin

Per the new business arrangement between Mozilla & Yandex in Russia, we need to make some changes to the ru build's search defaults. Those changes will include modifying the default Yandex search plugin, putting it first in search plugin order, and making it the default searchengineprovider. We will also need to change the keyword.URL to Yandex, and add an argument to the default start page. (see below)

Google will move from position 1 to position 2. 

This change is for the ru locale only.

The value for keyword.URL should be:

http://yandex.ru/yandsearch?stype=first&clid=46511&text=

The value for the default start page should be:

http://ru.start2.mozilla.com/?clid=46512

The modified Yandex search plugin is attached.

This bug is marked confidential until the agreement has been announced publicly.
Comment 1 Shawn Wilsher :sdwilsh 2009-01-05 09:40:13 PST
(In reply to comment #0)
> This bug is marked confidential until the agreement has been announced
> publicly.
Does this mean it shouldn't be checked in until then as well?  Do we know when this will be announced publicly?

Lastly, Kev, are you going to generate the patch for this, or should someone else?
Comment 2 Kev Needham [:kev] 2009-01-05 09:44:03 PST
Margaret, can you weigh in on when we can make the change public? The sooner the better, so it can be included in beta releases. The agreement is executed, but I just want to make sure we don't surprise anyone if it gets checked into nightlies.

I'll generate the patch this aft and add it.
Comment 3 Shawn Wilsher :sdwilsh 2009-01-05 10:19:29 PST
FYI - the code freeze for beta 3 is January 13th, 11:59pm PST, and technically it's supposed to bake on mozilla-central for a bit too.
Comment 4 Margaret 2009-01-05 13:18:11 PST
Harvey or I will post one very short blog indicating that the partnership is on.  That will be done by end of this week.

Once that is up (and I will update this bug when that happens) we can then make the change public in a non-confidential bug and start getting it in any future beta release builds.

Thanks,
/M
Comment 5 Reed Loden [:reed] (use needinfo?) 2009-01-07 11:21:21 PST
(In reply to comment #0)
> The value for the default start page should be:
> 
> http://ru.start2.mozilla.com/?clid=46512

I thought our policy was to not change the search settings for people already using Firefox and that any change would just affect new users... If that's still true, shouldn't this be ru.start3.mozilla.com instead?
Comment 6 Kev Needham [:kev] 2009-01-07 11:24:15 PST
Not sure how that would really change things, unless we were talking about users who did not update. I have no objection to using ru.start3.mozilla.com, just so everyone's clear that the default changes will affect all users who update to 3.1.
Comment 7 Reed Loden [:reed] (use needinfo?) 2009-01-07 11:27:47 PST
(In reply to comment #6)
> Not sure how that would really change things, unless we were talking about
> users who did not update. I have no objection to using ru.start3.mozilla.com,
> just so everyone's clear that the default changes will affect all users who
> update to 3.1.

So, if a user currently uses the default start page setting (currently Google), we're just going to change it to Yandex without their permission?
Comment 8 Kev Needham [:kev] 2009-01-07 11:36:40 PST
Yes.

We're changing the default providers in 3.1. They are not user-set, they're application defaults. We did this when we moved from Yahoo! to Google in Asia with 2.0, and the changes would only apply to 3.1 and beyond.

After a little more thought, we do have to use a different hostname, as we don't want the change to effect existing users of current and earlier versions.
Comment 9 Mike Beltzner [:beltzner, not reading bugmail] 2009-01-07 11:53:52 PST
(In reply to comment #7)
> So, if a user currently uses the default start page setting (currently Google),
> we're just going to change it to Yandex without their permission?

Default providers and settings have always been changed this way - if a user has changed their settings, we respect and keep that change. If they have accepted the default, and if we believe the default should change, then the change should go out to existing and new users. This has been the case before for other changes to defaults ("Latest Headlines", f.e.) as well.

We're making this change because the .ru localization community and our community feels like it's the best choice for users. Feel free to dispute that claim, bringing evidence or rationale, here or perhaps in dev-apps-firefox.
Comment 10 Reed Loden [:reed] (use needinfo?) 2009-01-07 13:36:06 PST
I have no qualms with the change... I was just surprised we were changing what some people may already be using, but I understand your reasoning behind it. :)
Comment 11 Infant 2009-01-09 13:21:01 PST
My apologies! And when and where interrogation of Russian community what Yandex is the best choice was spent? Can the best choice for Russian community will Google Chrome, Safari or Internet Explorer?
Comment 12 Axel Hecht [:Pike] 2009-01-09 17:39:39 PST
Why weren't the russian localizers and l10n drivers team on this bug?

Should this bug move over to the russian localization component now that it's public?
Comment 13 :Gavin Sharp [email: gavin@gavinsharp.com] 2009-01-10 20:55:24 PST
(In reply to comment #8)
> We're changing the default providers in 3.1. They are not user-set, they're
> application defaults. We did this when we moved from Yahoo! to Google in Asia
> with 2.0, and the changes would only apply to 3.1 and beyond.

Actually, for the 2.0.0.2 CJKT changes we actually went through a lot of trouble to ensure that they applied only to new users (see bug 364297, particularly bug 364297 comment 5).

We could make use of that technique again, but it's far from perfect (we can only ensure the "no-change" transition for a given upgrade due to bug 380429), and if we're OK with avoiding it for this change it makes our lives much easier.
Comment 14 Konstantin A. Lepikhov 2009-01-11 14:53:07 PST
(In reply to comment #11)
> My apologies! And when and where interrogation of Russian community what Yandex
> is the best choice was spent? Can the best choice for Russian community will
> Google Chrome, Safari or Internet Explorer?

AFAIR, it was internal research. But you can see browser statistics on liveinternet.ru for example and make self decisions. Anyway, it's not 180deg turn, just extension of current possibilities.
Comment 15 Constantine A. Murenin 2009-01-11 15:29:31 PST
(In reply to comment #14)
> (In reply to comment #11)
> > ... when and where ...?
> 
> AFAIR, it was internal research. But you can see browser statistics on
> liveinternet.ru for example and make self decisions. Anyway, it's not 180deg
> turn, just extension of current possibilities.

The problem was originally discussed in great detail in bug #348096 back in 2006.

So it appears that negotiations took about two years, and had several iterations, including Yandex releasing its own branded version of Firefox.  Here's what Harvey Anderson, VP and General Counsel of Mozilla Corporation, has to say:
http://lockshot.wordpress.com/2008/10/15/exploring-partnership-with-yandex/
http://lockshot.wordpress.com/2009/01/09/yandex-partnership-for-search-services/
Comment 16 Konstantin A. Lepikhov 2009-01-12 00:27:41 PST
(In reply to comment #15)
> > AFAIR, it was internal research. But you can see browser statistics on
> > liveinternet.ru for example and make self decisions. Anyway, it's not 180deg
> > turn, just extension of current possibilities.
> 
> The problem was originally discussed in great detail in bug #348096 back in
> 2006.
No, I say about browser market research and what features make Yandex unique in Russia.

> 
> So it appears that negotiations took about two years, and had several
> iterations, including Yandex releasing its own branded version of Firefox. 
> Here's what Harvey Anderson, VP and General Counsel of Mozilla Corporation, has
> to say:
> http://lockshot.wordpress.com/2008/10/15/exploring-partnership-with-yandex/
> http://lockshot.wordpress.com/2009/01/09/yandex-partnership-for-search-services/
Thanks for notify about this!
Comment 17 Axel Hecht [:Pike] 2009-01-12 10:26:03 PST
Kev, this bug is assigned to you, are you coming up with a patch?
Comment 18 Kev Needham [:kev] 2009-01-12 19:40:10 PST
Per comment #5, is there a preferred way (or any way, for that matter) to specify a locale-specific override for browser.startup.homepage and browser.startup.homepage_reset?
Comment 19 Kev Needham [:kev] 2009-01-12 20:00:12 PST
Please disregard the previous comment. Has to be done web-side, and I'll open a separate bug for that. Axel - yes, I'll add a patch.
Comment 20 Zibi Braniecki [:gandalf][:zibi] 2009-01-13 00:37:52 PST
Should we contact Yandex on bug 428354?
Comment 21 Vyacheslav Sedov 2009-01-13 01:28:48 PST
I should let you know something about what you do

Russian Goverment forced employers (and childrens in russian schools too - most worst thing) to use "Russian search system Yandex"

http://www.liveinternet.ru/stat/ru/searches.html - just note that at weekends & russian holidays Yandex lost positions - sometime google win over Yandex at weekends

Look like Mozilla going to help Russian Government to close "iron curtain". Free soft for non-free peoples with non-free search. :(

By the way

Please compare Yandex browsers (wow - IE6-lovers still majority!):

http://www.liveinternet.ru/stat/ru/browsers.html?slice=yandex;lang=en

and Google (IE7&FF3 almost share(!) first place, then Opera 9, and only then IE6)

http://www.liveinternet.ru/stat/ru/browsers.html?slice=Google

Google lovers love new browsers, Yandex lovers love old browsers? FF 3.1 is old browser? 

One free tip - make this "special version" looking like IE 5 and you winner!

And don`t forget to rename shortcut to "ImperNet Explorer" (icon must be blue E)
Comment 22 Konstantin A. Lepikhov 2009-01-13 01:59:21 PST
(In reply to comment #21)
> I should let you know something about what you do
> 
> Russian Goverment forced employers (and childrens in russian schools too - most
> worst thing) to use "Russian search system Yandex"
its FUD. There is no special government direction about that engine must be used for search in Russia. Maybe you approximate local work requires?

> 
> http://www.liveinternet.ru/stat/ru/searches.html - just note that at weekends &
> russian holidays Yandex lost positions - sometime google win over Yandex at
> weekends
Sometimes is not the answer.

> 
> Look like Mozilla going to help Russian Government to close "iron curtain".
> Free soft for non-free peoples with non-free search. :(
> 
> By the way
> 
> Please compare Yandex browsers (wow - IE6-lovers still majority!):
> 
> http://www.liveinternet.ru/stat/ru/browsers.html?slice=yandex;lang=en
> 
> and Google (IE7&FF3 almost share(!) first place, then Opera 9, and only then
> IE6)
> 
> http://www.liveinternet.ru/stat/ru/browsers.html?slice=Google
> 
> Google lovers love new browsers, Yandex lovers love old browsers? FF 3.1 is old
> browser? 
> 
> One free tip - make this "special version" looking like IE 5 and you winner!
> 
> And don`t forget to rename shortcut to "ImperNet Explorer" (icon must be blue
> E)
Feel free to use what you want but don't say it for others. All of your opinions are very strange and irrelevant.
Comment 23 Alexey Gladkov 2009-01-13 02:28:26 PST
(In reply to comment #21)
> Russian Goverment forced employers (and childrens in russian schools too - most
> worst thing) to use "Russian search system Yandex"

Do you have any evidence (documents or anything else) ?
I hear about it first time.

> Look like Mozilla going to help Russian Government to close "iron curtain".

It looks like a global Conspiracy. :)

You should remember that we discuss a _default_ search engine. Use another search engine if you wish.

You can see that Yandex is most popular for russians in Internet. Yandex don't have 100% ... Your opinion is a proof of that. That is why yandex is not a single search engine in firefox.

> Free soft for non-free peoples with non-free search. :(

Google is a free search ?! :)
Comment 24 Vyacheslav Sedov 2009-01-13 03:34:16 PST
>Do you have any evidence (documents or anything else) ?
>I hear about it first time.

Ask any child or teacher. By the way "This bug is marked confidential until the
agreement has been announced publicly" Is it look friendly and open? Why you
think KGB-based Russian Government more open then Mozilla? It was ordinary phone order.

> It looks like a global Conspiracy. :)

Hear it first time too? You know how many journalists killed in Russia every
year? And again you not seen any documented order to kill any of them?

> Google is a free search ?! :)

At least free for use - google not force you to use it with methods similar to
MS Office Open XML propagation - $$ and false. $$ is same "internal research"
written above? Google was set as default search as *best global* search engine.
Why you want russians become local? Maybe Yandex should become global first to
be compared with Google?
Comment 25 Alexey Gladkov 2009-01-13 04:30:20 PST
(In reply to comment #24)
> Ask any child or teacher. By the way "This bug is marked confidential until the
> agreement has been announced publicly" 

Oh. Please use facts ... not gossip. You can not be verified.

> At least free for use - google not force you to use it with methods similar to
> MS Office Open XML propagation - $$ and false. 

Please stop this flood. This has nothing to do with the bug subject.

Again, we are not discussing technologies of MS or others. We are discussing the default search engine (one of several _available_). And the choice is based on popularity. This is a good motivation.

> Maybe Yandex should become global first to be compared with Google?

Again and again, yandex is more popular than google for russians (You showed us the statistics). This is a global search engine for russians.
Comment 26 Shawn Wilsher :sdwilsh 2009-01-13 05:28:09 PST
Shouldn't this "discussion" be taken to the newsgroups?  This bug is about implementing the change...
Comment 27 Kev Needham [:kev] 2009-01-13 06:38:09 PST
Created attachment 356722 [details] [diff] [review]
proposed patch for search plugin and region.properties

Proposed changes.
Comment 28 Vyacheslav Sedov 2009-01-13 07:28:22 PST
this is not flood - just suggestion

Google more popular then Yandex for Linux users in Russia - why Linux build should be affected by this 'patch' too?

look like Chrome have not Linux version yet so should Linux users need to be involved into this mess?

i suggest exclude Linux build from this 'improvement'
Comment 29 Kev Needham [:kev] 2009-01-13 07:35:35 PST
Created attachment 356726 [details] [diff] [review]
proposed patch for search plugin and region.properties

Previous patch wasn't done per MDC recommendations. re-submitting.
Comment 30 Vyacheslav Sedov 2009-01-13 08:19:09 PST
this is not flood - just suggestion

Google more popular then Yandex for Linux users in Russia - why Linux build
should be affected by this 'patch' too?

look like Chrome have not Linux version yet so should Linux users need to be
involved into this mess?

i suggest exclude Linux build from this 'improvement'
Comment 31 Zibi Braniecki [:gandalf][:zibi] 2009-01-13 08:37:52 PST
Vyacheslav: First of all, please, do not spam anymore by sending everyone from the CC list emails. This is impolite.

> Google more popular then Yandex for Linux users in Russia

Can you back this claim by any data? Our data shows the opposite.

> why Linux build should be affected by this 'patch' too?

Because our decision is based on the careful consideration of the best option for our users in Russia, not on any selected platform.

> look like Chrome have not Linux version yet so should Linux users need to be
involved into this mess?

Because the decision has nothing to do with Chrome.

Please, before replying next time to this thread once more, read your comment twice and make sure it has no emotional flavor, is valuable for readers and contains all data to back up any of your claims.
Comment 32 Zibi Braniecki [:gandalf][:zibi] 2009-01-13 08:51:13 PST
FYI. I responded to  Vyacheslav by email explaining him how to avoid such comments in the future and what mistakes he made. Please, do not respond massively to his email to avoid more problems around it. Thanks
Comment 33 Vyacheslav Sedov 2009-01-13 09:57:14 PST
my coworker was angry too when i told to him about this 'bug', especially 'blocking-firefox3.1' flag and 'confidencial' status - i guess  this will be common reaction of Open Source Community to Yandex expansion in their world

Well - lets check Linux stats for Russia

Yandex 

http://www.liveinternet.ru/stat/ru/oses.html?=ru@yandex&slice=yandex&id=10&show=rebuild+graph&per_page=10&report=oses.html%3Fslice%3Dyandex

Google

http://www.liveinternet.ru/stat/ru/oses.html?=ru@Google&slice=Google&id=10&show=rebuild+graph&per_page=10&report=oses.html%3Fslice%3DGoogle

Look like 1 against 3 and probably this one 'linuxoid' use Yandex.Market from time to time to check prices for Asus EEE PC :) I hope Yandex.Market present in this patch. Probably almost 100% linux users use Google as default search and 25% of them sometime use Yandex.Market (as i do until Google implement same functionality).

Site search at http://linuxcenter.ru based on Google too at now (i guess they smart guys and they know what they do)

By the way - Windows Vista users prefer Google too in Russia (most Vista based at home laptops and free from admin`s restrictions), maybe better option is to use Yandex at job and Google at home. Maybe Firefox should have Enterprise Edition packed with Yandex plugin (good oportunity for include XForms plugin too).

to my opinion look like Yandex trying to "sell dead bird to blind boy" 
(c) DUMB & DUMBER 
or if you want more serious comparing "sell burning house"

p.s. this comment was readed by me twice and it not contain emotional flower (really)
Comment 34 Zibi Braniecki [:gandalf][:zibi] 2009-01-13 10:10:55 PST
Vyacheslav: You fail to understand that we are not interested what is browser or OS market share of google vs yandex in Russia beyond oportunnity to promote Firefox among users who don't know about it yet (and more of them seems to be in Yandex market as you mentioned).

> p.s. this comment was readed by me twice and it not contain emotional flower
(really)

Unfortunately it does.

Please, move with your concerns to newgroup, as sdwilsh noted in comment 26 this bug is about implementation of a patch, not discussion on the bowser market share choices. We respect your opinion, but I doubt you will cause anything more than frustration among people on the CC list by your comments.
Comment 35 Vitaly Fedrushkov 2009-01-14 02:46:54 PST
> Shouldn't this "discussion" be taken to the newsgroups?

Relevant discussion:

http://forum.mozilla-russia.org/viewtopic.php?id=29708
Comment 36 Vyacheslav Sedov 2009-01-14 03:22:13 PST
i am banned here - got life-time ban for message about lost dog in flame topic

look like i am born to be victim :(
Comment 37 Mike Beltzner [:beltzner, not reading bugmail] 2009-02-18 14:04:07 PST
Kev: if you want a reviewer for that patch, please prod gavin.sharp@gmail.com or mconnor@mozilla.com for it.
Comment 38 Axel Hecht [:Pike] 2009-02-19 17:59:59 PST
Comment on attachment 356726 [details] [diff] [review]
proposed patch for search plugin and region.properties

r=me, putting this patch on the radar of both Stas and Unghost, too. Stas needs to track this in his paper works.

Reading the initial comment, is there an IT bug that describes what to do for the start page?
Comment 39 Kev Needham [:kev] 2009-02-19 18:20:27 PST
For the start page, we'll be using the standard URL with default arguments. The hostname for the startpage in 3.1 is being changed to <locale>.start3.mozilla.com (see 479240), and ru.start3.mozilla.com has a CNAME entry for firefox.yandex.ru (active now).
Comment 40 Staś Małolepszy :stas 2009-02-20 03:35:18 PST
Comment on attachment 356726 [details] [diff] [review]
proposed patch for search plugin and region.properties

Updated https://wiki.mozilla.org/L10n:Firefox_web_services_status:ru to reflect these changes. I usually do this after the patch lands, but let's make an exception here. I'll keep an eye on the landing.
Comment 41 Alexander L. Slovesnik 2009-02-20 10:12:22 PST
Comment on attachment 356726 [details] [diff] [review]
proposed patch for search plugin and region.properties

r=me
Comment 42 Andrew Jackson 2009-02-23 16:17:49 PST
I don't know if this matters yet, but

you can land this, but

http://ru.start2.mozilla.com/?clid=46512

currently goes to google with the message
The page - www.google.com/?clid=46512 - does not exist.

either the ru.start2.mozilla.com needs a dns record changing so that it goes to yandex or mozilla.com/yandex ? so people running the nightlies have a working startpage?
Comment 43 Staś Małolepszy :stas 2009-02-24 05:17:52 PST
Andrew: see comment 39 and bug 479240.
Comment 44 :Gavin Sharp [email: gavin@gavinsharp.com] 2009-02-26 10:53:52 PST
pushed to l10n-central: https://hg.mozilla.org/l10n-central/ru/rev/88e32d5f2a14
Comment 45 :Gavin Sharp [email: gavin@gavinsharp.com] 2009-02-26 11:24:22 PST
Landed on the release branch as well:
https://hg.mozilla.org/releases/l10n-mozilla-1.9.1/ru/rev/722bd4f64c17

This won't make b3 unless we change the signed-off changeset for ru, though, so I guess I'll omit the fixed1.9.1 keyword for now?
Comment 46 Nick Thomas [:nthomas] 2009-03-01 14:49:08 PST
(In reply to comment #45)
> This won't make b3 unless we change the signed-off changeset for ru, though, so
> I guess I'll omit the fixed1.9.1 keyword for now?

Axel went ahead and did this in bug 480598.
Comment 47 Aakash Desai [:aakashd] 2009-05-21 16:16:56 PDT
verified FIXED On builds: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; ru; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4 ID:20090423191946

Note You need to log in before you can comment on or make changes to this bug.