gDBView.hdrForFirstSelectedMessage doesn't work with standalone message window when .eml is opened

RESOLVED INVALID

Status

RESOLVED INVALID
10 years ago
9 years ago

People

(Reporter: sid0, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
STR:
1. Open an eml file in Tb.
2. Attempt to hide or show header details.

The header pane disappears, because of this error:
JavaScript error: , line 0: uncaught exception: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIMsgDBView.hdrForFirstSelectedMessage]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: chrome://messenger/content/mailWindowOverlay.js :: UpdateJunkButton :: line 1647"  data: no]

Looks similar to bug 470474 / bug 395495 , but I'm having trouble reproducing those two.
(Reporter)

Comment 1

9 years ago
We have a proper message display widget now.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.