Closed Bug 473760 Opened 11 years ago Closed 11 years ago

browser components broken (Can't set default browser, RSS feed has no style information, No default browser dialog anymore, no import of bookmarks)

Categories

(Firefox :: Shell Integration, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED FIXED
Firefox 3.6a1

People

(Reporter: shadow912kage, Assigned: ted)

References

Details

(Keywords: regression)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090115 Minefield/3.2a1pre BuildID: 20090115033950 

Can't set to system defaults browser when press [Check Now] button.

Reproducible: Always

Steps to Reproduce:
1.Open Options dialog, select Advanced panel > General tab
2.Press [Check Now] button in System Defaults

Actual Results:  
Minefield isn't set to System Defaults browser.

Expected Results:  
Minefield is set to System Defaults browser.

on error console:

Error: Components.classes['@mozilla.org/browser/shell-service;1'] is undefined
Source File: chrome://browser/content/preferences/advanced.js
Line: 531
Component: Preferences → Shell Integration
QA Contact: preferences → shell.integration
Version: unspecified → Trunk
Confirmed using
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090115 Minefield/3.2a1pre

Now to figure out what broke this
Status: UNCONFIRMED → NEW
Ever confirmed: true
Is this broken on 1.9.1 branch?
No. That can be checked by installing / running Shiretoko, making sure another browser is set as default, and trying to set as default.
Nothing obvious has changed that would cause this. A regression range would be handy.
Just rebuilt without a clobber and was not able to reproduce this. :(
The following build works
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090113 Minefield/3.2a1pre

SourceStamp=9dbded90af2a
So only packaged builds?
I also just verified that running in dist/bin with changeset 19e319a0647b does work
In case you didn't see it in bug 467862 I'm taking tomorrow off and won't be back until Tuesday so I won't be able to help fix this bug anytime soon
Oops, I broke the browser components. I suspect this has to do with SHORT_LIBNAME.
Summary: Can't set to default browser → browser components broken (Can't set default browser, RSS feed has no style information, No default browser dialog anymore, no import of bookmarks)
Assignee: nobody → ted.mielczarek
Status: NEW → ASSIGNED
Duplicate of this bug: 473929
Duplicate of this bug: 473814
< ./components/browsercomps.dll

Yeah. The browser components are getting built as "browsercomps.dll", but the packaging manifest wants to package "brwsrcmp.dll". Hilarity ensues. I guess I should either fix or remove support for SHORT_LIBNAME. (I'd prefer the latter, actually.)
Wish our unit tests were testing the packaged builds. :-/ (Granted that bug is assigned to me too.)
Pushed a bustage fix, sorry about that:
http://hg.mozilla.org/mozilla-central/rev/28e4291a4892
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
(In reply to comment #19)
> Pushed a bustage fix, sorry about that:
> http://hg.mozilla.org/mozilla-central/rev/28e4291a4892

Checked in same fix to js/src/config to fix TUnit: http://hg.mozilla.org/mozilla-central/rev/865f79b35ebf
Duplicate of this bug: 473955
I've confirmed to fix this issue under Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090117 Minefield/3.2a1pre BuildID: 20090117033728.
thanks all.
This seems to be broken again in build:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090130 Minefield/3.2a1pre

so if anyone can confirm.
WFM with the same build.
Actually it WFM now on a different machine with Vista instead of XP using same build.
Blocks: 543382
Flags: in-testsuite-
Target Milestone: --- → Firefox 3.6a1
You need to log in before you can comment on or make changes to this bug.