Closed Bug 475100 Opened 11 years ago Closed 11 years ago

Change name to "Firefox 3.1 Beta 3" for official branding

Categories

(Firefox Build System :: General, defect, P1, blocker)

3.5 Branch
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 468197
mozilla3.1b3

People

(Reporter: nthomas, Assigned: beltzner)

References

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #467124 +++

and also bug 458895, we need to modify the installer and menubar for b3.
Flags: blocking-firefox3.1?
Target Milestone: --- → Firefox 3.1b3
Summary: Change name to "Firefox 3 Beta 3" for official branding → Change name to "Firefox 3.1 Beta 3" for official branding
Priority: -- → P1
Assignee: nobody → beltzner
Flags: blocking-firefox3.1? → blocking-firefox3.1+
Attached patch suggested patchSplinter Review
Mike, I know you are very busy so if you like I can take this.

Gavin, this should fix the issue you mentioned in bug 467124 comment #3
Attachment #359463 - Flags: review?(gavin.sharp)
Not that it's much important, but doing things this way breaks at least the private browsing mode title magic.  Is there any bug filed to get a better way to do this for each milestone?
For simplifying it for each milestone there is bug 468197 but I don't believe there is a bug to fix the private browsing strings. What specifically is broken with them and do you know a way it can be fixed so this can be done for beta releases?
Inside the private browsing mode, the window title would be: "Mozilla Firefox (Private Browsing) 3.1 Beta 3", which doesn't look right.

The correct way to fix this would probably be to put these strings in another DTD file and just include them inside the browser.  The DTD file doesn't need to go inside the browser/locale/ directory; I bet with some build magic we can see to it that it contains the version number for milestone releases automatically.  If that's not feasible, then the same manual patches to browser.xul can be made on that file.  This way the private browsing code could have a chance to deal with the new entity...
It is fairly trivial to add the beta string automatically to all places that need it which would be done in bug 468197.

Where in the attached patch is "Mozilla Firefox (Private Browsing) 3.1 Beta 3" being set?
(In reply to comment #5)
> Where in the attached patch is "Mozilla Firefox (Private Browsing) 3.1 Beta 3"
> being set?

Sorry I thought the same thing as <http://hg.mozilla.org/mozilla-central/rev/3ed5ca9b8277> is being done here.  I took a closer look and your changes seem fine.  I stand corrected.
Attachment #359463 - Flags: review?(gavin.sharp) → review+
When does Firefox 3.1b3 is going to be launched?

Regards
Note: if bug 468197 is approved for 1.9.1 this patch won't need to land
Whiteboard: [patch ready]
Just landed bug 468197 so this should no longer be needed. Duping this over to bug 468197 seems appropriate.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Whiteboard: [patch ready]
Duplicate of bug: 468197
Flags: blocking-firefox3.1+
Component: Build Config → General
Product: Firefox → Firefox Build System
Target Milestone: Firefox 3.1b3 → mozilla3.1b3
You need to log in before you can comment on or make changes to this bug.