Closed Bug 476343 Opened 13 years ago Closed 13 years ago

Hiding folder pane then switching to message tab and back shows folder pane

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 517244
Thunderbird 3.0rc1

People

(Reporter: beckley, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

Using Thunderbird 3.0b1

STR:
1. Select a folder in the folder pane
2. Drag the folder pane splitter all the way to the left so that the folder pane is hidden
3. Right-click on a message and select "Open Message in New Tab"
4. Click on the first tab

Expected results:
Folder pane remains hidden as it was after step #2

Actual results:
Folder pane is exposed with a small width
Attached patch Suggested fix (obsolete) — Splinter Review
Here's a fix for the problem.  There are two scenarios to worry about.  One is when the splitter (either folder pane or thread pane) is moved all the way to the side, and the other is when the splitter is hidden entirely (which Thunderbird doesn't do, but Penelope does).  The new code looks at the previous state of the splitter and pane, and restores is when switching between mailbox and message tabs.

This also addresses Karsten's concerns in comment 20 of bug 429440 about notifications not being sent when the message pane changes visibility.
Assignee: nobody → beckley
Status: NEW → ASSIGNED
Attachment #360018 - Flags: review?(bugzilla)
I'm having to straighten out a bunch of the horrible issues raised by the tab implementation in bug 474701.  I believe my most recent patch deals with this specific problem in a reasonable fashion.  Namely, we track the state of folder and message pane collapse for each tab.  When opening a new tab, we propagate the state of the 'current' tab (assuming it is a "folder" tab), or failing that, the first "folder" tab.  It makes a lot of the logic more explicit, so I think it feels like the right way to go.

That bug and patch are targeted for beta 2, so I'd just assume we make this bug depend on that one, but if you want to land this in the interim and are fine with it being clobbered, that's good too.
(In reply to comment #2)
> but if you want to land this in the interim and are fine
> with it being clobbered, that's good too.

Yes, I'd like to see this get in, and I'm fine with it being obsoleted with your new code.

Mark, what say ye?
Comment on attachment 360018 [details] [diff] [review]
Suggested fix

Sorry for the delay in reviewing this.

>+      tpSplitter.collapsed = (tpSplitter.getAttribute("substate")? false : true);

nit: the brackets aren't necessary, and insert a space before the ? please.

r=me with that fixed.
Attachment #360018 - Flags: review?(bugzilla) → review+
Attached patch Final patchSplinter Review
Fixed the formatting of the conditional assignment.

Thanks for the review, Mark.

Continuing r=Standard8
Attachment #360018 - Attachment is obsolete: true
Attachment #364112 - Flags: review+
Keywords: checkin-needed
Checked in: http://hg.mozilla.org/comm-central/rev/a22d1919abc0

Thanks for fixing this Jeff.
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.0b3
Depends on: 481331
Hi guys I found this bug after encountering the exact same problem in Thunderbird 3 beta 3. If I move the folders panel all the way to the left, it will reappear after switching tabs. Does this mean this bug should be re-opened?
Yeah, since I clobbered this bug's fix and the fix never saw an actual beta release and the STR are the same, might as well re-open this bug.
Assignee: beckley → nobody
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: Thunderbird 3.0b3 → Thunderbird 3.0rc1
OK, bug 517244 fixes this along with other issues, so I'm going to dup this to that.
Status: REOPENED → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 517244
You need to log in before you can comment on or make changes to this bug.