JavaScript exception when clicking "File" menu of "Write:" window while composing message

VERIFIED FIXED

Status

MailNews Core
Composition
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: IU, Assigned: neil@parkwaycc.co.uk)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(status1.9.2 beta1-fixed, status1.9.1 .6-fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090201 Lightning/1.0pre

When in message "Write" mode (i.e. composing a message or viewing a draft), if
the File menu of the "Write:" (compose) window is clicked, the following
JavaScript exception is generated:

Error: [Exception... "'JavaScript component does not have a method named:
"handleEvent"' when calling method: [nsIDOMEventListener::handleEvent]" 
nsresult: "0x80570030 (NS_ERROR_XPC_JSOBJECT_HAS_NO_FUNCTION_NAMED)"  location:
"<unknown>"  data: no]

This is a regression starting with: Mozilla/5.0 (Windows; U; Windows NT 5.1;
en-US; rv:1.9.1b3pre) Gecko/20081230 Shredder/3.0b2pre


Reproducible: Always

Steps to Reproduce:
1. Click to compose a new message (or open a draft message)
2. Click the "File" menu of that "Write:" (compose) window
3. Observe the exception in Error Console
(Reporter)

Updated

8 years ago
Flags: blocking-thunderbird3?
Keywords: regression
Version: unspecified → Trunk
Summary: avaScript exception when clicking "File" menu of "Write:" window while composing message → JavaScript exception when clicking "File" menu of "Write:" window while composing message

Updated

8 years ago
Duplicate of this bug: 476421

Comment 2

8 years ago
I'm seeing the same with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090203 SeaMonkey/2.0a3pre as soon as opening the
"File" menu in the composition window, thus a Core issue - confirming.

There is also bug 449038 for Firefox, not specific to any menu though.
Status: UNCONFIRMED → NEW
Component: Message Compose Window → Composition
Ever confirmed: true
Product: Thunderbird → MailNews Core
QA Contact: message-compose → composition
(Reporter)

Comment 3

8 years ago
I'm now getting this when I click on any of the menus.
Component: Composition → XPCOM
Flags: blocking-thunderbird3?
Product: MailNews Core → Core

Comment 4

8 years ago
Linux too.
OS: Windows XP → All
QA Contact: composition → xpcom
Hardware: x86 → All
Duplicate of this bug: 519566

Comment 6

8 years ago
Confirming: On all menus of composer. Windows and Linux. German (de) and English (en_us).

Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.4pre) Gecko/20090915 Thunderbird/3.0b4

Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); de; rv:1.9.1.4pre)
Gecko/20090915 Thunderbird/3.0b4

Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.1.4pre) Gecko/20090915 Thunderbird/3.0b4

Comment 7

8 years ago
Regression between two nightly builds found.

Last non bug:
Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.1b3pre) Gecko/20081229 Shredder/3.0b2pre
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2008/12/2008-12-29-03-comm-central/thunderbird-3.0b2pre.en-US.linux-i686.tar.bz2


First it bugged:
Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.1b3pre) Gecko/20081230 Shredder/3.0b2pre
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2008/12/2008-12-30-03-comm-central/thunderbird-3.0b2pre.en-US.linux-i686.tar.bz2
Component: XPCOM → Composition
Product: Core → MailNews Core
QA Contact: xpcom → composition
Neil: I backed out the patch from bug 464914, and the exception goes away. Other than that, the only potentially interesting thing I saw was that it's Windows/Linux only. Apparently the Mac menu code isn't firing whatever at us when we're not there to deal with it.
Blocks: 464914
(Assignee)

Comment 9

8 years ago
Must be some side-effect of the way Compose clones its autocomplete widgets.
But you're right about the menu code, the Mac code is completely different.
(Assignee)

Comment 10

8 years ago
Created attachment 404019 [details] [diff] [review]
Proposed patch

I turned the event listener into its own object so it can detect when the autocomplete element goes away and remove itself automagically.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #404019 - Flags: review?(philringnalda)
Comment on attachment 404019 [details] [diff] [review]
Proposed patch

Seems reasonable to me.
Attachment #404019 - Flags: review?(philringnalda) → review+
(Assignee)

Comment 12

8 years ago
Pushed changeset abe269bb23ef to mozilla-central

Pushed changeset 6757787f9499 to releases/mozilla-1.9.2

Pushed changeset be773dd62e6b to releases/mozilla-1.9.1
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
status1.9.1: --- → .4-fixed
status1.9.2: --- → beta1-fixed
Resolution: --- → FIXED
(Reporter)

Comment 13

8 years ago
Verified fixed.  Thanks

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5pre) Gecko/20091012 Lightning/1.0pre
Status: RESOLVED → VERIFIED
(Assignee)

Updated

8 years ago
status1.9.1: .4-fixed → .5-fixed
(Reporter)

Comment 14

8 years ago
This has regressed again.  Bug exists in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091116 Shredder/3.0.1pre

Don't yet have time to search for a regression window.  Should a new bug be filed?
(Reporter)

Comment 15

8 years ago
Filed Bug 529202
You need to log in before you can comment on or make changes to this bug.