Closed Bug 480180 Opened 13 years ago Closed 13 years ago

Widen the new tab button on OS X

Categories

(Firefox :: Theme, defect, P2)

x86
macOS
defect

Tracking

()

VERIFIED FIXED
Firefox 3.6a1

People

(Reporter: faaborg, Assigned: dao)

References

Details

(Keywords: polish, verified1.9.1, Whiteboard: [polish-easy] [polish-visual][polish-p1])

Attachments

(2 files, 1 obsolete file)

We should make the new tab button on OS X visually 32 pixels wide.  This is similar to other platforms, matches the width of the site and search buttons, and makes the button a little easier to target and hit.  It isn't currently visually 32 pixels wide due to the images we use for tabs on OS X making it appear smaller.  Details in the attached mockup.
Whiteboard: [polish-easy] [polish-visual]
Whiteboard: [polish-easy] [polish-visual] → [polish-easy] [polish-visual][polish-high-visibility]
Summary: Modify visual width of the new tab button on OS X → Widen the new tab button on OS X
Flags: blocking-firefox3.1?
Flags: blocking-firefox3.1? → blocking-firefox3.1+
Priority: -- → P2
Assignee: nobody → dao
Attached patch wip (obsolete) — Splinter Review
Attached patch patchSplinter Review
Attachment #365166 - Attachment is obsolete: true
Attachment #365176 - Flags: review?(gavin.sharp)
Attachment #365176 - Flags: review?(gavin.sharp) → review+
Comment on attachment 365176 [details] [diff] [review]
patch

>diff --git a/browser/themes/pinstripe/browser/browser.css b/browser/themes/pinstripe/browser/browser.css

>-.tabbrowser-tab:not(:hover):not([selected="true"]) > .tab-icon-image,
>-.tabbrowser-arrowscrollbox > .tabs-newtab-button:not(:hover) > .toolbarbutton-icon {
>+.tabbrowser-tab:not(:hover):not([selected="true"]) > .tab-icon-image {
>   opacity: .6;
> }

I don't really see any mention of losing the hover effect in the mockup, but I suppose it is less translucent by default. Alex?
That's based on reverse engineering attachment 364166 [details] -- the icon doesn't seem to be faded there, otherwise it would be really dark (i.e. black) on hover.
>I don't really see any mention of losing the hover effect in the mockup, but I
>suppose it is less translucent by default. Alex?

I can't really find any other instance of a hover effect icon change on OS X (do you know of any?), so I think it makes sense to drop the hover effect.
Keywords: checkin-needed
http://hg.mozilla.org/mozilla-central/rev/8948ec7f8195
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.2a1
Duplicate of this bug: 479869
Verified fix on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090309 Minefield/3.2a1pre
and Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b4pre) Gecko/20090310 Shiretoko/3.1b4pre Ubiquity/0.1.5
Status: RESOLVED → VERIFIED
Blocks: 468839
This bug's priority relative to the set of other polish bugs is:
P1 - Polish issue that appears in the main window, or is something that the user may encounter several times a day.
Whiteboard: [polish-easy] [polish-visual][polish-high-visibility] → [polish-easy] [polish-visual][polish-p1]
You need to log in before you can comment on or make changes to this bug.