"know your rights" is not findable

RESOLVED FIXED in Thunderbird 3.0rc1

Status

RESOLVED FIXED
10 years ago
3 years ago

People

(Reporter: iang, Assigned: standard8)

Tracking

Trunk
Thunderbird 3.0rc1
Dependency tree / graph
Bug Flags:
blocking-thunderbird3 -
wanted-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 3 obsolete attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.6) Gecko/2009011912 Firefox/3.0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090223 Thunderbird/3.0b2

I downloaded the 3.0b2 and was highly encouraged to read the "know your rights" button in a prominent place, bottom right of the window.  This is very good news.

Unfortunately after reading it and closing it, I cannot find it again.  This means it is impossible for me to "know my rights" so the primary purpose has been lost.  Further, because of the arrangement, it is likely to compromise any legal case with a very easy demonstration of how the rights are unknowable to the ordinary person;  it would have been better not being there, and on a web page instead if it is going to be hidden after startup.

Reproducible: Always

Steps to Reproduce:
1.  Start Thunderbird for 2nd time.
2.  Search menus for something about rights.
3.  Find nothing!
Actual Results:  
An ordinary user cannot find the rights.

Expected Results:  
It should be possible to find the Rights page with a click on one top bar menu, and a selection from there.  Perhaps a click on the "About Thunderbird" or under the Help Menu.

I am told that on Firefox the proper way to find this is to type "about:rights" into the URL bar.  This is also unlikely to impress in court;  ordinary users don't know about that feature, and even if they did, are unlikely to be able to navigate it.  Thus the rights are limited to a small set of developers who probably don't need this display anyway.  Hence, the whole thing would look in court as if the developers are denying the users effective understanding of their rights by hiding the description in the geeky areas.

The certification authority business and CA policy area, as managed by Mozilla Foundation and discussed on the dev-security-policy list, is an area that is hyper-sensitive to liabilities because it makes implied but unmeetable claims of security.  It is very important to establish clear limits on liability to all users.  Without these liabilities being clearly limited, Mozilla runs the risk of picking up liability in any area where the certificates fail in their job.
(Assignee)

Comment 1

10 years ago
(In reply to comment #0)
The about:rights was designed to be less "in the face" of the user than presenting them with the previous EULA policies. Maybe we should have made it easier to get at.

> I am told that on Firefox the proper way to find this is to type "about:rights"
> into the URL bar.

The equivalent for Thunderbird is about:rights as the mail start page, which I accept isn't very discoverable.

>  This is also unlikely to impress in court;  ordinary users
> don't know about that feature, and even if they did, are unlikely to be able to
> navigate it.  Thus the rights are limited to a small set of developers who
> probably don't need this display anyway.  Hence, the whole thing would look in
> court as if the developers are denying the users effective understanding of
> their rights by hiding the description in the geeky areas.

If you're saying there's a problem with Firefox, then that needs to be dealt with in a Firefox specific bug.

> Reproducible: Always
> Steps to Reproduce:
> 1.  Start Thunderbird for 2nd time.
> 2.  Search menus for something about rights.
> 3.  Find nothing!
> Actual Results:  
> An ordinary user cannot find the rights.

At the moment I'm thinking of a couple of options:

a) On the About Thunderbird dialog, have a menu button entitled "About" with the options: Rights (about:rights), Contributors (about:credits), Licence (about:licence)
b) In the Help menu, just have one option: About Rights.

I think hiding them away in preferences would be too hidden.

All these options would open a new tab with the appropriate information.

cc'ing various folks for opinions.
Flags: blocking-thunderbird3?
OS: Mac OS X → All
Hardware: x86 → All
Yah, at some point Gerv's going to realize we should have an equivalent of the Fx
(
Licensing information) link in the About window, be nice to get that done more elegantly and before the night of the final string freeze :)
I'm interested in the about:rights button in the about window; that placement seems to make sense to me.  

IANAL (I am not a lawyer) and I don't think anyone else is on this bug is either, but I find the legal arguments pretty ineffective.  I don't think we block the release on this, however I do want to see if we can push something like the about:rights button through.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: wanted-thunderbird3+
Flags: blocking-thunderbird3?
Flags: blocking-thunderbird3-
Version: unspecified → Trunk
The correct fix is for Thunderbird's about:licence page to link to the about:rights page from the APP_LICENSE_BLOCK include at the top of the file, as currently happens on the Firefox trunk. 

http://mxr.mozilla.org/mozilla-central/source/toolkit/content/license.html
http://mxr.mozilla.org/mozilla-central/source/browser/base/content/overrides/app-license.html

But what about getting to about:licence? In Firefox, about:licence is reached from the very top of the scrolling list of credits in the About box, and from "about:". There is no such link on the About box in Thunderbird at the moment. However, before you copy them, I actually think it should be linked more prominently (as the MPL requires), from the front page of the About box rather than the second one.

More specifically, the "Contributors" word should like to about:credits, and then there should be the words "Licensing information", which are linked to about:licence. 

Does that make sense? :-)

Gerv
(Assignee)

Comment 5

10 years ago
(In reply to comment #4)
> The correct fix is for Thunderbird's about:licence page to link to the
> about:rights page from the APP_LICENSE_BLOCK include at the top of the file, as
> currently happens on the Firefox trunk. 

Ok we can do that.

> But what about getting to about:licence? In Firefox, about:licence is reached
> from the very top of the scrolling list of credits in the About box, and from
> "about:". There is no such link on the About box in Thunderbird at the moment.

Actually FF 3.2a1pre has it on the main page of the about box. TB does have it right at the bottom of the credits page (you have to let it scroll!), but it tries to open it in the browser...

> However, before you copy them, I actually think it should be linked more
> prominently (as the MPL requires), from the front page of the About box rather
> than the second one.
> 
> More specifically, the "Contributors" word should like to about:credits, and
> then there should be the words "Licensing information", which are linked to
> about:licence. 

Right, so we should be able to do that. 

> Does that make sense? :-)

Yes.
But note bug 471837 and bug 471838, which are why I liked your menubutton better than the inevitable suggestion of pretend-links in XUL.
Oh, and bug 417733 - trunk Fx currently has a non-modal About on Windows, and nevertheless opens (
Licensing information) in a new window instead of a tab in the opener; we currently have a modal About on Windows, with potential for both UX and widget fun if we open a tab in the window under it.
(Assignee)

Updated

10 years ago
Assignee: nobody → bugzilla
I have no objection to the menubutton solution, although I'd like to see it in action to get a feel for how it would work.

Gerv
(Assignee)

Comment 9

10 years ago
Created attachment 368680 [details]
Prototype Extension

This is a prototype extension I knocked up. It adds a menu button onto the about dialog and opens a tab in the main 3 pane window when the items are selected.

It needs a lot of work to get it to the state that it is ready to go into the main source, but is intended to give an idea of how it would work.

"Lots of work" as in: string fixes, style fixes, bug fixes (e.g. you must have the main 3 pane window open, internal document links don't work correctly) etc.

If folks (I'm thinking Bryan, Phil & Gerv) want to give it a go and give feedback on the general idea, that would be useful. Thanks.
Yep, just how I was picturing it (except I didn't picture not having enough width for two buttons on the credits pane).
I think it looks good.  The about:rights opening in a tab below the window isn't really nice.  I'm not sure what the right path to fixing that is.  But otherwise I think it's worthwhile.
(Assignee)

Updated

10 years ago
Depends on: 489154
(Assignee)

Updated

9 years ago
Depends on: 490817
(Assignee)

Updated

9 years ago
Depends on: 490819
(Assignee)

Comment 12

9 years ago
Created attachment 375175 [details] [diff] [review]
Incomplete patch

This is an incomplete patch for this bug - I haven't got time to work on it now, though I'd really like to see it make TB 3. This patch would need to address the modal about dialog on windows, and we'd also need to make sure we fix the bugs that block this one - bug 490817 (adds about:rights to about:license) and bug 490819 (fixes navigation of about: protocol).
Attachment #368680 - Attachment is obsolete: true
(Assignee)

Updated

9 years ago
Assignee: bugzilla → nobody
Keywords: helpwanted
(Assignee)

Updated

9 years ago
Depends on: 497570
(Assignee)

Updated

9 years ago
Depends on: 498018
(Assignee)

Comment 13

9 years ago
Created attachment 385219 [details] [diff] [review]
Part 1 - about rights and contributors

Given where we are with content tabs, this is step 1, what this does:

- Provides an about menu on the about dialog with Your Rights and Contributors as options.
- Renames the About Shredder button to "Back", something much shorter and means all three buttons can fit on Windows and Linux.
- Always opens about:rights and about:contributors in new windows. This is the same way as Firefox, it gets around the windows issues of a modal dialog, and is at least reasonable.

Something I'm unsure about is the width of the buttons for localised builds. Any thoughts here would be welcome.
Assignee: nobody → bugzilla
Attachment #375175 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #385219 - Flags: ui-review?(clarkbw)
Attachment #385219 - Flags: review?(philringnalda)
Comment on attachment 385219 [details] [diff] [review]
Part 1 - about rights and contributors

not sure about the button width but it looks good in general.
Attachment #385219 - Flags: ui-review?(clarkbw) → ui-review+
Did you get rotted by background tabs? All I get from this is "Error: invalid 'in' operand aArgs" and a new window with a 3pane.
(Assignee)

Comment 16

9 years ago
Created attachment 386105 [details] [diff] [review]
[checked in] Part 1 - about rights and contributors v2

Fixed bustage from the tabs checkin.
Attachment #385219 - Attachment is obsolete: true
Attachment #386105 - Flags: review?(philringnalda)
Attachment #385219 - Flags: review?(philringnalda)
Comment on attachment 386105 [details] [diff] [review]
[checked in] Part 1 - about rights and contributors v2

Feels really weird to open a 3pane behind this tab, but I'd rather see this go in now, and find out what l10n pain we're going to have now, than wait to fight with that.
Attachment #386105 - Flags: review?(philringnalda) → review+
(Assignee)

Comment 18

9 years ago
Comment on attachment 386105 [details] [diff] [review]
[checked in] Part 1 - about rights and contributors v2

Checked in: http://hg.mozilla.org/comm-central/rev/3491ba183bb0
Attachment #386105 - Attachment description: Part 1 - about rights and contributors v2 → [checked in] Part 1 - about rights and contributors v2
(Assignee)

Comment 19

9 years ago
Landed the patch, I'm keeping the bug open to continue the work on about:licence once the contentTab has improved a little bit more.
Keywords: helpwanted
Whiteboard: [rights/contributors landed for b3][license needs work]
Target Milestone: --- → Thunderbird 3.0b4

Comment 20

9 years ago
I realize this is a WIP, but a few observations:
Help>>about shredder>>about contributors, or rights brings up the Tab OK
It also asks if I want to send my unsent email :)
Closing that tab, then no further access to about shredder will come up.
If I use the x to close TB it does not close, but does free up help>>about

It looks like the contributors tab is still there after closing the tab.
I don't have anything set to open tabs in background. (not even sure of that pref)

Also some weirdness with other open tabs getting minimized in an odd fashion when opening the about tabs.
(Reporter)

Comment 21

9 years ago
I just got the 3.02b and now I can see the About / Know your Rights.  Super...

When I click on it, it starts up an entire new instace of the Tb main window.  With need to enter master password.  If I click on the Credits, I get another new window, again ...  I'm guessing this is not intended :)

(Personally I would like to see "Know Your Rights" have it's own button.  That's the amateur lawyer in me wanting high visibility so our job in court is easier.  This feeds into the whole "establish Mozo liability as zero" project in the certificates area.  But this is not something to fight overmuchly.)
(Assignee)

Comment 22

9 years ago
(In reply to comment #21)
> When I click on it, it starts up an entire new instace of the Tb main window. 
> With need to enter master password.  If I click on the Credits, I get another
> new window, again ...  I'm guessing this is not intended :)

The master password bit is bug 483455. At the moment we're keeping the opening of the new window as it doesn't really make logical sense to pull a window from further back in front of the one you're working with.
(Assignee)

Updated

9 years ago
Depends on: 516776
(Assignee)

Comment 23

9 years ago
Created attachment 403238 [details] [diff] [review]
[checked in] Part 2 - Add about:license to the list of about options

This (string!) patch adds the about license menu option to the About button menu. Whilst it may not be as prominent as Gerv wants, at least it is there for now.

Opens a new tab in a main mail window just like the contributor and rights options.

There is an issue that clicking on the links to anchors at the top of the page wants to open the links in a different application rather than jumping to the appropriate section. I think I can solve that in the content tab work, and the strings are the important bit at the moment. Hence I'll file a bug on that when this one goes in.
Attachment #403238 - Flags: ui-review?(clarkbw)
Attachment #403238 - Flags: review?(bienvenu)

Updated

9 years ago
Attachment #403238 - Flags: review?(bienvenu) → review+
Attachment #403238 - Flags: ui-review?(clarkbw) → ui-review+
(Assignee)

Comment 24

9 years ago
Comment on attachment 403238 [details] [diff] [review]
[checked in] Part 2 - Add about:license to the list of about options

Approving my own low risk patch for checkin.
Attachment #403238 - Flags: approval-thunderbird3+
(Assignee)

Comment 25

9 years ago
Comment on attachment 403238 [details] [diff] [review]
[checked in] Part 2 - Add about:license to the list of about options

Checked in: http://hg.mozilla.org/comm-central/rev/73b84c443286
Attachment #403238 - Attachment description: Part 2 - Add about:license to the list of about options → [checked in] Part 2 - Add about:license to the list of about options
(Assignee)

Comment 26

9 years ago
I'm going to declare this bug fixed. We can now get to all the main license and credit related pages from the the about dialog.

Bug 490817 is for adding an about:rights to the license page, which needs bug 516776 fixing first.

It should probably be a litmus test (at least in the first instance) to check that the about pages are working correctly.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Flags: in-litmus?
Resolution: --- → FIXED
Whiteboard: [rights/contributors landed for b3][license needs work]
Target Milestone: Thunderbird 3.0b4 → Thunderbird 3.0rc1
(Assignee)

Updated

9 years ago
No longer depends on: 516776
(Assignee)

Updated

9 years ago
Blocks: 490817
No longer depends on: 490817
(Assignee)

Updated

9 years ago
Blocks: 519667
(Assignee)

Updated

3 years ago
Flags: in-litmus?
You need to log in before you can comment on or make changes to this bug.