Closed Bug 483761 Opened 12 years ago Closed 12 years ago

introduce native look&feel for folder pane, message pane and message view

Categories

(Thunderbird :: Folder and Message Lists, defect)

All
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b3

People

(Reporter: andreasn, Assigned: clarkbw)

References

Details

Attachments

(10 files, 9 obsolete files)

9.88 KB, text/css
Details
4.54 KB, application/x-gzip
Details
2.38 KB, application/x-gzip
Details
581 bytes, image/png
Details
10.00 KB, text/css
Details
969 bytes, image/png
Details
621 bytes, image/png
Details
56.09 KB, image/png
Details
28.19 KB, patch
mkmelin
: review+
Details | Diff | Splinter Review
927 bytes, text/plain
Details
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.7) Gecko/2009030422 Ubuntu/8.10 (intrepid) Firefox/3.0.7 Ubiquity/0.1.5
Build Identifier: 

To make Thunderbird feel more native, the folder pane, message pane and message view needs some adjustments.
* solid borders
* zebra striping in message pane

Reproducible: Always
Attached file modified mailwindow (obsolete) —
#threadTree, #folderTree are set to -moz-appearance: treeview;

and some adjustments to #threadTree treechildren::-moz-tree-row
Added some new icons as well.
Attachment #367745 - Attachment is obsolete: true
Attached file the icons in question
Assignee: nobody → nisses.mail
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: x86 → All
This isn't complete as we'll still need to finish with the column icons, but it's an initial start for anyone who's on hg
Assignee: nisses.mail → clarkbw
Status: NEW → ASSIGNED
Blocks: 415415
Bryan: I just noticed a regression with this. It seems a "}" character is missing on line 379 (the section saying #threadTree treechildren::-moz-tree-row(selected) {
+  background-color: Highlight;), resulting in no icon being displayed on message tabs.
added a new line saying:
+}

I'm pretty bad at this patching business, so please correct me if I screwed up! :)
Attached patch updated patch w/ fix (obsolete) — Splinter Review
Ok I added your fix in.  I think you have to be really careful about the patch format if you're going to hand edit the file.  I don't really know.  I usually just apply, make changes and then remake the patch; even if it's something easy.

There are a couple things left to do, but I'll get to those when I upload a screenshot next.
Attachment #368076 - Attachment is obsolete: true
Attachment #368261 - Attachment is obsolete: true
Attached image message list screenshot (obsolete) —
here's the screenshot of the message list with this patch applied.

Here's what's left to do:

* header icons - b&w and slightly smaller versions of these icons
* new message icon - old one seen in screenshot; we can use the one from bug 483759

With those items done I think we can get this patch applied, even though we may not have larger icon version to replace the ones in the toolbar.  We could also land bug 474523 soonish so the missing larger versions aren't so noticeable.
Whiteboard: [has patch][needs header col and new icon]
Target Milestone: --- → Thunderbird 3.0b3
Version: unspecified → Trunk
Attached file column icons
to go into icons
Attached file updated css (obsolete) —
Realized there was some oddness going on when combined with #484395, since there was a box around the tab area and the 3 pane area. Hope this css works better.
Attached image new message icon
Attachment #370402 - Attachment is obsolete: true
matches the one we use in the header, compose window etc. better
Whiteboard: [has patch][needs header col and new icon] → [needs updated patch]
did you have a replied/forwarded icon for this as well?
I'm still missing a reply + forward icon, but otherwise this patch is ready for review.
Attachment #369561 - Attachment is obsolete: true
wow, completely missed that comment.  will update
Attached patch updated patch w/ all icons (obsolete) — Splinter Review
here's the updated patch w/ the latest reply+forward icon included.

asking magnus for a review here.

will attach screenshot next
Attachment #371469 - Attachment is obsolete: true
Attachment #371473 - Flags: review?(mkmelin+mozilla)
Attached image message list screenshot
here's the updated screenshot against my test inbox
Attachment #369564 - Attachment is obsolete: true
Whiteboard: [needs updated patch] → [needs review]
Comment on attachment 371473 [details] [diff] [review]
updated patch w/ all icons

Overall this is very nice!

The one icon i'm not quite happy with is mail/themes/gnomestripe/mail/icons/message-new.png 
It looks too much like a star imo, and the star or whatever it's supposed to be is slightly off center.

Also there's the issue that Phil mentioned in some other bug: that -moz-image-region speeds things up... It's a PITA but I guess we have to use that. I'll attach a small script shortly that at least partly could help.

>+#threadTree treechildren::-moz-tree-row(selected) {
>+  background-color: Highlight;
> }

Looks like this fixes bug 352833, yay!
Nothing fancy, feel free to improve

~/tmp/imgs$ ./do_collage.sh *.png
-moz-image-region: rect(0px 0px 16px 16px); /* collage.png */
-moz-image-region: rect(16px 0px 32px 16px); /* message-read.png */
File to write to [collage.png]:
Wrote to collage.png
Attachment #372093 - Attachment mime type: text/x-sh → text/plain
actually, this script could be super useful.  nice to know!
Comment on attachment 371473 [details] [diff] [review]
updated patch w/ all icons

Minusing for the -moz-image-region stuff
Attachment #371473 - Flags: review?(mkmelin+mozilla) → review-
Whiteboard: [needs review] → [needs updated patch]
thanks for the script!  that's going to save a lot of time in reworking these patches
Here's the updated patch that uses a single message-list.png image.

I didn't remove the message.png image yet since it's still being used by  Account Central.  Once that page gets reworked we can probably strip this image down to the singe imap-deleted that is left.

And just to note that the do_collage.sh is awesome, but needs the following patch:

@@ -11,9 +11,9 @@
 let h=16;
 
 let top=0;
-let right=w;
+let right=0;
 let bottom=h;
-let left=0;
+let left=w;
 
 let images=$#-1
 for file in ${@}; do
Attachment #371473 - Attachment is obsolete: true
Attachment #372127 - Flags: review?(mkmelin+mozilla)
Whiteboard: [needs updated patch] → [needs review mkmelin]
Fix the bug Bryan found, remove/fix old bogus comments.
Attachment #372093 - Attachment is obsolete: true
Comment on attachment 372127 [details] [diff] [review]
updated patch using moz-image-region

Looks good! r=mkmelin

(with a mumble about message-new.png also not matching the folder icon "red sun", but I'll leave the artistic decisions to others)
Attachment #372127 - Flags: review?(mkmelin+mozilla) → review+
Whiteboard: [needs review mkmelin]
I just realized, I guess we need to put the source images into hg too somehow - otherwise it's a major pain in the future when someone wants to change one of them. Something like in a dir mail/icons/unpackaged/ perhaps?
I was going to do that, however there was a movement to put all the "design" related source artifacts in a separate repository (bug 476008); however my account has yet to be created (bug 476056) so the files are just on my laptop for now.

I'd like to put your script in that same repository if you don't mind.
Sure, feel free to!
changeset:   2375:94ac5164425d
http://hg.mozilla.org/comm-central/rev/94ac5164425d

->FIXED
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Depends on: 488118
Depends on: 503312
You need to log in before you can comment on or make changes to this bug.