Last Comment Bug 415415 - [meta] tango icons for thunderbird linux integration
: [meta] tango icons for thunderbird linux integration
Status: RESOLVED FIXED
: meta
Product: Thunderbird
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All Linux
: -- enhancement with 2 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
https://wiki.mozilla.org/Thunderbird:...
: 416339 tbtango (view as bug list)
Depends on: 495088 406742 472541 482610 482717 482720 483759 483761 483777 484064 484179 484199 484364 484395 484800 485371 490067 492994 496375 507508 508548 509268 509442
Blocks: 284962 389143
  Show dependency treegraph
 
Reported: 2008-02-03 02:11 PST by Jakub 'Livio' Rusinek
Modified: 2011-03-04 11:52 PST (History)
20 users (show)
mkmelin+mozilla: wanted‑thunderbird3+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Screenshot (144.90 KB, image/png)
2008-11-17 02:56 PST, Michael Monreal [:monreal]
no flags Details
userChrome (6.31 KB, application/zip)
2009-01-16 13:37 PST, Michael Monreal [:monreal]
no flags Details

Description Jakub 'Livio' Rusinek 2008-02-03 02:11:23 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.9b3pre) Gecko/2008020204 Fedora/8 (Werewolf) Minefield/3.0b3pre
Build Identifier: version 3.0a1pre (2008020203)

thunderbird cannot be worst than firefox. it also needs a bit of love.

some icons can be copied from bug #381206.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Comment 1 Jakub 'Livio' Rusinek 2008-02-03 02:11:51 PST
also, gtk stock icons should be used where possible.
Comment 2 Magnus Melin 2008-02-03 05:38:51 PST
Confirming. Though we use the same theme for windows and linux currently...
Comment 3 Michael Monreal [:monreal] 2008-02-16 05:36:57 PST
See bug 406742
Comment 4 Magnus Melin 2008-04-26 10:57:03 PDT
*** Bug 430751 has been marked as a duplicate of this bug. ***
Comment 5 Michael Monreal [:monreal] 2008-11-17 02:56:58 PST
Created attachment 348539 [details]
Screenshot

Quickly hacked together, using desktop spec icons.
Comment 6 Jakub 'Livio' Rusinek 2008-11-17 05:16:01 PST
Add patch or whatever you did so someone could take a look, how you did it.

BTW, looks awesome!
Comment 7 Michael Monreal [:monreal] 2008-11-17 05:21:54 PST
It's just a number of overrides in userChrome. Most of the icons are non-gtk stock theme icons so probably a no-no for Thunderbird (-> no fallback icons).

I know that some artists are interested in doing a complete Tango set but what we really need is some "official" word from Mozilla Messaging.
Comment 8 Magnus Melin 2008-11-17 13:21:02 PST
I think we're pretty interested in doing this...
Comment 9 Victor Bielawski 2008-11-17 14:13:37 PST
(In reply to comment #5)
> Created an attachment (id=348539) [details]
> Screenshot
> 
> Quickly hacked together, using desktop spec icons.

Amazing how some GNOME icons can light up Thunderbird. One question: are the separators between toolbars supposed to be missing?
Comment 10 Michael Monreal [:monreal] 2008-11-17 14:48:35 PST
(In reply to comment #9)
> One question: are the separators between toolbars supposed to be missing?

Yes, it's a feature of the Gilouche GTK theme :)
Comment 11 Bryan Clark (DevTools PM) [@clarkbw] 2008-11-17 18:21:33 PST
I'd really love to get a separate linux and windows theme created.  I'm not sure if that's this bug or bug 406742 for making that happen.  My plan had be to push on the Linux theme for the b1 -> b2 timeframe.  I believe we just need someone (magnus?) to create a new linux theme space (gnomestripe?).  I'm comfortable with using the Tango icons in the Windows theme where it makes sense.  The only difference between the Windows and Linux themes will likely be some color palette changes.

Our "official" stance is, lets do it! :)
Comment 12 Magnus Melin 2008-12-01 11:06:58 PST
I just submitted a patch to bug 406742 which creates a gnomestripe theme space - basically hg copy of qute and makefile adjustments. 

But before we apply that we need someone to take care of the actual icons.

Andreas did the firefox ones. IIRC he expressed interest in doing some tango icons for thunderbird too?
Comment 13 Vinicius Depizzol 2008-12-04 09:45:12 PST
What are the specific icons that don't have an icon-naming-spec equivalent?
Comment 14 Michael Monreal [:monreal] 2008-12-04 09:56:21 PST
Vinicius, get a recent TB build, and unzip chrome/classic.jar you will get the idea... Try not to get depressed :)
We really need to iron out the details e.g.:
- can we use non-gtk stock but spec icons? 
- can we use some of the icons created for the old (TB 2.0) tango addon theme?
- create new icons for the public domain tango-icon-library first and reuse them for TB?
Comment 15 Michael Ventnor 2008-12-06 16:40:07 PST
If Thunderbird-GTK is also used on Solaris and/or other non-Linux UNIXes then its probably not a good idea to use non-gtk stock unless those OS's also support the icon spec.
Comment 16 David Ascher (:davida) 2008-12-06 16:52:19 PST
> If Thunderbird-GTK is also used on Solaris and/or other non-Linux UNIXes then
> its probably not a good idea to use non-gtk stock unless those OS's also
> support the icon spec.

I think getting Tb to look great on Linux is priority 1 here.  If we need to do theme or icon development work to make it look good on non-Linux Unices, then that's the subject of follow-on bugs.  I fear that trying to make it look good everywhere to start will slow things down too much.

- can we use some of the icons created for the old (TB 2.0) tango addon theme?

I don't see why not, but I may be missing something.

- create new icons for the public domain tango-icon-library first and reuse
them for TB?

Similarly.
Comment 17 Michael Monreal [:monreal] 2008-12-07 01:55:24 PST
(In reply to comment #16)
> I think getting Tb to look great on Linux is priority 1 here. If we need to do
> theme or icon development work to make it look good on non-Linux Unices, then
> that's the subject of follow-on bugs.  I fear that trying to make it look good
> everywhere to start will slow things down too much.
We don't have any problem if we assume Linux == GNOME or Linux == KDE or even many others. FWIW, same for the *BSDs which use either of those DEs or openSolaris (which uses GNOME by default). We will run into problems with legacy desktops or window manages like fvwm (as well as most of the minimalistic WMs, though.

> I don't see why not, but I may be missing something.
License. Many of the basic icons were in fact taken from the (then) CCBYSA licensed Tango Icon Theme which is now being released under public domain as Tango Icon Library. The TB specific icons (most of them were done by Andreas IIRC) would need to be explicitly relicensed for inclusion in TB (which I assume requires the same license as Fx?)
Comment 18 Lapo Calamandrei 2008-12-07 17:28:45 PST
I'd love a nicelly integrated tb, Michael if you provide me a list of the missing icons, I'll happily work on them. Bonus points for a comparison sheet  with other platforms, like the one Alex used for firefox.
Comment 19 Magnus Melin 2008-12-14 03:47:48 PST
Well, "missing" icons - i suppose that's a matter of opinion... The current icons are found here: http://mxr.mozilla.org/comm-central/source/mail/themes/qute/

... but as Michael points out, it's probably easiest to just get the source and start looking at what's needed, and what is ok as is from a tango prespective.

I'd be glad to help (with the technical part), but I'm not sure what people need.
Comment 20 Michael Monreal [:monreal] 2008-12-14 04:10:22 PST
The most important thing right now would be for the core TB team to decide if fdo spec icons should be used.

ADVANTAGE: most mail related icons (send, forward, reply etc) can be pulled from the system icon theme => less duplication, less work for the designers, more unified look with the desktop theme in use

DISADVANTAGE: on minimal X11 systems, TB would probably look broken. Distribution packages could add a hard dependancy on tango icon theme to make sure a theme is present but the same cannot be done for mozilla.org downloaded packages


If FD.O spec icons are to be used, we could just update the theme and then fix the remaining (mostly minor) icons. If not, redoing all the mail-* spec icons would be the first priority.
Comment 21 Magnus Melin 2008-12-14 04:32:32 PST
What's firefox doing wrt fdo spec icons?
Comment 22 Michael Monreal [:monreal] 2008-12-14 04:41:24 PST
Nothing :)
Firefox makes use of the icons available from GTK. Fortunately, most of the highly visible icons in Firefox (<-, ->, (x) etc) are available in GTK because they are very basic icons.

However GTK does not provide mail related icons, so TB could make better use of the additional icons in FD.o themes.

In the end, only relying on GTK icons and redoing the rest is probably the safest choice, but it means Lapo has to re-draw/fix a lot of mail icons. What do you think, Lapo? :)
Comment 23 Calvin Buckley 2009-01-16 12:06:58 PST
I'd like to see the userChrome file Monreal used to get the native goodness.
Comment 24 Michael Monreal [:monreal] 2009-01-16 13:37:40 PST
Created attachment 357420 [details]
userChrome

Well this will not be helpful for solving the bug properly but as you asked for it... have fun :)

Hopefully someone *cough* Lapo, Hylke *cough* will draw the actual new icons soon :P
Comment 25 Bryan Clark (DevTools PM) [@clarkbw] 2009-03-10 14:40:19 PDT
changing this to a meta tracking bug since it has no real deliverable and I'd like to start making other bugs with real tasks block this bug.  

Leaving as wanted-tb3+ even though I'm not sure if meta bugs can be wanted, I know they can't block.  Dependent bugs will block as necessary.
Comment 26 Ludovic Hirlimann [:Usul] 2010-07-01 04:58:17 PDT
Do we need to keep this meta open ?
Comment 27 Andreas Nilsson (:andreasn) 2010-07-01 05:19:49 PDT
No, I think it's main goal is accomplished, and the two bugs that depends on it are not really related to it. Marking as Fixed.
Comment 28 [:Aureliano Buendía] 2011-03-04 11:52:08 PST
*** Bug 416339 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.