updated tango icon for junk in the junk status header

RESOLVED FIXED in Thunderbird 3.0b3

Status

defect
--
trivial
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: andreasn, Assigned: clarkbw)

Tracking

Trunk
Thunderbird 3.0b3
All
Linux
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.7) Gecko/2009030422 Ubuntu/8.10 (intrepid) Firefox/3.0.7 Ubiquity/0.1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4pre) Gecko/20090318 Shredder/3.0b3pre

Need to update the icon.

Reproducible: Always
(Reporter)

Comment 1

10 years ago
Posted image update icon
to go into mail/themes/gnomestripe/mail/icons/
updated junk icon.

also changed mode from 755 to 644 because it's annoying to have images show up as executable.

This piece is a little out of step as bug 483761 hasn't landed yet.  We also need to get header column icons, see bug 483761 comment 8
Assignee: nobody → clarkbw
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Updated

10 years ago
Hardware: x86 → All
Target Milestone: --- → Thunderbird 3.0b3
Version: unspecified → Trunk
(Assignee)

Updated

10 years ago
Blocks: 415415
(Assignee)

Updated

10 years ago
Attachment #370108 - Flags: review?(mkmelin+mozilla)
Comment on attachment 370108 [details] [diff] [review]
hg patch w/ updated junk icon

I haven't tested this since I first dropped it in there but I can't imagine there would be conflicts on the icon.  Most of the other junk icons have landed except for the toolbar so it'd be good to get this one in as well.

Thanks!
Comment on attachment 370108 [details] [diff] [review]
hg patch w/ updated junk icon

r=mkmelin
Attachment #370108 - Flags: review?(mkmelin+mozilla) → review+
(Assignee)

Updated

10 years ago
Keywords: checkin-needed
Checked in: http://hg.mozilla.org/comm-central/rev/ca8e8499a972
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Flags: in-testsuite-

Comment 6

10 years ago
"Crumpled paper" is a bad metaphor for "junk": it is hardly recognizable at any small size, and it is likely to confuse users.

In real life, you crumple paper when it is not needed, when it contains mistakes, and you throw it away - usually in a trash can or paper recycling bin. Unsolicited mail is usually destroyed or recycled directly, without being opened or [re]used.

In Thunderbird 2.x junk goes into a folder clearly labeled with fire - i.e. "to be destroyed".

The new icon set breaks a common pattern currently visible in most software: crumpled paper appears in the trash icon when you delete items. In TB 3 deleted item are moved to the trash, implicitly becoming crumpled paper, but junk is also shown as crumpled paper, which ends up in the... "crumpled paper container". This has -no- real life counterpart, thus it is non-realistic metaphor which has no grounding in any common concept of visual pattern, and will lead users to confusion.

A good metaphor should suggest that junk is headed for destruction and is -not- related to the trash, since junk is never moved to the trash folder.

Comment 7

10 years ago
Typo, might seriously change the meaning of the sentence: "in any common concept of visual pattern" should read "in any common concept or visual pattern".
You need to log in before you can comment on or make changes to this bug.