Need Additional Message Filter Actions

RESOLVED DUPLICATE of bug 66425

Status

Thunderbird
General
--
enhancement
RESOLVED DUPLICATE of bug 66425
9 years ago
9 years ago

People

(Reporter: Brent Davidson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7
Build Identifier: version 2.0.0.21 (20090302)

This is a feature request.  I would like the ability to add one of the following actions to message filter rules:

1.  Play a sound.  For instance, I have filters set up so when my fax server sends me a fax it goes to a special folder.  I'd like for the system to play a specific sound to let me know that a fax has been received.

2.  Display a dialog box with a custom message.  It would be nice if the dialog box had the option to make it persistent so it has to be manually dismissed.  Example:  My phone system sends voicemail by e-mail.  I would like to add an option to the filter that routes voicemail to a special folder to display a dialog box that says "New voicemail received", and have the box stay on the screen until it is dismissed.

3.  Run an external application on match.  This would allow a user to handle both of the situations above by writing external scripts.

Reproducible: Always
(In reply to comment #0)
> This is a feature request.  I would like the ability to add one of the
> following actions to message filter rules:

1 feature request/bug, please.

> 1.  Play a sound.  For instance, I have filters set up so when my fax server
> sends me a fax it goes to a special folder.  I'd like for the system to play a
> specific sound to let me know that a fax has been received.

bug 438441

> 2.  Display a dialog box with a custom message.  It would be nice if the dialog
> box had the option to make it persistent so it has to be manually dismissed. 
> Example:  My phone system sends voicemail by e-mail.  I would like to add an
> option to the filter that routes voicemail to a special folder to display a
> dialog box that says "New voicemail received", and have the box stay on the
> screen until it is dismissed.

Bug 11037 would be most helpful here, most likely (via window.alert())

> 3.  Run an external application on match.  This would allow a user to handle
> both of the situations above by writing external scripts.

Bug 84039.

I'll just dupe this to the entire "improve filters" meta bug...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 66425

Comment 2

9 years ago
Requests 1) and 3) are currently provided by my FiltaQuilla extension (available on addons.mozilla.org, though in experimental status)

Request 2) would be pretty easy to add. If you want that, please make a request on the FiltaQuilla forum at http://mesquilla.com/forum/filtaquilla/
You need to log in before you can comment on or make changes to this bug.