bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Send Link fails iff Thunderbird is already running

RESOLVED WORKSFORME

Status

Thunderbird
General
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: peter, Unassigned)

Tracking

x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.19) Gecko/20081201 Firefox/2.0.0.19
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8 

File>send link results in an error message from thunderbird if thunderbird is already running.  The dialog says: "Thunderbird is already running, but is not responding.  To open a new window, you must first close the existing Thunderbird process, or restart your system."

If thunderbird is not already running, it opens a composition window and everything works fine.

This problem does NOT occur with FF 2.0.0.20, or any earlier versions.

To verify that it is not trying to open different versions of tbird, I did the following:

1. make sure no tbird running.
2. do file > send link
3. from composition window, open a mail/newsgroups window.
4. close composition window.
5. do file > send link
 result: lossage as described above.

This does occur in safe mode.

I am submitting this as a FF bug, not a TB bug, since other applications do not have this problem.  But, it is possible that TB is not performing as advertised.  This is TB 2.0.0.21

I have already taken the steps mentioned in bug https://bugzilla.mozilla.org/show_bug.cgi?id=470529
and in bug https://bugzilla.mozilla.org/show_bug.cgi?id=483936
without any change.

I note that the following bugs are similar and might actually be duplicates of this bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=434368
https://bugzilla.mozilla.org/show_bug.cgi?id=442918

There are also some others that involve mailto: which might or might not be related.

Reproducible: Always
(Reporter)

Comment 1

9 years ago
Note that this bug is on Win2000, while https://bugzilla.mozilla.org/show_bug.cgi?id=434368 is for Linux, which is the main reason I am submitting it separately.
(Reporter)

Comment 2

9 years ago
After further investigation, I can't reproduce this problem on another (different hardware x86) machine running win2k sp4.

I am now pretty sure this is a problem either with TB or with the particular configuration on the losing machine.  I will change it to a TB bug, and to WFM, until and unless I determine that it truly is a TB bug.
(Reporter)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Component: File Handling → General
Product: Firefox → Thunderbird
Resolution: --- → WORKSFORME
Version: unspecified → 2.0
You need to log in before you can comment on or make changes to this bug.