support alternate OS themes

RESOLVED WONTFIX

Status

Mozilla Labs Graveyard
Personas Plus
RESOLVED WONTFIX
9 years ago
a year ago

People

(Reporter: myk, Assigned: Chris Beard)

Tracking

(Depends on: 1 bug)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
On Windows and Linux, which allow users to change OS themes, Personas only supports the default OS theme.  It sometimes works to some degree with alternate themes, but more often than not it fails, with various elements of the browser window not being styled according to the specifications of the persona, which generally makes the window look pretty bad (see for example this discussion in the forum <https://labs.mozilla.com/forum/comments.php?DiscussionID=5299>).

The modifications that Personas make to Firefox's theme were designed to apply the persona and make it look good on the default OS theme, and they don't work the same on other themes, presumably because the various -moz-appearance rules in the Firefox theme override different aspects of Firefox's appearance on different OS themes.

Making a single set of Personas theme modifications work equally well on two different OS themes is probably hard but doable, so if we thought that the majority of folks having this problem are using Windows Classic on Vista and XP, then we might be able to get things working for just that theme without breaking them too badly for the default theme.

But that still doesn't solve the problem for anyone using any other theme in Windows or Linux.  We need a better solution.  And I think that's bug 486264, which should make it possible for Personas to set the transparency of various elements without unduly interfering with any OS theme.

Setting the dependency accordingly.
(Reporter)

Updated

9 years ago
Duplicate of this bug: 492268
(Reporter)

Updated

9 years ago
Duplicate of this bug: 494673

Comment 3

8 years ago
Created attachment 399267 [details]
Personas applying background image to the status bar as intended, on Windows XP SP3 with default OS theme.

Adding two screenshots: 
Default OS theme <-> OK
Non-default OS theme <-> No background image at status bar.

Comment 4

8 years ago
Created attachment 399269 [details]
Personas not applying background image to the status bar, on Windows XP SP3 with non-default OS theme.

Comment 5

8 years ago
Some themes, like my Nautipolis and LittleFox do actually support the use of Personas.
There should be a way to allow the combination of a Personas 'theme' with a normal 'Theme'. 
When Personas was just an extension this was possible (and still is via the extension), but now that FF3.6 has 'lwtheme' build in, it outcasts existing themes.
This outcasting behaviour is not Mozilla like, and one should allow theme extensions. 
Note, I have been theming Mozilla for 10 years now, ofwhich5 years for FF, and now this is stopped because of this.
I have invested time to support Personas in my themes (with great effect), but now Personas is refusing to support me....

Comment 6

8 years ago
The first thing I do after a Windows installation, beside the usual security stuff, is load the classic theme file I had tuned to my liking since 2002.

I've been using Personas since it came out, but because Groovy Blues uses black text and therefore shows perfectly fine over my light green status bar, I never thought there's anything wrong. I suspected the Windows theme when I noticed the coloured status bar on the work computer with default XP theme, but it was minor so I didn't really care.

Recently I noticed there's an option to display random Personas from my favourites, which wasn't available before (which was why I stuck with Groovy Blues for two years). Then the status bar thing became an issue for me because there's now Personas with dark background/light text that I liked, so half the time I would have to squint to read the status bar when the randomness fell on any such Personas.

I got fed up after a few days and search for a solution. Now I'm a happy user of the Personas Windows Classic Statusbar add-on. The only grip I have is that it's an experimental add-on so I'd have to update it manually whenever Firefox is updated.

Since Personas will be part of 3.6, I think it would be a good idea to get this straightened out. Surely there's more people out there like me who can't stand the default Windows theme?
This is now handled via Firefox. If this is still an issue please open a bug under Firefox -> Theme.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 506331
Duplicate of this bug: 540994
Product: Mozilla Labs → Mozilla Labs Graveyard
You need to log in before you can comment on or make changes to this bug.