Gmail IMAP messages marked as deleted no longer disappear (When "Just mark it deleted", deleted mail of read X icon is not removed until "expunge" operation)

RESOLVED INVALID

Status

Thunderbird
General
RESOLVED INVALID
9 years ago
6 years ago

People

(Reporter: myk, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
A few weeks ago, Thunderbird stopped removing messages in my Gmail IMAP account after I delete them.

The account is configured with "When I delete a message:" set to "Just mark it as deleted", as recommended by Google, and Thunderbird appears to correctly mark the message as deleted, as it strikes through the message and places a "deleted" icon next to it, but the message never disappears from the folder in which it is located.

I've tested this behavior with two folders, Inbox and [Gmail]/Spam, and I see the same behavior with both.  Before a few weeks ago, those messages disappeared from those folders after I marked the messages deleted and then reopened the folder or restarted Thunderbird.

Comment 1

9 years ago
It was a TB bug that the messages got removed in the first place, since fixed - if you chose the mark as deleted mode, that means you sign up for doing the occasional expunge/compact to get rid of messages marked as deleted. There's now a toolbar item you can add to expunge the current folder.

I don't really recommend using the "mark as deleted" model, unless you like it. I'm not sure what interop bug(s) caused Google to recommend it, but, for me at least, they're easier to live with than the mark as deleted mode.

Comment 2

9 years ago
removing dependency - my inclination would be to mark this as invalid - I guess there's an education issue about how the mark as deleted mode is supposed to work, but it's really a geeky mode that Google is recommending on unsuspecting  users.
No longer blocks: 402793
(Reporter)

Comment 3

9 years ago
(In reply to comment #1)
> It was a TB bug that the messages got removed in the first place, since fixed -
> if you chose the mark as deleted mode, that means you sign up for doing the
> occasional expunge/compact to get rid of messages marked as deleted. There's
> now a toolbar item you can add to expunge the current folder.

Ah, I guess this bug is invalid then.


> I don't really recommend using the "mark as deleted" model, unless you like it.
> I'm not sure what interop bug(s) caused Google to recommend it, but, for me at
> least, they're easier to live with than the mark as deleted mode.

I've been using it because Google recommended it and I didn't know any better.  Also, it seemed to behave similar to how I expect message deletion to behave, in that the messages disappeared from the folder from which I deleted them (albeit after a delay) and then appeared in the Trash folder (but perhaps I was mistaken; that doesn't appear to happen now when I manually Compact the folder).
(In reply to comment #2)
> I guess there's an education issue about how the mark as deleted mode is supposed to work,
> but it's really a geeky mode that Google is recommending on unsuspecting users.

To David Bienvenu.

This bug is spin-off of a phenomenon in bug 482337 comment #12 by Myk. (and my #15). As Myk says, "mark as deleted model" is written as recommended option in some Google Help documents and user written Web pages. It's the reason why Myk tried the delete model when he(or she) saw funny phenomenon with Gmail IMAP.
Further, dangerous description is found in MozillaZine KB document...
>(for account definition via ordinal "Account Wizard" for IMAP)
> http://kb.mozillazine.org/Using_Gmail_with_Thunderbird_and_Mozilla_Suite
> Enter "[Gmail]" (without the quotes) in "IMAP server directory".
> This works around a bug in how it displays the folders.

I think description like next is required in Release Notes.
> If you want to use Gmail IMAP, define account via "Account Wizard for Gmail IMAP" instead of ordinal "Account Wizard for POP3/IMAP".
> If domain name in your country is other than "gmail.com"(e.g. "googlemail.com"), change server name and domain name part of mail address manually after definition. 
> If you use Gmail's Display Language other than English(US), change folder path choice for Drafts, Sent, Trash, Junk etc. manually. (See bug 476260 for improvement of it).
> If you use option other than preset option(such as "delete model"), execute it  with your own risk after reading Gmail Help documents well.

Do you know any good document in Mozilla Wiki or MozillaZine KB about Tb's "delete model"?

Comment 5

9 years ago
Bug 476260 should help improve our gmail interoperability. I'm not sure how it would interact with setting the imap server directory to "[Gmail]" though.

I don't know of any end-user documentation about the imap delete model.
Adding "Just mark it deleted" in summary, for ease of search.
Summary: Gmail IMAP messages marked as deleted no longer disappear → Gmail IMAP messages marked as deleted no longer disappear (When "Just mark it deleted", deleted mail of read X icon is not removed until "expunge" operation)
To David Bienvenu:

I think;
> (A) "Just mark it deleted" + "delete a mail via Gmail IMAP"
> is nearly equals to
> (B) "Just mark it deleted" + "delete a mail via ordinal IMAP" + "expunge by other client"
User has to do "expunge"(compact operation) manually(or by option for automatic-expunge such as "empty trash on exit"), even when (B)?

Updated

8 years ago
Duplicate of this bug: 590898
I don't know if this was the case when this bug was opened, but Gmail has an auto-expunge option on the server side. This bug should be closed.

Comment 10

6 years ago
Yes, i think this is working as intended.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.