Folder unread counts not updating correctly until moused over

RESOLVED FIXED in Thunderbird 3.0b3

Status

Thunderbird
Mail Window Front End
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: standard8, Assigned: Bienvenu)

Tracking

({regression})

Trunk
Thunderbird 3.0b3
All
Mac OS X
regression
Bug Flags:
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Tested on: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b5pre) Gecko/20090513 Lightning/1.0pre Shredder/3.0b3pre

Steps to repeat:

1) Have some new mail in newsgroup, read it (using space to advance through messages, and having it automatically marked as read)
2) Get to the last message and read the last message

Result:
- Folder Pane still says 1 new message, space doesn't select more messages or asks to go onto the next folder.

Moving the folder pane or selecting another message fixes it.

Alternate steps to repeat:

1) Have some new mail in newsgroup, select the newsgroup
2) Right click -> Mark as read.

Result:
- Folder pane still says the original number of unread messages as per step 1.

Moving the folder pane or selecting another message fixes it.
Flags: blocking-thunderbird3?
(Reporter)

Comment 1

9 years ago
Oh, and I think I may have seen something similar on imap and/or local folders, hence the question mark on newsgroup.

Comment 2

9 years ago
I saw the same thing today, using the automatic Shredder update, on mail folders. What I noticed is that the unread count was not updated when the actual message "unread" changed (as noted by the bolding change in the thread pane, which occurs after a 1 second delay on my system) but only when I moved to a new message.

So the only (small) difference from your report is that the behavior exists on every message, not just the last unread message.
Mozilla/5.0 (Windows; U; Windows NT 6.0; sk; rv:1.9.2a1pre) Gecko/20090513 Minefield/3.6a1pre

This applies to *all* folders in folder pane (including POP3 and IMAP accounts, newsgroups and feeds). Noticed this in yesterdays nightly for the first time. Hovering folder name in folder pane fixes the unread count.
(Assignee)

Comment 4

9 years ago
I'll look into this. It's most likely one of the recent folderPane changes.
Assignee: nobody → bienvenu
Status: NEW → ASSIGNED
(Assignee)

Comment 5

9 years ago
Created attachment 377403 [details] [diff] [review]
proposed fix

my bad for not catching this at review time - w/o the braces, we return out before invalidating the row.
Attachment #377403 - Flags: review?(philringnalda)
(Assignee)

Updated

9 years ago
Flags: blocking-thunderbird3? → blocking-thunderbird3+
Whiteboard: [has patch for review]
Target Milestone: --- → Thunderbird 3.0b3
(Assignee)

Comment 6

9 years ago
caused by fix for bug 466644
Depends on: 466644
Comment on attachment 377403 [details] [diff] [review]
proposed fix

The inline comments are cute, but not cute enough to make up for how confusing (and, clearly, error-prone) the last one is. r=me with all three condition-comments moved up before the if - anyone who can't figure out which comment goes with which condition in

// We only want to rebuild if:
// - foo
// - bar
// - baz

if (foo &&
    bar &&
    baz) {

probably needs more help than just inline comments will provide :)
Attachment #377403 - Flags: review?(philringnalda) → review+
Duplicate of this bug: 492990
Summary: (Newsgroup?) folder counts not updating correctly → Folder unread counts not updating correctly until moused over
Whiteboard: [has patch for review]
Duplicate of this bug: 493003
(Assignee)

Comment 10

9 years ago
fixed, with inline comments extracted
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.