Not all links are clickable in the message window

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: Stephen, Unassigned)

Tracking

Trunk
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1b4) Gecko/20090427 Fedora/3.5-0.20.beta4.fc11 Firefox/3.5b4
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1b3pre) Gecko/20090324 Fedora/3.0-2.1.beta2.fc11 Lightning/1.0pre Thunderbird/3.0b2

I have received an email (in this case an update from a Bugzilla bug). In it, not all of the links are clickable.

The links auto-generated as part of the header and footer of the bug update are clickable, but links entered into the bug comment appear clickable (and flash red when clicked on), but don't trigger the host system to send that URL to the configured browser (in my case, Firefox (Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1b4) Gecko/20090427 Fedora/3.5-0.20.beta4.fc11 Firefox/3.5b4).

Right-clicking on the link and selecting "Copy link location" works, and I can paste that link successfully into Firefox.

Reproducible: Always

Steps to Reproduce:
Easiest to reproduce with Bugzilla updates
1. Receive an email from Bugzilla where someone has included a URL in the bug update comment.
2. Click on the URL in the comment.
3. Observe that the web browser is not invoked.
Actual Results:  
The link flashes red for a moment, and then nothing else happens.

Expected Results:  
The link should flash red and Thunderbird should invoke the system command to load the URL into the configured browser.
(Reporter)

Comment 1

9 years ago
Created attachment 377662 [details]
.eml file exhibiting the bad behavior
The given email is WFM on os X.

Magnus do you see the same issue ?
Version: unspecified → Trunk
(Reporter)

Comment 3

9 years ago
Agreed, I just verified that this behavior is not present on OSX as well. It appears to be unique to the Linux build (or possibly to Fedora). I will investigate further.

Comment 5

9 years ago
No response, ->WFM

Might be a problem with default browser settings, and/or extensions
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

9 years ago
Sorry, request for information fell into my SPAM folder for some reason.

I think it's actually a bug in Fedora, not Thunderbird (as I'm seeing similar behavior in some other programs)

I will open a bug there instead.
(Reporter)

Comment 7

9 years ago
Sorry, I'm reopening this. I realized this morning that it matters what type of links they are. All https:// links work properly, but http:// links do not.

Could you folks retest, making sure that you test with both http:// and https:// links? Also, please disregard my previous message, the similar behavior I was seeing was an unrelated issue.

I am using the following version right now:
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1b3pre) Gecko/20090513 Fedora/3.0-2.3.beta2.fc11 Lightning/1.0pre Thunderbird/3.0b2

I have the following add-ons:
FolderPane Tools 0.0.5.1 (Disabled because it's not compatible with TB3)
Lightning 1.0pre (from Fedora 11 repos)
Provider for Google Calendar 0.6pre (nightly from 6/5/09)
Remove Duplicate Messages (Alternate) 0.3.2
Reply to mailing list 0.3.1 (Disabled because it's not compatible with TB3)
Zindus 0.8.10
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 8

9 years ago
Just to update this bug, I am not the only person seeing this behavior. The bug https://bugzilla.redhat.com/show_bug.cgi?id=490308 against Fedora has been opened. I directed them here as well.

Has there been any movement on this issue? It's extremely inconvenient.

Comment 9

9 years ago
I tomorrow's linux nightly you'll get the changes from bug 446291. 
ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-1.9.1/

In the attachments preferences pane, type in https and then type in http and check the settings for those. (Sounds like the https is wrong for you.)

Comment 10

9 years ago
(In reply to comment #8)
> Just to update this bug, I am not the only person seeing this behavior. The bug
> https://bugzilla.redhat.com/show_bug.cgi?id=490308 against Fedora has been
> opened. I directed them here as well.

The RHBZ bug you suggested is not about this issue. You probably have problem with xdg-open command handling https:// uri. Please try to test it in your terminal by following command: 

xdg-open https://www.paypal.com

If it does not open the page in browser you probably have mis-configured Gnome preferred applications. Try to use 'gnome-default-applications-properties' to reset default browser to your favourite.

You may find bug https://bugzilla.redhat.com/show_bug.cgi?id=489120 relevant to your issue. You can also reopen this bug if you still have problems.
(Reporter)

Comment 11

9 years ago
xdg-open http://www.paypal.com -> works
xdg-open https://www.paypal.com -> works

Clicking https://www.paypal.com in the bug update email I just got -> works

Clicking http://www.paypal.com in an email I just sent myself -> DOES NOT WORK.

This is not an xdg-open issue.

Comment 12

9 years ago
Please check also pref variable: 

network.protocol-handler.app.http 
network.protocol-handler.app.https

(You may find

Comment 13

9 years ago
Please check also following pref variables: 

network.protocol-handler.app.http 
network.protocol-handler.app.https

You may find these values in Edit/Preferences/Advanced/Config Editor.
(Reporter)

Comment 14

9 years ago
Both network.protocol-handler.app.http and network.protocol-handler.app.https have the following value:
/usr/lib64/thunderbird-3.0b2/open-browser.sh
(Reporter)

Comment 15

9 years ago
Just looking for an update on this issue. It's by far the most jarring bug in Fedora Thunderbird.
(In reply to comment #15)
> Just looking for an update on this issue. It's by far the most jarring bug in
> Fedora Thunderbird.

Well it's seems to be working for many of us. In comment #11 where you using the build recommended by  Magnus in Comment #9 ?

Question not asked before what happens if you run thunderbird in -safe-mode ?

Comment 17

9 years ago
Created attachment 393593 [details]
Reproduced

Hi, this is a lowly Fedora bug triager speaking. I have managed to reproduce this bug even with your binary from 
ftp://ftp.mozilla.org/pub/thunderbird/nightly/latest-comm-1.9.1/thunderbird-3.0b4pre.en-US.linux-i686.tar.bz2

See attached email which I created with it. Particular account where I sent the bug from has "Compose HTML messages" and Options/Format/ was on Auto (which is a default, isn't it?).

Not only the email was sent in plain text (which probably could be explained by that Auto option), but http://www.google.com page was not attached and cid: URL included points to nowhere.

Comment 18

9 years ago
(In reply to comment #17)
sorry wrong tab, should go to bug 509541

Comment 19

9 years ago
bug 389732 ?

Comment 20

8 years ago
Stefan, Jason, Matej  can you reproduce this in version 3.1?

Comment 21

8 years ago
Hi Wayne

I've no idea why you Cc'ed me to this ticket - I don't think I've reported any issue like this. Have you got your "Jason"s mixed up?

Comment 22

8 years ago
Didn't experience such a thing lately, and have been running 3.1.x for quite some time now. Might be resolved?

Comment 23

8 years ago
(In reply to comment #20)
> Stefan, Jason, Matej  can you reproduce this in version 3.1?

I haven't seen this for a long time either.
WFM based on comment 23  and comment 22
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.