IMAP folders more than 2 deep not listed in folder list

RESOLVED DUPLICATE of bug 506095

Status

Thunderbird
Folder and Message Lists
--
major
RESOLVED DUPLICATE of bug 506095
9 years ago
8 years ago

People

(Reporter: P Nienaber, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090514 Minefield/3.6a1pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1pre) Gecko/20090523 Shredder/3.0b3pre

Right about the same time Shredder sprouted support for Spotlight (maybe 3 weeks ago), it stopped displaying folders (and tree-expansion arrows) more than 2 levels deep, so at most I see account > folder > folder.  This appears to happen on all configured IMAP accounts (including one gmail one), but does not affect local folders.  Creation of new subfolders also does not result in those folders being shown in the tree.  The folders appear and are already checked in Manage Folder Subscriptions.

Reproducible: Always

Steps to Reproduce:
1. Set up IMAP account with some deep folders.
2. Update Shredder.
3. Try to find those folders...
Actual Results:  
No folders, no expansion triangles, nada.
(Reporter)

Comment 1

9 years ago
Interesting.  After confirming that the Manage Folder Subscriptions dialog displayed affected folders, SOME of my folders (I think a max of 3-deep now) are being displayed, but I can't seem to get more of them going beyond that...
(Reporter)

Comment 2

9 years ago
I take that back, sort of.  Just viewed a folder 3-deep (account > folder1 > folder2 > folder3), which had a sibling which was also being displayed at the time.  This resulted in Shredder apparently trying to get headers for the folder, and then suddenly removing both of the 3-deep folders from the tree again, as well as the other ones elsewhere that had mysteriously reappeared.
Nienaber, can you try getting a protocol log and attaching it?

https://wiki.mozilla.org/MailNews:Logging
(Reporter)

Comment 4

9 years ago
As soon as I try to do something fancy like viewing parts of the folder tree in the Folder Subscription dialog I end up with a 2.5-6MB log with verbosity 5 -- would a lower level still provide sufficient information, or should I grep (-v) for anything or compress this?
(Reporter)

Comment 5

9 years ago
The interesting thing here is that I can unsubscribe from all folders (and upon restarting shredder, it still tells me I'm unsubscribed from everything), and yet I still see everything, but only 2-deep, so obviously it's completely ignoring what folders it's subscribed to, and this may be the root of this problem.

Updated

9 years ago
Keywords: regression
(Reporter)

Comment 6

9 years ago
This is still happening (at least without blowing out my profile) in 3.0b3.  Can anyone give details as to what logging level is sufficient to investigate this problem -- as I mentioned before using 5 generates enormous multi-megabyte logs.
P Nienaber, "still occurs" only comment like comment #6, which has no additional and valuable findings such as comment #5, will produce nothing.
First, get IMAP log and check whether same issue as Bug 506095 Comment #6 or not.
Second, check whether "Show only subscribed folders" is relevant or not to your problem. (See Bug 495975, Gmail IMAP case, and Bug 506095, non Gmail IMAP case) 

(In reply to comment #6)
> as I mentioned before using 5 generates enormous multi-megabyte logs.

Because folder subscription related issue(around LIST or XLIST), there is no need to get log data of mail download.
Get log of imap:5 with; 
 - Disable offline use option of all mail folders
   (Done by single unclick of "Keep message for this account on this computer". )
   (To enable auto-sync again, click "Keep message for this account on this     )
   ( computer", and disable offline use of some folders via "Advanced" button. )
 - Disable automatic mail check (at startup, every NNN minute)
 - After restart of Tb, click a small folder(force first login)
   => LIST, XLIST etc. is issued.
(Reporter)

Comment 8

9 years ago
Confirmed that this works correctly (minus the convenience of being able to select which folders I see) with "Show only subscribed folders" disabled, exactly as in 495975.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 495975
(In reply to comment #8)

> exactly as in 495975.

Gmail IMAP?
XLIST was really supported by your IMAP server and is really used by Tb?
(Reporter)

Comment 10

9 years ago
Created attachment 392676 [details]
tbird using xlist

Yes, this is with GMail IMAP.  There are no arrows next to folders e.g. Business/Companies despite them having \HasChildren
> Yes, this is with GMail IMAP.

Roger. If you attached log in June, that bug would be closed as DUP of this bug :-)
(Reporter)

Comment 12

9 years ago
The one other thing worth serious investigation here is the fact that tbird ignores folder subscription settings entirely, so this is likely an issue with whatever code applies those to the tree of available folders to determine which folders are actually displayed (as also indicated by the "Show only subscribed folders" workaround).
Duplicate of bug: 506095
(In reply to comment #12)
> The one other thing worth serious investigation here is the fact that
> tbird ignores folder subscription settings entirely, (snip)

It's Bug 493455.
You need to log in before you can comment on or make changes to this bug.