Cannot unsubscribe newsgroup (Error: server is undefined)

RESOLVED FIXED in Thunderbird 3.0b3

Status

Thunderbird
Folder and Message Lists
--
major
RESOLVED FIXED
9 years ago
5 months ago

People

(Reporter: whimboo, Assigned: Magnus Melin)

Tracking

({regression})

Trunk
Thunderbird 3.0b3
regression
Bug Flags:
blocking-thunderbird3 +
in-litmus +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1pre) Gecko/20090603 Shredder/3.0b3pre ID:20090603024723

Today I tried to unsubscribe from a couple of newsgroups and selected the unsubscribe entry from the context menu of such newsgroups. I'm getting ask if I'm really sure to delete it and I answered with yes. But the newsgroup doesn't get deleted. Instead the following error appears in the Error Console:

Error: server is undefined
Source File: chrome://messenger/content/mailCommands.js
Line: 282

Right now, I have it tested on OS X only but could be x-platform.
Flags: blocking-thunderbird3?
Probably a regression from one of the recent context menu bugs. Magnus and I seem to like fixing these up between us, so assigning to him hoping he'll take this on.
Assignee: nobody → mkmelin+mozilla
Flags: in-litmus?
Flags: blocking-thunderbird3?
Flags: blocking-thunderbird3+
Target Milestone: --- → Thunderbird 3.0b3
Oh and I expect we have litmus tests for subscribing to newsgroups, so it should be easy for adding/extending one for unsubscribe.
(In reply to comment #2)
> Oh and I expect we have litmus tests for subscribing to newsgroups, so it
> should be easy for adding/extending one for unsubscribe.

We have 5686 which is kind of empty.

added https://litmus.mozilla.org/show_test.cgi?id=7776 for unsubscribing.
Flags: in-litmus? → in-litmus+
Unsubscribe works with:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b5pre) Gecko/20090509 Lightning/1.0pre Shredder/3.0b3pre

build ID 20090509024840

Unsubscribe fails with the Error Console error from:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b5pre) Gecko/20090510 Lightning/1.0pre Shredder/3.0b3pre

build ID 20090510024918
Keywords: regressionwindow-wanted
http://hg.mozilla.org/comm-central/pushloghtml?startdate=2009-05-09+02%3A40%3A00&enddate=2009-05-10+02%3A50%3A00

The regression range only comprises 3 bugs, and bug 296655 seems to be a likely candidate.
Blocks: 296655
(Assignee)

Comment 6

9 years ago
I think jminta is going to fix this in bug 493156
Depends on: 493156
OS: Mac OS X → All
Hardware: x86 → All

Comment 7

9 years ago
unsubscribe not working for about month for me. I've not tried unsubscribe before May, so maybe even more than month. 
Problem appears to be only when you select menu unsubscribe by right clicking on appropriate news group. Error will not show up if you select newsgroup and press delete then press ok to delete.
(Assignee)

Comment 8

9 years ago
Created attachment 385165 [details] [diff] [review]
proposed fix

Bug 496273 isn't moving forward soon, so let's get this part fixed.
Attachment #385165 - Flags: review?(bugzilla)

Comment 9

9 years ago
In the current nightly (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090629 Lightning/1.0pre Shredder/3.0b3pre ID:20090629032928) this is what I find:

* pressing delete then OK, does not work, and does not produce an error in the console.  
* right click on a newsgroup and select Unsubscribe, I get a popup asking if I'm sure.  When I say yes, the popup goes away yet the newsgroup stays subscribed.  Error in console (server is undefined)
* right click on the parent group (eg news.mozilla.org) and select Subscribe.  Then navigate through the long list and uncheck the group I want to remove, it finally goes away.
Attachment #385165 - Flags: review?(bugzilla) → review+
(Assignee)

Comment 10

9 years ago
changeset:   2976:1dee0f0e5012
http://hg.mozilla.org/comm-central/rev/1dee0f0e5012

->FIXED
Status: NEW → RESOLVED
Last Resolved: 9 years ago
No longer depends on: 493156
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.