The default bug view has changed. See this FAQ.

Remove locale-specific subdomains from SeaMonkey client-generated URLs

RESOLVED FIXED in seamonkey2.1a1

Status

SeaMonkey
General
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: Robert Kaiser, Assigned: sgautherie)

Tracking

({fixed-seamonkey2.0.3})

Trunk
seamonkey2.1a1
fixed-seamonkey2.0.3
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 3 obsolete attachments)

(Reporter)

Description

8 years ago
This is the SeaMonkey version of bug 454300. In particular, we're still seeing the bug 488856 problem with the URLs from http://hg.mozilla.org/comm-central/file/default/suite/locales/en-US/chrome/branding/brand.properties and getting a cert error on in-client URLs is quite lame...
I know support for *.add-ons.mozilla.org was never completely official, but it worked well enough for some time.
In any case, we need to switch to other URLs, apparently preferably plain addons.mozilla.org ones, but bug 471834 has open questions as to what to change them to (i.e. it's unclear where/if the version will still be used in the URLs).
Flags: blocking-seamonkey2?
(Reporter)

Updated

8 years ago
Depends on: 488856
Dupe of bug 488856?
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> Dupe of bug 488856?

No, as the bug there is fixed but we still have URLs like that in the tree, which are covered here now.

Comment 3

8 years ago
An example would be https://en-US.add-ons.mozilla.org/en-US/SeaMonkey/2.0/extensions/
(Reporter)

Comment 4

8 years ago
(In reply to comment #3)
> An example would be
> https://en-US.add-ons.mozilla.org/en-US/SeaMonkey/2.0/extensions/

Actually, that was my fault, I got some cases wrong. A better example is https://en-us.add-ons.mozilla.org/en-US/seamonkey/2.0/themes/ - and this happens to be what View > Apply Theme > Get New Themes is calling currently.

If we just change the .org to .com, it works, see https://en-us.add-ons.mozilla.com/en-US/seamonkey/2.0/themes/ (the page that comes up looks bad because of bug 513227 but that's on the AMO side).

Comment 5

8 years ago
Need this for 2.0 final.
Flags: blocking-seamonkey2? → blocking-seamonkey2+
(Reporter)

Comment 6

8 years ago
BTW, the other links - besides the themes one from the View menu - are not exposed in the UI any more, extensions.js does this:

  var showGetMore = false;
  var getMore = document.getElementById("getMore");
  if (prefURL && !gShowGetAddonsPane) {
    [... set showGetMore to true on other conditions ...]
  }

as gShowGetAddonsPane is always true for us - we show the "Get Add-ons" pane - we never show the links in add-ons manager, and that's the place they would be there for (we just re-used one of them in the view menu).
(Reporter)

Updated

8 years ago
Whiteboard: [l10n-impact]
(Reporter)

Updated

8 years ago
Depends on: 517596
(Reporter)

Comment 7

8 years ago
I moved the part that actually blocks 2.0 to bug 517596 - this will stay here for removing the locale-specific domains later.
Flags: blocking-seamonkey2.0+
Whiteboard: [l10n-impact]
Target Milestone: seamonkey2.0 → ---
(Assignee)

Updated

7 years ago
Assignee: nobody → sgautherie.bz
Status: NEW → ASSIGNED
Depends on: 454300
Target Milestone: --- → seamonkey2.1a1
(Assignee)

Updated

7 years ago
(Assignee)

Comment 8

7 years ago
Created attachment 415890 [details] [diff] [review]
(Av1) Update the urls to their current redirections
Attachment #415890 - Flags: review?(kairo)
Comment on attachment 415890 [details] [diff] [review]
(Av1) Update the urls to their current redirections

Use the words for the types like in the Firefox patch. Don't use the actual type numbers.
Attachment #415890 - Flags: review?(kairo) → review-
(Reporter)

Comment 10

7 years ago
Comment on attachment 415890 [details] [diff] [review]
(Av1) Update the urls to their current redirections

>-#define seamonkey_l10n  
>+#define seamonkey_l10n 
> 
> # LOCALIZATION NOTE (seamonkey_l10n_long):
> # insert full bookmark line for localized SeaMonkey page (normal bookmark)
>-# e.g. #define seamonkey_l10n <DT><A HREF="http://www.seamonkey.tld/">tlhIngan Hol SeaMonkey</a>
>-#define seamonkey_l10n_long  
>+# e.g. #define seamonkey_l10n_long <DT><A HREF="http://www.seamonkey.tld/">tlhIngan Hol SeaMonkey</a>
>+#define seamonkey_l10n_long 

...and don't change the whitespace on those #defines, from all I remember, that space is actually necessary for this to work correctly. Nice catch on the comment, though. :)
(Assignee)

Comment 11

7 years ago
Created attachment 415896 [details] [diff] [review]
(Av2) Update the urls to their current redirecting aliases, Fix some nits too

Per comment 9.

brand.properties:
*I dropped the 'extensions/' part too, per current redirection and to be in sync' with the 2 other files.
*Can't we replace '%LOCALE%/%APP%' by 'en-US/seamonkey' like in bookmarks.inc?
Attachment #415890 - Attachment is obsolete: true
Attachment #415896 - Flags: review?(kairo)
(Assignee)

Comment 12

7 years ago
Created attachment 415899 [details] [diff] [review]
(Av2a) Update the urls to their current redirecting aliases, Fix some nits too

Per your comment 10.
See my comment 11 too.
Attachment #415896 - Attachment is obsolete: true
Attachment #415899 - Flags: review?(kairo)
Attachment #415896 - Flags: review?(kairo)
(Reporter)

Updated

7 years ago
Duplicate of this bug: 532644
(Reporter)

Comment 14

7 years ago
Comment on attachment 415899 [details] [diff] [review]
(Av2a) Update the urls to their current redirecting aliases, Fix some nits too

>-# LOCALIZATION NOTE (seamonkey_themes):
>-# link title for https://en-US.add-ons.mozilla.com/en-US/seamonkey/themes
>-#define seamonkey_themes SeaMonkey Themes

No reason to move that one around, please leave it where it was.

> # LOCALIZATION NOTE (seamonkey_l10n):
>+# (Double-)Space value is needed as-is by default.

That comment is confusing for localizers, please just leave it out. If localizers actually use this line to define something non-empty, they want a single space to separate the key and value, else they should just leave it unchanged to what en-US has.
Attachment #415899 - Flags: review?(kairo) → review-
(Assignee)

Comment 15

7 years ago
What about my comment 11 question?
(Reporter)

Comment 16

7 years ago
Only bookmarks.inc can use 'en-US/seamonkey', if you mean that, because it's just comments there. Everything else needs to go with the '%LOCALE%/%APP%' stuff, esp. because all locales can use exactly the same values and get the right thing.
(Assignee)

Comment 17

7 years ago
Created attachment 415959 [details] [diff] [review]
(Av3) Update the urls to their current redirecting aliases, Fix some nits too
[Checkin: Comment 18 & 19]

Per your comment 14.

Thanks for the explanation/confirmation.
Attachment #415899 - Attachment is obsolete: true
Attachment #415959 - Flags: review?(kairo)
(Reporter)

Updated

7 years ago
Attachment #415959 - Flags: review?(kairo) → review+
(Assignee)

Updated

7 years ago
Attachment #415959 - Attachment description: (Av3) Update the urls to their current redirecting aliases, Fix some nits too → (Av3) Update the urls to their current redirecting aliases, Fix some nits too [Checkin: Comment 18]
Attachment #415959 - Flags: approval-seamonkey2.0.1?
(Assignee)

Comment 18

7 years ago
Comment on attachment 415959 [details] [diff] [review]
(Av3) Update the urls to their current redirecting aliases, Fix some nits too
[Checkin: Comment 18 & 19]


http://hg.mozilla.org/comm-central/rev/663c9fb21ea2


"approval-seamonkey2.0.1=?":
Should really be wanted, unless these urls are considered l10n strings...
(Assignee)

Updated

7 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Updated

7 years ago
Attachment #415959 - Flags: approval-seamonkey2.0.2+
Attachment #415959 - Flags: approval-seamonkey2.0.1?
Attachment #415959 - Flags: approval-seamonkey2.0.1-
(Assignee)

Comment 19

7 years ago
Comment on attachment 415959 [details] [diff] [review]
(Av3) Update the urls to their current redirecting aliases, Fix some nits too
[Checkin: Comment 18 & 19]


http://hg.mozilla.org/releases/comm-1.9.1/rev/e62adbd5b4f7
Attachment #415959 - Attachment description: (Av3) Update the urls to their current redirecting aliases, Fix some nits too [Checkin: Comment 18] → (Av3) Update the urls to their current redirecting aliases, Fix some nits too [Checkin: Comment 18 & 19]
(Assignee)

Updated

7 years ago
Keywords: fixed-seamonkey2.0.2
You need to log in before you can comment on or make changes to this bug.