Thunderbird can get into a state where account central shows up for every folder

VERIFIED FIXED in Thunderbird 3.0b3

Status

VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: standard8, Assigned: asuth)

Tracking

(Blocks: 1 bug, {regression})

Trunk
Thunderbird 3.0b3
All
Mac OS X
regression
Bug Flags:
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
I've noticed two things that are probably related:

1) When switching to an IMAP folder that is empty, account central briefly shows up. This is probably best seen just after startup when you're still opening connections etc, but it does it every time I enter an empty IMAP folder.

2) If you catch it just right, and I believe fast switching of folders on gmail IMAP (probably because its a slightly bigger delay for me) triggers it, then you can get Thunderbird into a state where it will show account central for *any* folder.

Opening a folder in a new tab at this time gives you normal behaviour.


Nothing useful in error console.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1pre) Gecko/20090613 Lightning/1.0pre Shredder/3.0b3pre
Flags: blocking-thunderbird3+

Comment 1

9 years ago
I ran into a similar problem with the 20090613 Shredder nightly build under Vista home premium SP1 after dragging and dropping a message to a folder and selecting a folder that had messages in it. 

The main difference is that besides displaying account central whenever I selected a folder it also changed the server directory in tools -> account settings -> server settings -> advanced to [Gmail] in every IMAP account and saved that change in prefs.js. I had no problem removing that change.
Same as Mark's #1 for me. Haven't seen #2 (Exchange IMAP on Corp LAN <1ms away) or Eric's scenario. 

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1pre) Gecko/20090615 Shredder/3.0b3pre
(Reporter)

Comment 3

9 years ago
(In reply to comment #2)
> Same as Mark's #1 for me. Haven't seen #2 (Exchange IMAP on Corp LAN <1ms away)
> or Eric's scenario. 

With my ISP's IMAP server it is much harder to reproduce than with gmail.
(Assignee)

Comment 4

9 years ago
(In reply to comment #0)
> 1) When switching to an IMAP folder that is empty, account central briefly
> shows up. This is probably best seen just after startup when you're still
> opening connections etc, but it does it every time I enter an empty IMAP
> folder.

This was sortof intentional, but not really.  Per the legacy code, we do not enter some folders[1] until a call to updateFolder completes.  The old code used to leave the previous view displayed through this 'limbo' time, but because of our normalized control flow and invariants, we end up displaying account central.

I expect we can probably get away with entering empty IMAP folders early and should do so.  The account central thing is probably fine for the dubious mail.password_protect_local_cache pref.

1:
http://mxr.mozilla.org/comm-central/source/mailnews/base/src/dbViewWrapper.js#922
Assignee: nobody → bugmail
Status: NEW → ASSIGNED
(Assignee)

Updated

9 years ago
Duplicate of this bug: 498810
(Reporter)

Updated

9 years ago
Duplicate of this bug: 498947
(Assignee)

Comment 7

9 years ago
Created attachment 383828 [details] [diff] [review]
do not let view update depth get out of wack v1

This only handles Standard8's 2nd case.  The 1st needs to be spun off into its own bug.

The view update depth would get above 0 if you switch folders before the FolderLoaded notification showed up.  Then you would never ever see a view again.  The patch addresses this in multiple ways, adds some documentation, and a unit test.
Attachment #383828 - Flags: superreview?(bienvenu)
Attachment #383828 - Flags: review?(bienvenu)

Comment 8

9 years ago
Comment on attachment 383828 [details] [diff] [review]
do not let view update depth get out of wack v1

this definitely fixes the quick selection of imap folders case
Attachment #383828 - Flags: superreview?(bienvenu)
Attachment #383828 - Flags: superreview+
Attachment #383828 - Flags: review?(bienvenu)
Attachment #383828 - Flags: review+
(Assignee)

Comment 9

9 years ago
pushed: http://hg.mozilla.org/comm-central/rev/7b0473b45719

Standard8's first point has been spun off to bug 499069, which depends on changes bienvenu is making on bug 499064 to support immediate folder entry.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

9 years ago
Verifying that I can't make account central stay on the screen any more.
Status: RESOLVED → VERIFIED

Comment 11

9 years ago
Perhaps this fix caused an unintended bug with date based Sorts?

https://bugzilla.mozilla.org/show_bug.cgi?id=499238
You need to log in before you can comment on or make changes to this bug.