Closed Bug 505067 Opened 10 years ago Closed 10 years ago

Right clicking opens a new empty toolbar and right click (context menu) stops working [Yahoo! Toolbar]

Categories

(Firefox :: Extension Compatibility, defect)

3.5 Branch
defect
Not set

Tracking

()

VERIFIED INVALID

People

(Reporter: Michael, Unassigned)

References

()

Details

(Keywords: common-issue+, Whiteboard: [caused by Yahoo Toolbar] )

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1

I'm not sure if this is OSX specific, but in Firefox 3.0, I never had this issue occur.  But, not I'm running 3.5 on OSX, so hard to tell when the bug formed.

When I right click on a web page, (doesn't matter where, just anywhere on a web page), an extra bar appears at the top of the Firefox window.  See screen shot before.  Top is before Right Click, Bottom is After.

http://img.photobucket.com/albums/v288/Mike4824/Image-2.jpg 

Reproducible: Always

Steps to Reproduce:
1. Open up any web page
2. Right click anywhere on the web page.
Actual Results:  
A random, gray bar appears at the top of the window

Expected Results:  
Not display a random gray bar.
Attached image Shows the gray bar.
Comment on attachment 389338 [details]
Shows the gray bar.

Didn't realize I could add an attachment here.  Feel free to delete link in post.
Attachment #389338 - Attachment description: Didn't realize I could add an attachment here. Feel free to delete link in post. → Shows the gray bar.
Version: unspecified → 3.5 Branch
Could be caused by an add-on. Please try safe-mode to find out: http://support.mozilla.com/en-US/kb/Safe+Mode
Alright, it was fixed when I tried safemode, so I tried to figure out which extension was causing it.  Turns out it was Yahoo! Toolbar.  Disabled now.  Thanks!
Michael, when you enable the extension again and check the View | Toolbars menu is the Yahoo Toolbar listed there? If yes, does disabling and enabling help? Is the Yahoo Toolbar displayed correctly at all or cant you see it?
Component: Menus → Extension Compatibility
QA Contact: menus → extension.compatibility
The toolbar is working fine, without any issues.  Yes, it does appear in View-->Toolbars.  When I disable it this way, then right click, the bar still appears.

When I open a new window via "command n", the bar is absent in the new window.  However, as soon as I right click, it reappears.
Thank. So one remaining question. Which version are you using? Yahoo! Toolbar 1.6.6.20090220?
2.0.0.20090622040742
Ok, so this is one of the reported issues an AMO too. I tested it myself and can also see this behavior. Further the right click stops working afterward. This really looks like an extension issue. Let's mark it invalid. I have notified the developers via a comment on AMO.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → INVALID
Summary: right clicking opens a new, extra panel → Right clicking opens a new empty toolbar and right click stops working [!Yahoo Toolbar]
Status: RESOLVED → VERIFIED
Whiteboard: [caused by Yahoo Toolbar]
Duplicate of this bug: 506435
Summary: Right clicking opens a new empty toolbar and right click stops working [!Yahoo Toolbar] → Right clicking opens a new empty toolbar and right click stops working [Yahoo! Toolbar]
Duplicate of this bug: 507602
OS: Mac OS X → All
Hardware: x86 → All
Summary: Right clicking opens a new empty toolbar and right click stops working [Yahoo! Toolbar] → Right clicking opens a new empty toolbar and right click (context menu) stops working [Yahoo! Toolbar]
Bug 501879
Bug 503460
Bug 504076
Bug 507827
look like this too
Keywords: common-issue?
Whiteboard: [caused by Yahoo Toolbar] → [caused by Yahoo Toolbar]
More, Bug 493191
Bug 496064
Bug 498812
bug 499434
Bug 501171
Some of those may not be, but this really spiked with 3.5
Duplicate of this bug: 501879
It really looks like a wide spread problem with 3.5. I have contacted Yahoo again via a web form. Let's see if we get a feedback. Chris, do we have a direct contact to Yahoo we could use otherwise?
Duplicate of this bug: 504076
Definitely a common issue.
All my old contacts at Yahoo have moved on.  ss and/or kev might have some ideas.
I don't have anyone on that team. I think Kev has a contact on the Yahoo! Toolbar team though.
Duplicate of this bug: 462475
I see a yahoo-inc address here, so I'm assuming Yahoo knows about this bug, but if not, ping me and I can forward it to the correct team.
I'd forward anyway, can't hurt.  We may not have contacts in the right places.
Blocks: 506994
Duplicate of this bug: 510658
Duplicate of this bug: 510787
First of all thanks bringing into our notice. 
We were unable to reproduce the scenario described in the bug. Can some give me specific scenario to produce this. Does latest release on toolbar.yahoo.com fixes this issue?
I notice it whenever I am trying to copy html code.  For instance, at Webshots to use a picture in a blog elsewhere.  Suddenly, my right-click menu is gone.  I have the latest release and it still does it.
I'm not able to see the issue anymore. Not with the latest 2.0 version but neither with 1.6.6.20090220. Is anyone able to reproduce this problem? If yes, please tell us if the new version on toolbar.yahoo.com fixes your problem. Thanks!
Again, I have the latest version and the bug still happens.
I checked for updates from the Addon menu, and no updates were available.  I went to toolbar.yahoo.com, and downloaded the latest version.  It seems that the issue is now gone.  I can right click without any issues.
I tried downloading from toolbar.yahoo.com and the problem appears to be resolved for me.
Duplicate of this bug: 511055
Duplicate of this bug: 511632
Duplicate of this bug: 511727
If the current version fixes this and people are still hitting it with the old, then maybe blocklisting the old version on Firefox 3.5 is in order? Seems to be very common and a particularly problematic breakage.
filed  Bug 513021
Duplicate of this bug: 496064
Duplicate of this bug: 498812
Duplicate of this bug: 503460
Duplicate of this bug: 517059
Duplicate of this bug: 521174
You need to log in before you can comment on or make changes to this bug.