Closed Bug 50523 Opened 20 years ago Closed 20 years ago

Update Name of null plugin

Categories

(Core :: Plug-ins, defect, P3)

defect

Tracking

()

VERIFIED FIXED
mozilla0.9

People

(Reporter: bugzilla, Assigned: BenB)

References

Details

(Whiteboard: [remind][rtm-])

Attachments

(1 file)

When right-clicing on the NPNUL32.DLL file in the plugins directory you can get 
the see in the Version tab that the file says it's copyrighted by Netscape, 
1997, etc...

This should be updated to say something about Mozilla instead!

The code for the copyright stuff:
http://lxr.mozilla.org/mozilla/source/modules/plugin/default/windows/npnul32.rc#
76
The file name ought to be changed as well ("np" obviously stands for "Netscape
plugin", when what we really mean is "Mozilla plugin"), but that probably
deserves a different bug report.

This might not *quite* be an API issue, but it's close enough. Making a blocker
for bug 35548.
Blocks: 35548
bradne, do you have an CVS account? If yes, just fix it right away.
Taking bug.
OS: Windows 2000 → All
Hardware: PC → All
Summary: Update Version info on NPNUL32.DLL → Update Name of null plugin
No longer blocks: 35548
Attached patch Fix, version 1Splinter Review
av, please review <http://www.bucksch.org/1/projects/mozilla/review.html>. The
Win32 change is untested - I have no Win32 build environment. Please test it,
including <about:plugins> and the DLL info.
Blocks: 14532
Status: NEW → ASSIGNED
Keywords: review
Changes look OK to me. I applied it on Windows, and everything works fine. a=av
av, who should give a review?
I think to get the fix in you should escalate the bug and get rtm+ status in the 
Whiteboard, then send it to the team of reviewers as described on the top of the 
tinderbox page.

Nominating for rtm.
Keywords: rtm
*** Bug 55790 has been marked as a duplicate of this bug. ***
Erm, we're in the process of rewriting the plugin to be XPCOM instead of n4.x, 
I'll make sure that it doesn't say netscape assuming we've decided to rename 
the plugin "Mozilla Default Plugin" or would we prefer for the plugin to be 
polymorphic "&Branding; Default Plugin" [i'm not sure of the correct entity but 
you get the point].

Marking [remind] because i'll need to check on this when an xpcom null plugin 
lands.
Whiteboard: [remind]
ETA?
Andrei, please make sure you don't spend more than five minutes on this bug. We
have numerous outstanding plug-in bugs that actually cause user-visible failures
(crashes, PDT forms not submitting, RealPlayer not working, QuickTime failing to
display) so we absolutely can't afford to be spending your time on this bug
until we're certain that all these other bugs that actually harm users will get
fixed for RTM. (We could live with the erroneous copyright issue for RTM;
Netscape won't enforce a copyright notice that was asserted by accident and it
could be fixed after RTM. Sounds like you'll fix that during the XPCOM rewrite
anyway though. BTW, what's the motivation for the XPCOM rewrite at this point?)
Many thanks to all who are working on this bug; if you can reassign the bug to
yourself and handle the check-in for Andrei, many thanks!
ops, I thought, it were assigned to me. Taking bug again.

timeless doesn't know when he'll get to rewrite the backend. It surely might be
a good idea, because the old one is Netscape-centristic (unsurprisingly).
Anyway, we should get this in before mozilla0.9.

ekrock, Netscape might be in hot times, but it also has responsibilities towards
mozilla.org. There are distributions other than Netscape 6, and the world
doesn't stop while Netscape is busy. But I think, av's part in this bug is done.
Assignee: av → mozilla
Status: ASSIGNED → NEW
Target Milestone: --- → mozilla0.9
Whiteboard: [remind] → [remind][rtm-]
These changes seem reasonable; av built on Windows ... so, sr=scc.
scc, I now have a=av and sr=scc collected. Do I need an r=?
As I understand it, no.  Since av has super-review powers for this module, and I
have super-review powers in general, you can count either one of as the reviewer
and the other as the super-reviewer.  One review + one super-review is enough
for an external contributor to check into the trunk (normal open-and-green rules
still apply, of course).
Checked in.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Verified.
The plugin properties now says mozilla.org as company name, etc....
Status: RESOLVED → VERIFIED
Please verify for Linux and Windows. The changes are not XP.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
verified on windows trunk 1128. I looked in the properties menu option for the 
null plugin on linux but there is no specific name mentioned. Looks ok..unless I 
missed something.Marking VERIFIED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.