Closed Bug 505705 Opened 11 years ago Closed 11 years ago

Window layout position and columns not remembered after each exit (using Vertical view, width, persist)

Categories

(Thunderbird :: Folder and Message Lists, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b4

People

(Reporter: koubekk, Assigned: standard8)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [no l10n impact])

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Thunderbird/3.0b3

After upgrade to Thunderbird 3.0 beta 3 (keeping my old profile) the window layout position and list columns are always forgotten when restarting the application. No matter how much I stretch the windows and columns, with each restart it returns to its previous position.

The problem occurs when using the Vertical view. When using the Classic or Wide view, the layout position and columns are remembered. I've even tried wiping out my profile and creating a new one with a single POP3 account. The same problem persists.

Reproducible: Always

Steps to Reproduce:
1. Create a new clean profile and setup some account
2. Switch to the Vertical View layout and change the default window size proportions 
3. Restart Thunderbird and see the layout come back to the default state
Actual Results:  
The window layout position is not remembered with each application restart.

Expected Results:  
The application should remember the window layout position.
Yes, the above behavior is confirmed for Thunderbird 3.0 beta 3
Duplicate of this bug: 506086
Thank you, Aureliano Buendía, for correcting my misplacement of this bug.

/DeLorean75
Can confirm this on MacOS X 10.5.7 Intel. 
Clean profile and beta3 - same thing.
Duplicate of this bug: 502987
Flags: blocking-thunderbird3?
OS: Windows XP → All
Confirming based on comments and duplicates.

Usability issue, so I think we should block on this.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-thunderbird3? → blocking-thunderbird3+
Target Milestone: --- → Thunderbird 3.0b4
Duplicate of this bug: 506828
Keywords: regression
Hardware: x86 → All
Confirming the same issue on Ubuntu with TB 3.0b3. This is not applicable with TB 2.0.0.22 as the position and columns are remembered.
Duplicate of this bug: 509371
Adding width and persist to summary to make finding in search easier.
Summary: Window layout position and columns not remembered after each exit (using Vertical view) → Window layout position and columns not remembered after each exit (using Vertical view, width, persist)
Whiteboard: [no l10n impact]
I have a fix in progress for this.
Assignee: nobody → bugzilla
Attached patch The fixSplinter Review
The folder pane re-factoring altered the structure of the thread pane slightly - there's now an extra vbox surrounding the threadTree and a few other things. So we need to persist the width of that vbox to fix this bug.

We could probably remove the persist from the threadTree, but I'm concerned about causing more persist regressions if I do that ;-)
Attachment #396707 - Flags: review?(philringnalda)
Whiteboard: [no l10n impact] → [no l10n impact][needs review philor]
Attachment #396707 - Flags: review?(philringnalda) → review+
Checked in: http://hg.mozilla.org/comm-central/rev/5554873e7cef
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Whiteboard: [no l10n impact][needs review philor] → [no l10n impact]
Duplicate of this bug: 512767
This bus seems to be back with a vengeance in today's build[1]. Regression!?

REOPEN ?

BTW: This bug doesn't only happen in Vertical View (I use Classic View). Please fix the Subject.

[1] Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090911 Lightning/1.0pre Shredder/3.0b4pre

PS. I always remove the "Read" column (who needs this? The Subject is already *bold*) and add the (essential) "Size" column, and every day Thunderbird reverts back to the default columns (+Read and no Size).
(In reply to comment #15)
> This bus seems to be back with a vengeance in today's build[1]. Regression!?

If it is a regression something else has caused it.

> REOPEN ?

NO

> BTW: This bug doesn't only happen in Vertical View (I use Classic View). Please
> fix the Subject.

That especially means it *isn't* this bug. This bug was *only* about the vertical view when it was open. Please file a new bug as is the normal practice.
(In reply to comment #16)
> (In reply to comment #15)
> > BTW: This bug doesn't only happen in Vertical View (I use Classic View). Please
> > fix the Subject.
> 
> That especially means it *isn't* this bug. This bug was *only* about the
> vertical view when it was open. Please file a new bug as is the normal
> practice.

Well, this bug did fix the same problem in my "Classic View"... :-\

Anyhow, I've just filed bug 516145 for the new issue.
You need to log in before you can comment on or make changes to this bug.