Account Settings Window Is Too Tall to Fit Monitor Screen

RESOLVED FIXED in Thunderbird 49.0

Status

MailNews Core
Account Manager
RESOLVED FIXED
8 years ago
8 months ago

People

(Reporter: andreasn, Assigned: Magnus Melin)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

Trunk
Thunderbird 49.0
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird48 fixed, thunderbird49 fixed, thunderbird_esr4549+ fixed, seamonkey2.45 fixed, seamonkey2.46 fixed)

Details

(URL)

Attachments

(4 attachments, 2 obsolete attachments)

(Reporter)

Description

8 years ago
Created attachment 391880 [details]
Ubuntu running in Virtualbox

It appears the dialog gets cut off in 800x600 under Copies & Folder

Comment 1

8 years ago
xref bug 416263.
(Assignee)

Updated

8 years ago
Blocks: 416263

Comment 2

6 years ago
600 lines (vertical pixels) is an increasing, not decreasing condition, because Netbooks and Pads of 10.5 diagonal inches were available with 720 lines in 2009 but these have been withdrawn from the market for strategic reasons. 
The worst effect of this is the "Manage Identities" button, which is actually REMOVED when the "Account Settings" window is maximised into 600 lines. It can only be pressed by "guesswork tabbing" when it is present but invisible off-screen.
Please prioritise this bug.

Comment 3

6 years ago
This issue still exists in Thunderbird v5 
I have installed in my Ubuntu 11.04 from the mozillateam repository.
The "Manage Identities" button is off-screen in the normal window, removed when maximised into 1024x600.

Comment 4

6 years ago
Created attachment 575529 [details]
screen-shot on Ubuntu 11.10 and Thunderbird 10.0a2 with 1280x800 screen

The problem is really critical, not only on 800x600, but also 1280x800!!!

Updated

6 years ago
Summary: Copies & Folders in Account settings gets cut off on Linux in 800x600 → Copies & Folders in Account settings gets cut off on Linux in 800x600 and 1280x800

Updated

6 years ago
Blocks: 702199

Comment 5

6 years ago
So what is the official minimum screen size to target? Where can we find documentation?
Keywords: uiwanted
(Assignee)

Comment 6

6 years ago
Probably h=600 or 800, but making the account manager smaller than it already is wouldn't be nice for larger screens. I think the right hand pane should get vertical scrollbars when needed, but that may be harder to do than it sounds.
I don't think we have an official minimum screen size, but I will say that our netbook designs were targeted for 1024x570 (https://wiki.mozilla.org/Thunderbird/Netbooks/Designs/Add-ons/Thunderbird_Air), so our official non-netbook minimum would likely be larger than that…  I'm asking people if we have any data on the screen sizes of Thunderbird users so that we can see how big the average screen is.  If we don't have that data, we'll try to get it from a Test Pilot run.

Later,
Blake (currently running on a 1440x900 laptop ;).

Comment 8

6 years ago
The other point to keep in mind is that OS dialog fonts vary among platforms and depend on the desktop theme used, thus content may be cut off in one configuration but shows up fine in another. I'm not sure to which extent - if at all - those settings are considered in the current implementation (specifications in "em" should consider such already). A more generic solution such as scrollbars would cover all fringe cases, though they may be an annoyance if showing up too often.

Comment 9

6 years ago
Thanks Blake. It seems that netbook design may solve the problems in the related bugs. And the standard design would not need to be changed.
However probably not all users will find that addon (once it exists) and they still may not like the layout. But good to know there something in the planning.
And it turns out we don't have the data on screen sizes.  :(
But I've upgraded to a 1680x1050 laptop.  :)

Aceman: Perhaps we could offer to install the add-on if the user had a screen of less than a certain size?  The other main problem is that the core team doesn't have a lot of spare time to work on it, so it's sort of slowed down until someone from the community picks up development…  (It is kind of nearing the limit of its growth, too, so a rewrite might not be a terrible idea.)

Thanks,
Blake.

Comment 11

6 years ago
You mean the development of the addon?
Yep.

Updated

5 years ago
Blocks: 760454

Updated

5 years ago
No longer blocks: 760454
Duplicate of this bug: 760454

Comment 14

5 years ago
What is the name of the addon? Is it released?
Nothing comes up under "netbook" in addon search.

This bug is still critical for "Manage Identities" - I can only use that button if I use screen-scaling to increase my resolution (temporarily because almost unreadable) because there are still no scroll-bars in Ubuntu latest Thunderbird and "Manage Identities" is selectively removed on maximizing the dialog.
(In reply to Mike Yates from comment #14)
> What is the name of the addon? Is it released?

TbAir, and I don't think it was ever released…
http://bwinton.github.com/TbAir/ is a url to some info.
This issue also affects the very common laptop resolution 1366x768, effectively cutting off the "OK" button. I'm running Ubuntu 13.04 (Raring) with default font sizes in Unity.

For anyone who doesn't know how to Alt+Click move windows, this is pretty scary.
Created attachment 762577 [details]
Screenshot of Account Manager with 1366x768 resolution in Unity for Ubuntu 13.04 (sv_SE locale, default everything)
(Assignee)

Comment 18

4 years ago
Comment on attachment 391880 [details]
Ubuntu running in Virtualbox

obsoleting, this part was fixed in bug 567280
Attachment #391880 - Attachment is obsolete: true
(Assignee)

Comment 19

4 years ago
Sorry if i'm hijacking the bug, changing the title for one part that is left - the account manager is a bit too high - as seen in both the attached screenshots.
Summary: Copies & Folders in Account settings gets cut off on Linux in 800x600 and 1280x800 → account manager is a bit too high to fit screen 800px screens with Unity desktop
(Assignee)

Comment 20

4 years ago
Created attachment 762836 [details] [diff] [review]
proposed fix

This is a bit of a pain actually, can't believe we haven't fixed it earlier.
Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Attachment #762836 - Flags: review?(richard.marti)
Attachment #762836 - Flags: review?(neil)

Comment 21

4 years ago
Comment on attachment 762836 [details] [diff] [review]
proposed fix

The reduction from 55em to 50.5em in height works for me on Windows 7 with Direct2D hardware acceleration disabled. However, with the DirectWrite fonts (xref bug 868495), several panes (Server Settings [barely], Copies & Folders, and Junk Settings) are cut off at the bottom and the scroll bar appears.
(In reply to Magnus Melin from comment #19)
> Sorry if i'm hijacking the bug, changing the title for one part that is left
> - the account manager is a bit too high - as seen in both the attached
> screenshots.

Also please note that my screen resolution is 768px high (including titlebar!), so 800px may be a slightly too high target. Is it possible to set a max-height of 100% or something?

Other than that: Thanks for looking into it. Is there any way to apply the xul patch without recompiling? :)
(Assignee)

Comment 23

4 years ago
rsx11m: thx for testing!

Mikael: it's possible to unpack whatever ja(r) file this ends up in and change it.
(Assignee)

Comment 24

4 years ago
Created attachment 763088 [details] [diff] [review]
proposed fix, v2

Just limit the max height by code.
Attachment #762836 - Attachment is obsolete: true
Attachment #762836 - Flags: review?(richard.marti)
Attachment #762836 - Flags: review?(neil)
Attachment #763088 - Flags: review?(neil)
(Assignee)

Updated

4 years ago
Keywords: uiwanted
Comment on attachment 763088 [details] [diff] [review]
proposed fix, v2

This is a tricky one, because Linux doesn't* actually tell us how big the window decorations are (they're 32px on my system for instance).

*Not historically, at least. I could ask around to see if there's a way we can find this information out these days.
(Assignee)

Comment 26

4 years ago
(In reply to neil@parkwaycc.co.uk from comment #25)
> Comment on attachment 763088 [details] [diff] [review]
> proposed fix, v2
> 
> This is a tricky one, because Linux doesn't* actually tell us how big the
> window decorations are (they're 32px on my system for instance).
> 
> *Not historically, at least. I could ask around to see if there's a way we
> can find this information out these days.

32px wfm - i'm not actually sure if it's 30 over here, but i don't think a few pixels matter much. With more pixels, possibly more room beneath, but that's a very very minor issue.
(Assignee)

Comment 27

4 years ago
Neil: review ping

Comment 28

4 years ago
Hi
My comments of 2011-08-09 are invalidated by history:-
1) 720-high screens have "regained" the norm for cheap 10" notebooks. I now use 720.
2) I no longer use Thunderbird myself, but Gmail on the web.
3) I just looked at Thunderbird v24.0 in Xubuntu 800x600 (Virtualbox)and the account-settings dialog had scroll-bars whether maximised or not and "Manage Identities" remained visible throughout all changes, including increasing the "screen decorations". While I was looking, 24.1.0 came in. Oddly, that lost its scroll bars when not maximised and said button was "irretrievably offscreen"! However, scroll-bars on maximised are sufficient.

So, thanks! it's fixed, please close this bug.
(Assignee)

Comment 29

4 years ago
It's not. Buttons are off screen when the dialog isn't maximized.

Comment 30

4 years ago
So why not make "Manage Identities" available when you pull-down the "From" when composing?
It could even be the last of the pull-down options. That would be really handy for all mailers, so why not get ahead of them?
Interesting idea, Mike!
Would you mind filing this as a new bug?

Thanks,
Blake.
(Assignee)

Comment 32

3 years ago
Neil: review ping
Hardware: x86 → All
Duplicate of this bug: 700039

Comment 34

3 years ago
Windows 7
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Thunderbird/24.6.0
1280x720 screen, 32-bit true colors

Since bug #700039 was closed as a duplicate of this one, I updated the Summary and Platform to be more general.
OS: Linux → All
Summary: account manager is a bit too high to fit screen 800px screens with Unity desktop → Account Settings Window Is Too Tall to Fit Monitor Screen

Comment 35

3 years ago
The easy solution on my Asus T100 with 1366 x 768 screen, Windoze 8.1 and Thunderbird 31.1.1 is to unplug the keyboard, rotate into portrait mode and use onscreen keyboard to enter into Account Setup.
Even notebooks can be changed to Portrait through screen settings - maybe use external USB mouse and keyboard.
Mozilla should remedy this issue with a shorter window.
This is driving me slightly crazy. (OK, an overstatement) Can we revisit the proposed patch. pretty please with sugar?

Also this would to some degree help people who want bug 529245. Although even better, push into tabs?


(In reply to Blake Winton (:bwinton) from comment #31)
> Interesting idea, Mike!
> Would you mind filing this as a new bug?

(thanks Mike) bug 935028 Provide "Manage Identities" in "From" pull-down when composing - duped to bug 323710
Blocks: 529245
Component: Preferences → Account Manager
Flags: needinfo?(mkmelin+mozilla)
See Also: → bug 82122, bug 416263
Created attachment 8569481 [details]
TB account settings 2.png

Normally I cannot see the bottom, "OK", etc. 
In this screen shot I somehow moved it so I could not see the top.

Could be my imagination, but it seems worse in the past year

Comment 38

2 years ago
While I don't really like it UI-wise, wouldn't Preferences and Account manager-in-tab solve this particular problem?
(In reply to :aceman from comment #38)
> While I don't really like it UI-wise, wouldn't Preferences and Account
> manager-in-tab solve this particular problem?

Very likely (comment 36).

How might pushing these into tabs affect the ability to open preferences from account settings (eg account testtings | compose | global compose and global addressing), and vice versa?

Comment 40

2 years ago
Should be described in bug 1096006. I think there are some problems opening specific accounts in the account manager. But I don't think opening specific panels/subtabs in preferences was mentioned as a problem. I think the code is in nightly/aurora. Can you try it out?
The account settings in prefs tab aren't yet in nightly, only the strings.
(Assignee)

Comment 42

2 years ago
I don't seem to reproduce this problem on linux anymore. And I now have a larger laptop screen then in 2013.
The patch still applies though and could help on windows. 

So I guess, neil: review ping! :)
Flags: needinfo?(mkmelin+mozilla)

Comment 43

2 years ago
Windows 7 Ultimate SP 1 (x64)
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Thunderbird/31.6.0
Monitor screen 10 inches high, set for 1280x720 px

I still see this problem.

Comment 44

2 years ago
When the Address Manager is resized, where are we saving the size data?  I ran a Wordpad search through localstore.rdf and found only position data.  When size data recall fails were at risk of an over tall dialog overflowing the window.
(Assignee)

Comment 45

2 years ago
localstore.rdf is no longer used (since tb36+). XULStore.json is what's used now. This bug isn't about the address manager though (by which I assume you meant the account wizard).

Comment 46

2 years ago
Yes, account manager was what I intended to write.

Comment 47

2 years ago
Since this problem is also seen in SeaMonkey's mail-news capability, I am changing the Product and Component to Mail-News Core and Account Manager.  

There is a cumbersome work-around with two cases:  

If the title bar of the Account Settings window is even slightly visible, use the cursor to drag it down slightly to make the entire title bar visible.  Then use the cursor to drag the top of the title bar in order to resize the window smaller.  You can then drag the window back up so that the entire window is visible.  

If the very bottom of the Account Settings window is visible, use the cursor to drag it up in order to resize the window smaller.  This will generally expose enough of the title bar at the top to drag the window down so that the entire window is visible.  

Generally, I find that this problem is always one of these two cases.  I have not yet seen a case where neither a sliver of the title bar nor the bottom frame of the window are visible.
Component: Account Manager → Account Manager
Product: Thunderbird → MailNews Core
Version: Trunk → 38
bug 1096006 seems to be making better progress. 
Have we decided that is the direction to go, and focus our resources there?
Flags: needinfo?(mkmelin+mozilla)
Version: 38 → Trunk
(Assignee)

Comment 49

a year ago
Long term maybe, but it's not finished. Even then, it's not much resource focusing as this already have a very simple patch.
Flags: needinfo?(mkmelin+mozilla)
(In reply to Magnus Melin from comment #26)
> (In reply to neil@parkwaycc.co.uk from comment #25)
> > Comment on attachment 763088 [details] [diff] [review]
> > proposed fix, v2
> > 
> > This is a tricky one, because Linux doesn't* actually tell us how big the
> > window decorations are (they're 32px on my system for instance).
> > 
> > *Not historically, at least. I could ask around to see if there's a way we
> > can find this information out these days.
> 
> 32px wfm - i'm not actually sure if it's 30 over here, but i don't think a
> few pixels matter much. With more pixels, possibly more room beneath, but
> that's a very very minor issue.
Depends on: 1096006
Flags: needinfo?(neil)
Whiteboard: [review:neil]
Comment on attachment 763088 [details] [diff] [review]
proposed fix, v2

Transferring review to Iann.
Attachment #763088 - Flags: review?(neil) → review?(iann_bugzilla)

Comment 52

a year ago
Comment on attachment 763088 [details] [diff] [review]
proposed fix, v2

>+  // Make sure the account manager window fits the screen.
>+  document.getElementById("accountManager").style.maxHeight =
>+    (window.screen.availHeight - 30) + "px";

So a bit of research shows that the:
unity top menu is 24px
windows 7 taskbar with small icons is 30px
windows 7 taskbar with normal icons is 40px

I presume 30px will show enough of the buttons even on windows 7 with normal icons on the taskbar?

Shame there's not a method to give available height/width excluding the task/top menu bar. Or is there?

r=me with above considered.
Flags: needinfo?(neil)
Attachment #763088 - Flags: review?(iann_bugzilla) → review+
finally, you have review :)
Flags: needinfo?(mkmelin+mozilla)
(Assignee)

Comment 54

a year ago
(In reply to Ian Neal from comment #52)> 
> I presume 30px will show enough of the buttons even on windows 7 with normal
> icons on the taskbar?

It should, but this really only affects people with small resolutions, so you'd be crazy to use large icons in that setup.

> Shame there's not a method to give available height/width excluding the
> task/top menu bar. Or is there?

I don't think there is, no, which is indeed a shame.
Flags: needinfo?(mkmelin+mozilla)
(Assignee)

Comment 55

a year ago
https://hg.mozilla.org/comm-central/rev/cc4da076eadae952968a8ea7cb527fd39f4f3062 -> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Whiteboard: [review:neil]
Target Milestone: --- → Thunderbird 49.0

Comment 56

11 months ago
Any chance of backporting this to 45?
tracking-thunderbird_esr45: --- → ?

Updated

11 months ago
status-seamonkey2.45: --- → affected
status-seamonkey2.46: --- → fixed
status-thunderbird48: --- → affected
status-thunderbird49: --- → fixed
status-thunderbird_esr45: --- → affected

Comment 57

11 months ago
Comment on attachment 763088 [details] [diff] [review]
proposed fix, v2

Looks trivial enough, let's give it a try. For SeaMonkey at least, corresponding issues with the preferences window landed on the branches as well, thus it would be nice to get respective account manager fixes in too.

[Approval Request Comment]
Regression caused by (bug #): none, old issue with fixed sizes
User impact if declined: users with small screens may see window exceeding boundaries
Testing completed (on c-c, etc.): already functional in aurora builds 
Risk to taking this patch (and alternatives if risky): low
Attachment #763088 - Flags: approval-comm-esr45?
Attachment #763088 - Flags: approval-comm-beta?

Comment 58

11 months ago
Comment on attachment 763088 [details] [diff] [review]
proposed fix, v2

rsx11m: I usually do the uplifts in a block to avoid pushing trivial changes like this one.
Attachment #763088 - Flags: approval-comm-beta? → approval-comm-beta+

Comment 59

11 months ago
Ok, I'm not touching it and assume you'll be pushing this patch.

Comment 60

11 months ago
Beta (TB 48, SM 2.45):
https://hg.mozilla.org/releases/comm-beta/rev/9b737b9aeb81

(In reply to rsx11m from comment #59)
> Ok, I'm not touching it and assume you'll be pushing this patch.
Done. I like to do them in blocks, usually every Saturday/Sunday.
So far, server resources have been paid for by Mozilla, but this will change some day, so we need to be smart about pushes, and not every 2-liner needs to be pushed straight away, especially not on the branches.
status-seamonkey2.45: affected → fixed
status-thunderbird48: affected → fixed

Comment 61

8 months ago
http://hg.mozilla.org/releases/comm-esr45/rev/11823ddb88f0
status-thunderbird_esr45: affected → fixed
tracking-thunderbird_esr45: ? → +

Updated

8 months ago
Attachment #763088 - Flags: approval-comm-esr45? → approval-comm-esr45+

Updated

8 months ago
tracking-thunderbird_esr45: + → 49+

Comment 62

8 months ago
I just installed TB 45.4.0 on our netbook and I'd like to confirm that this problem appears to be fixed.  Never saw it on our regular machines (laptop & tower), but it sure was a pain on the netbook with its small screen.  Thanks to one and all for finally catching this one.

Comment 63

8 months ago
Thanks for confirming.
status-thunderbird_esr45: fixed → verified

Comment 64

8 months ago
Sorry, we're not done yet...

I tested this issue on my netbook (which is only 1024x600).  The initial screen for Account Settings did appear correctly, with OK/CANCEL buttons visible at the bottom -- so I stand by my Comment #62 that part seems to be fixed.

However, after re-reading various comments (in particular Comment #14), I confess that I forgot about "Manage Identities".  I tested this just now, but sorry to say, the window is still too tall! OK/CANCEL are not visible, and neither are the settings on the lower parts of the various tabs.  (It makes no difference whether TB is running full-screen or simply filling the screen.)

I have to use my usual work-around (similar to David's Comment #47 for Account Settings):
I try to click on the top margin of the window so it jumps down about 1cm and the scroll bar appears.  Then I can resize the window by pulling the top margin down substantially (about 1/4 screen height), then grabbing the top bar to move the window up to the top.  With the whole window visible, I can see OK/CANCEL pinned to the bottom area, while the scroll bar allows me to access the full window contents one way or another.

So please RE-OPEN this bug -- it's only half fixed.  (But I think it's the same fix for both: scroll bar needs to appear at the outset if the full window is too tall.)

Updated

8 months ago
Blocks: 1307773

Comment 65

8 months ago
I have filed bug 1307773 as a follow-up on your behalf.

Comment 66

8 months ago
We have not been using verified for branch tracking, and using that as a synonym for fixed might mess up some of my scripts.
status-thunderbird_esr45: verified → fixed
You need to log in before you can comment on or make changes to this bug.