Message list for Inbox blanks until manually selecting another folder to view (IMAP folder, after "Compact")

RESOLVED FIXED in Thunderbird 3.0rc1

Status

--
major
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: bleber, Assigned: Bienvenu)

Tracking

({qawanted, regression})

unspecified
Thunderbird 3.0rc1
qawanted, regression
Bug Flags:
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [no l10n impact][has potential fix for review])

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/530.5 (KHTML, like Gecko) Chrome/2.0.172.39 Safari/530.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a2pre) Gecko/20090810 Lightning/1.0pre Shredder/3.1a1pre ID:20090810224307

For my main IMAP account, I leave Shredder open on my Inbox view which lists all messages. Over time, this message list will just go blank in one step--I don't know the trigger. If a new message arrives, it appears in the message list but no other messages are shown. I have to click on another folder for messages to populate the list. Clicking back to the Inbox shows all of my messages like normal. 

Reproducible: Always

Steps to Reproduce:
1. Leave IMAP mail account open with Inbox message list shown.
2. Wait 10(?) minutes.
Actual Results:  
Message list is completely blank.

Expected Results:  
Nothing should have changed, except maybe some new messages in the message list if they arrived during the 10 min.

Also running Lightning nightly.

Comment 1

9 years ago
With Shredder 3.0b4pre on WinXP, checking for new mail every 10 minutes, I haven't seen what you describe even after leaving it open idle for a while. Since you are using 3.1a1pre, did you try to reproduce this with a build from the latest-comm-1.9.1 nightlies?

It may be 1.9.1/1.9.2-branch issue, or try safe mode to exclude any impact from extensions. If it happens with 3.0b4pre as well, it may be an interoperability issue with your IMAP server, or something in the profile causing problems.
(Reporter)

Comment 2

9 years ago
I think I meant to be testing with 3.0/1.9.1. In any case, I will try both reproducing with a latest-comm-1.9.1 nightly and also using safe mode for 3.1a1pre.
(Reporter)

Comment 3

9 years ago
I was able to reproduce in these cases:
- The original 3.1a1pre build in safe mode (existing profile)
- 1.9.1.3pre, Gecko/20090812 Shredder/3.0b4pre, safe mode (existing profile)
- 1.9.1.3pre, Gecko/20090812 Shredder/3.0b4pre, safe mode (new profile)

Steps to reproduce: I right-clicked Inbox for my IMAP account and chose "Compact". This triggered it, but it doesn't always trigger it (unfortunately).

Comment 4

9 years ago
If this only occurs during a routine expunge (compacting in IMAP), that may be another hint. I'm adding the IMAP experts to the CC list, but if you have some further information under which conditions the message list blanks, that would be helpful to narrow down the issue.
Blank message list pane(thread pane) is easily observed by manual rebuild-index with local mail folder, using Tb trunk 2009/8/10 build on MS Win. Mails are listed by folder re-open(click other folder, then click folder again).
Compact of local mail folder resets or changes thread pane display(sort order, currently selected mail, current scroll position etc.)

If comment #0 was for one time failure, it may be a result of an internal rebuild-index due to some internal errors while running or previous run.

Comment 6

9 years ago
WADA, not a one-time failure per comment #3 and apparently reproducible when compacting. However, if offline syncing is used this may cause the effect you describe when re-indexing a local folder (I was assuming that the problem occurs on the remote-folder indexing, but in the offline case also the local index may become inconsistent triggering a rebuild).

Brett, do you have the uppermost checkbox activated in the Synchronization & Storage pane of the Account Settings? If yes, did you switch folders when there was current activity downloading messages for IMAP offline storage, possibly resulting in some inconsistent offline-storage stage?

Comment 7

9 years ago
Brett, per bug 510330, do you see any background activity (network or disk) immediately after the message list blanks? Anything in Tools > Activity Manager indicating that message headers are downloaded?
(Reporter)

Comment 8

9 years ago
Message Synchronizing is enabled--"Keep messages for this account on this computer"--for all folders in the account. I'm sure I have switched folders when there was activity downloading messages for offline storage, but the blank inbox also occurs when the client is just sitting idle.

I compacted my inbox again, got the "Deleted 2 messages from Inbox" message in the Activity Manager. Immediately afterward, I saw the main progress bar for Thunderbird fill up, but there was no message in the status area or in the Activity Manager. Then the inbox went blank. Not sure how to detect background activity besides looking at the Windows Task Manager, but things looked pretty quiet there.
FYI.
I've opened Bug 510643 for local mail folder/rebuild-index case in Comment #5.

Adding "IMAP" and "Compact" in bug summary for ease of search, to avoid confusion with Bug 510643. Sorry to Threaded View lovers.
Summary: Message list for Inbox blanks until manually selecting another folder to view → Message list for Inbox blanks until manually selecting another folder to view (IMAP folder, after "Compact")
FYI.
"Scroll position reset to top after Compact" in Comment #5 was Bug 479064.
(Reporter)

Comment 11

9 years ago
Although no one asked for one, I've gone ahead and created an IMAP protocol log. If this would be useful for anyone, I'll go ahead and anonymize it a bit and attach it to this issue.
(In reply to comment #11)
> Although no one asked for one, I've gone ahead and created an IMAP protocol
> log. If this would be useful for anyone, I'll go ahead and anonymize it a bit
> and attach it to this issue.

Please do
(Reporter)

Comment 13

9 years ago
Created attachment 395331 [details]
IMAP, level 5, protocol log - delete/move a few emails, expunge, mail window blanks

Log file is much larger than it needs to be -- sorry -- but it captures the "compact"/expunge action followed by the blanking Inbox.
(Reporter)

Comment 14

9 years ago
Trying to find a regression window ... On Ubuntu 8.04, the behavior described in this bug happens currently, but did NOT happen with an earlier build:

No problem: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.2pre) Gecko/20090728 Shredder/3.0b4pre

Problem: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.3pre) Gecko/20090805 Shredder/3.0b4pre

I was able to reproduce on the later build by clicking the Compact button. This was followed by activity in the mail window (filling progress bar) and the blanking. On the earlier build, I clicked Compact, which was followed by the compacting and notably, no activity (no filling progress bar) in the main mail window.
FYI.
"Compaction of offline-store file" by "Folder context menu/Compact" was disabled by  Bug 420115 on 21 Nov 2008.
> http://hg.mozilla.org/comm-central/log?rev=e2c807892615
And it has come back by first part of patches for Bug 482476 on 03 Aug 2009.
> http://hg.mozilla.org/comm-central/log?rev=9aada059ba20
See Bug 499630 for brief history of "Compact and offline-store".

Comment 16

9 years ago
http://hg.mozilla.org/comm-central/pushloghtml?startdate=2009-07-28&enddate=2009-08-05

Sounds likely bug Bug 482476 caused/exposed this bug.

I see it almost on a daily basis. Click compact, old messages are cleared, bug 510330 shows, and then an empty thread pane. 

No exceptions, no nothing.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression

Updated

9 years ago
OS: Windows XP → All
Hardware: x86 → All
(Reporter)

Comment 17

9 years ago
I also noticed today (20090901 Shredder/3.0b4pre) that if I have messages open in tabs, these tabs (Inbox excluded) are closed when the thread pane goes blank.

Comment 18

9 years ago
I'm seeing this too in the nightly, for maybe 2 weeks now.

Just had it happen when I hit the compact button on my inbox, and this was in the error console - assuming it is related:

2009-09-29 21:35:10	gloda.ds.pch	ERROR	PostCommitHandler callback (undefined:150) threw: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIMsgDBHdr.setUint32Property]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: file:///Applications/Shredder.app/Contents/MacOS/modules/gloda/indexer.js :: anonymous :: line 150"  data: no]

Comment 19

9 years ago
I think we need this sorted out, it's *very* common.
Flags: blocking-thunderbird3+

Updated

9 years ago
Whiteboard: [no l10n impact]
Given the apparent relationship to bug 482476, giving to bienvenu for further investigation.
Assignee: nobody → bienvenu
Blocks: 482476
(Assignee)

Comment 21

9 years ago
I spent some time trying to reproduce this today, w/o any luck.

Comment 22

9 years ago
Using imap mark-as-deleted may be key to seeing it.
(Assignee)

Comment 23

9 years ago
Now that bug 519801 is fixed, do you still see this, Magnus?
(Assignee)

Updated

9 years ago
Keywords: qawanted
Whiteboard: [no l10n impact] → [no l10n impact][possibly fixed by fix for bug 519801]
(Assignee)

Comment 24

9 years ago
I saw this yesterday, so it's not fixed. I suspect it does have to do with issues/errors compacting the offline store, however, which was what bug 519801 was about.
Status: NEW → ASSIGNED
Whiteboard: [no l10n impact][possibly fixed by fix for bug 519801] → [no l10n impact]

Comment 25

9 years ago
Indeed, it's been better, but i just saw it myself too again.
(Assignee)

Comment 26

9 years ago
I do have a potential fix for this, which I'll put up in a bit.
(Assignee)

Comment 27

9 years ago
Created attachment 406326 [details] [diff] [review]
proposed fix

Magnus, do you think you could try running with this patch?
Attachment #406326 - Flags: superreview?(bugzilla)
Attachment #406326 - Flags: review?(bugzilla)
(Assignee)

Updated

9 years ago
Whiteboard: [no l10n impact] → [no l10n impact][has potential fix for review]
Comment on attachment 406326 [details] [diff] [review]
proposed fix

This looks like it is reasonable to give it a try.

Should we be logging the fact that it failed somewhere?
Attachment #406326 - Flags: superreview?(bugzilla)
Attachment #406326 - Flags: superreview+
Attachment #406326 - Flags: review?(bugzilla)
Attachment #406326 - Flags: review+
(Assignee)

Comment 29

9 years ago
The compaction code could use some logging and/or activity manager integration, but it doesn't have any now.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

9 years ago
Target Milestone: --- → Thunderbird 3.0rc1
(Reporter)

Comment 30

9 years ago
My Inbox no longer blanks (excellent!), but compaction does appear to trigger a process of fetching a lot of information from the server (not so excellent). I don't have a sense for whether this extra activity with the server is necessary; it's been common for the past few months and always happens after a compact. (I want to say it never happened in TB 2.x, but I don't have any proof at the moment.) Is the extra activity a bug or a required process?
(Assignee)

Comment 31

9 years ago
Brett, are you running a recent nightly build?
(Reporter)

Comment 32

9 years ago
David, I'm running yesterday's build: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5pre) Gecko/20091020 Shredder/3.0pre

Comment 33

9 years ago
I am having this problem in ThunderBird RC1 PortableApps Version.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.5) Gecko/20091130 Thunderbird/3.0
It started with TB3 beta 4.
You need to log in before you can comment on or make changes to this bug.