Closed Bug 511240 Opened 13 years ago Closed 12 years ago

Provide feedback for loading of content within content tabs

Categories

(Thunderbird :: Toolbars and Tabs, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b4

People

(Reporter: standard8, Assigned: standard8)

References

Details

Attachments

(1 file, 1 obsolete file)

Attached patch Thunderbird Fix (obsolete) — Splinter Review
At the moment there is no indication present whilst loading content within content tabs. We should provide a mechanism that we can use and extensions can benefit from as well.

Most of this is easily copied from tabbrowser. This requires nsBrowserStatusFilter to be included in the component list for which I'm just about to file a bug. The benefit of the filter is that it reduces the amount of calls that we get telling us about updates.
Attachment #395165 - Flags: review?(bugmail)
Depends on: 511242
The core patch is in bug 511242.
Comment on attachment 395165 [details] [diff] [review]
Thunderbird Fix

r=asuth if you move the listener object definition out to a 'proper' (per our conventions) class.  (Constructor with attached prototype.)  Also, please provide explicit function names...
Attachment #395165 - Flags: review?(bugmail) → review+
Whiteboard: [needs updated patch]
Whiteboard: [needs updated patch] → [needs updated patch][waiting on 511242 to land on 191]
Attached patch The fix v2Splinter Review
Updated patch fixed as per review comments and fixed for the odd change that has gone into the content tabs since we submitted it.

I'm giving myself a+ on this as I want to get it in so that we can test the loading indication (on at least the what's new page) and we can start building on it.
Attachment #395165 - Attachment is obsolete: true
Attachment #399989 - Flags: review+
Attachment #399989 - Flags: approval-thunderbird3+
Checked in: http://hg.mozilla.org/comm-central/rev/f5e0cd5b5c9d
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Whiteboard: [needs updated patch][waiting on 511242 to land on 191]
Blocks: 516777
Duplicate of this bug: 508999
Regressions: 1667774
You need to log in before you can comment on or make changes to this bug.