"Cc:" scrolling-list widget appears twice

RESOLVED DUPLICATE of bug 126592

Status

()

Core
Layout: Form Controls
P2
normal
RESOLVED DUPLICATE of bug 126592
18 years ago
15 years ago

People

(Reporter: jesup, Assigned: rods (gone))

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(7 attachments)

(Reporter)

Description

18 years ago
FreeBSD 4.1 20000905xx (noon EDT)

"Cc:" scrolling-list widget appears twice; once in the correct position, once
near __thunk_16_ImplName__10FooBarImpl (about 3/4 of the way down the long page).

Comment 1

18 years ago
To elaborate, the HTML form control is repeated in the page more than once.
Reproduced in 2000090308 win2k, but only for the initial load of the page;
a reload doesn't show this flawed layout. I will attach an image of win2k.

-> HTML Form Controls, for a starter, although perhaps this is the content sink.
Assignee: trudelle → rods
Component: XP Toolkit/Widgets → HTML Form Controls
QA Contact: jrgm → ckritzer

Comment 2

18 years ago
Created attachment 14052 [details]
screenshot of the double showing of form controls in page.
(Reporter)

Comment 3

18 years ago
I did see it after a reload - but for me, it was many thousands of pixels lower
(3/4 of the page size, which is huge.).
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Summary: "Cc:" scrolling-list widget appears twice → [CAN't REPRO]"Cc:" scrolling-list widget appears twice
(Reporter)

Comment 4

18 years ago
Fresh pull/build FreeBSD 20000906xx noon edt
Still happens in the same place (very different place than the other reporter).

Whomever set this to [CAN'T REPRO] should have added a comment about what they
tried and what version they were testing.  Was this tested under Linux/GTK?
FreeBSD?  (pollmann@netscape.com has a freebsd machine available)  Windows?  Mac?
(Assignee)

Comment 5

18 years ago
I can't reproduce this on Linux or on WinNT. Pollmann will have to test on 
FreeBSD.
Summary: [CAN't REPRO]"Cc:" scrolling-list widget appears twice → [CAN'T REPRO]"Cc:" scrolling-list widget appears twice
(Reporter)

Comment 6

18 years ago
Added pollmann to cc
qawanted - especially FreeBSD
Keywords: qawanted
(Reporter)

Comment 7

18 years ago
Using Win95 2000090608 (downloaded from the daily link) I see the problem the
same way the other person does; there's a duplication just within the first page
of _all_ the content, not just the CC widget.

I should note that today's build for Win95 is pretty horked - no scrollbars,
themes problems, no sidebars, etc.  However, my pull/build of FreeBSD works fine
in most respects, and I saw this a few days ago as well - no change.
(Reporter)

Comment 8

18 years ago
Rechecked with fresh pull of Win95 2000090708.
The URL (bugzilla bug 17997) shows two copies of a BUNCH of widgets (and is very
confused by it), as well as two additional copies of the CC widget far down the
page.
This win95 build is much more sane than the last.

Removing [CAN'T REPRO], re-add if you still can't repro.
Summary: [CAN'T REPRO]"Cc:" scrolling-list widget appears twice → "Cc:" scrolling-list widget appears twice
(Assignee)

Comment 9

18 years ago
Kevin, this seems like a pure rendering issue as far as I can tell, and I cannot 
reproduce this on NT, this needs to be looked at on Win98
Assignee: rods → kmcclusk
Status: ASSIGNED → NEW
(Reporter)

Comment 10

18 years ago
Win95 2000090908 (different build/machine/profile/etc than the others)

Still has the original problem (cc list duped way down the page).  I don't get
the duping of any other widgets.

Removing qawanted
Keywords: qawanted
Rod, is this related to the problem that Vidur fixed in the content sink where
you were getting multiple comboboxes?
Assignee: kmcclusk → rods
(Assignee)

Comment 12

18 years ago
I think your build is old, this was fixed this last week. marking works for me 
because it has been fixed
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 13

18 years ago
FreeBSD 4.1 20000922xx full depend build

Reopening.  The problem is unchanged, and appears in exactly the same spot as
before.  I will upload a gif of the original (and current) problem (the other
screenshot was of a point where another bug made things much worse).  I will
also retest with a fresh 9/25 pull/build.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Comment 14

18 years ago
You shouldn't have reopened until you tested with a current build, because that 
was point, that it appeared that your build was old.
(Reporter)

Comment 15

18 years ago
FreeBSD 4.1 20000925xx pull/build

No change.  Still broken.

I reopened because my build was from late friday (and so I believed it was after
the "fixed last week" (when?) checkin), and because I expected to have a test
with a 9/25 build soon (as I stated) which was building as I typed.  Also, I
didn't see any indication in the WORKSFORME note that it was actually tested,
nor against which version it was tested.  I don't think things should be marked
WORKSFORME unless someone has actually tried it and seen that it works.  If it
was believed fixed and needed verification of that, a note on the bug requesting
a check, or resolving as FIXED with a request to verify would be appropriate (IMHO).

In any case, it's not fixed.  Uploading current screenshot.


(Reporter)

Comment 16

18 years ago
Created attachment 15435 [details]
Image of the current (and original) problem
(Reporter)

Comment 17

18 years ago
Created attachment 15436 [details]
Previous upload was truncated.  Image of current problem.
(Reporter)

Comment 18

18 years ago
Created attachment 15437 [details]
One more try - uploading from ns4.7
(Assignee)

Comment 19

18 years ago
eric, could you test this out on FreeBSD and see if you can reproduce it, other 
than that I haven't got a clue.
Status: REOPENED → ASSIGNED
Target Milestone: --- → Future
(Reporter)

Comment 20

18 years ago
I've yet to see anyone report on a test with Linux (unless you're (rod) using
linux to test - it hasn't been mentioned).

The test is very quick.  Could someone running Linux give it a try?  Adding
qawanted.  I only have FreeBSD & Win95, and daily's won't start anymore on my
Win95 (even after scrubbing the disk of anything I can think of).
Keywords: qawanted

Comment 21

18 years ago
Updating QA contact.
QA Contact: ckritzer → bsharma
(Assignee)

Comment 22

18 years ago
I think this got fixed for rtm
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 23

18 years ago
Reopening; still broken as of FreeBSD4.1 20001210xx

The copy of the data from the widget appears around L$C0102 or iid___215 in the
current build.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 24

18 years ago
Rechecked FreeBSD 4.1 20010123xx.  Still there.  Duplicate image of widget, does
not respond to mouse actions.

QA (i.e. check if it happens) still wanted for Linux.  Perhaps this is a GTK
bug?  I'm using gtk 1.2.8

Comment 25

17 years ago
Mozilla0.8 on win95 : worksforme. The pages look totally fine
(Reporter)

Comment 26

17 years ago
Duplicate still there (20010212xx build); about 85% of the way down the page
(with my font settings, it's opposite 'iid___215').
Note that the duplicate has no border (and hasn't had one in the past).

Comment 27

17 years ago
QA Contact Update
QA Contact: bsharma → vladimire
(Reporter)

Comment 28

17 years ago
I have a suspicion that this is a wrap-around issue with widget positioning;
perhaps at 32K or 64K pixels.

Still there in moz 0.9.1 (2001060703), Win32.

OS -> All

Suggesting for moz1.0
Keywords: mozilla1.0
OS: FreeBSD → All

Comment 29

17 years ago
Still there, 0.9.4 (2001091303), win98SE
(Reporter)

Comment 30

17 years ago
Bug still there in mozilla 2001092703 Win98.  At least on this machine and
fontset, the copy of the widget appears a bit below L$0261 (several pages).

I'm guessing it's a PRInt16 or PRUint16 in the code that compares the drawing
region for the widget with the widget's position in the document.

Removing Future to put it on the radar for re-evaluation.  This has been open
for 1 year plus now...
Keywords: qawanted
Target Milestone: Future → ---

Comment 31

17 years ago
Still there, win98SE, 2001121003
(Assignee)

Updated

17 years ago
Status: REOPENED → ASSIGNED
Target Milestone: --- → mozilla1.2
(Assignee)

Updated

16 years ago
Priority: P3 → P2
Target Milestone: mozilla1.2 → Future
I see this on linux 2002022708 nightly. The select box is rendered again every
65536px (2^16) down the page. I'll upload a testcase.
Created attachment 71729 [details]
testcase

Interestingly enough, the <div> I used to make 200k pixels of room seems to get
chopped up oddly too after a while, and seems to restart at the same
intervals...

Updated

16 years ago
Hardware: PC → All

Updated

16 years ago
QA Contact: vladimire → tpreston

Comment 34

16 years ago
Any progress on this?

Comment 35

16 years ago
I can't reproduce this on 2002070908, winXP, either on the URL: link, or on the
testcase.  Is anyone else seeing it on a recent build?

Comment 36

16 years ago
Created attachment 91670 [details]
Screenshot of bad CC: list drawing

I regularly see odd cc: list drawing when using tabs in Mozilla. Build is
20020617 (branch). I've also seen something similar with the ad banners on
www.sourceforge.net drawing in the wrong place. In both cases, a window resize
fixes it.
Created attachment 92011 [details]
screenshot of testcase, linux trunk cvs 2002-07-12

re comment 35: screenshot of
<http://bugzilla.mozilla.org/attachment.cgi?id=71729&action=view#a1>, linux
trunk cvs 2002-07-12, xblfc off. With xblfc on same result except no scrollbar.
Tabs don't make a difference. Window resize has no effect.
(Reporter)

Comment 38

16 years ago
mozilla1.0 -> mozilla1.1

Removing future in the hope of it's being re-prioritized
Keywords: mozilla1.0 → mozilla1.1
Target Milestone: Future → ---

Comment 39

16 years ago
*** Bug 160067 has been marked as a duplicate of this bug. ***

Comment 40

16 years ago
From bug 160067: Verified on 1.1alpha@solaris, trunk-20020730@linux and
trunk-20020731@Win98. The testcase for this bug works pretty well on a 1.0.1 @
win98.

If you scroll by the repeated form control you will get some kind of artifact
(lines or a box, grey, black or garbled), you will almost only see it properly
if you jump straight at it. 

Comment 41

16 years ago
*** Bug 161630 has been marked as a duplicate of this bug. ***
*** Bug 164929 has been marked as a duplicate of this bug. ***

Comment 43

16 years ago
Bug 164625 could be related.
*** Bug 164666 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

16 years ago
Depends on: 164625
This is another "widgets wrap at 16K pixels" issue.

*** This bug has been marked as a duplicate of 126592 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.