Closed Bug 515652 Opened 11 years ago Closed 11 years ago

make sure Customize/Support/Weave bookmark links work

Categories

(Firefox for Android Graveyard :: Bookmarks, defect)

ARM
Maemo
defect
Not set

Tracking

(fennec1.0+)

VERIFIED FIXED
fennec1.0b5
Tracking Status
fennec 1.0+ ---

People

(Reporter: jmaher, Assigned: clooney)

References

Details

the default bookmarks "Firefox: Customize with add-ons", takes me to https://addons.mozilla.org/en-US/mobile which ends up as a 404.
We knew when we landed the patch that some of the links aren't working. Will need to test them all and potentially file bugs on AMO to update their link.
tracking-fennec: --- → ?
Summary: default boookmarks on fennec gets me a 404 on the amo link → make sure all default boookmark links work
Assignee: nobody → clooney
tracking-fennec: ? → 1.0+
that's correct, Joel. Currently, the page URL is: https://addons.mozilla.org/en-US/fennec, but will/should be changed to https://addons.mozilla.org/en-US/mobile

Cheers.
Summary: make sure all default boookmark links work → make sure Customize/Support/Weave bookmark links work
Duplicate of this bug: 515655
Duplicate of this bug: 515658
Just to be clear, the links that need to work are currently:

Weave: https://www.mozilla.com/@AB_CD@/mobile/weave
Customize: https://addons.mozilla.org/@AB_CD@/mobile
Support: https://mobile.support.mozilla.com

(Where @AB_CD@ is dynamically replaced by the user's locale, e.g. "en-US")

We could change these in the product if needed, but changes would only take effect for people creating new profiles (so potentially not early beta testers).
Looks like only the Weave link is still broken
Per discussion, we should revive the Weave webpage that we currently link the bookmark to.
The page will be a mobile page so we'd want to change the URL from https://www.mozilla.com/@AB_CD@/mobile/weave to /m/sync to be consistent with the desktop page (https://www-trunk.stage.mozilla.com/en-US/mobile/sync/)
Caitlin:  To be clear, we want the Weave Sync bookmark to point to http://www.mozilla.com/en-US/m/sync/, correct?
YES. Sorry for the delay.
I filed bug 531209 for that. Since the other links are working since the mozilla.com push, I'm marking this FIXED.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → B5
verified FIXED on builds:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b5pre) Gecko/20091130 Firefox/3.6b5pre Fennec/1.0b6pre

and

Mozilla/5.0 (X11; U; Linux armv6l; Nokia N8xx; en-US; rv:1.9.3a1pre) Gecko/20091130 Firefox/3.7a1pre Fennec/1.0b5
Status: RESOLVED → VERIFIED
Component: General → Bookmarks
You need to log in before you can comment on or make changes to this bug.