marking an email 'not junk' should return it to the originating folder, not inbox

RESOLVED DUPLICATE of bug 466041

Status

RESOLVED DUPLICATE of bug 466041
9 years ago
9 years ago

People

(Reporter: kbsingh, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-GB; rv:1.9.0.11) Gecko/2009061613 CentOS/3.0.11-2.el5.centos Firefox/3.0.11
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-GB; rv:1.9.1.4pre) Gecko/20090915 Shredder/3.0b4pre

With Adaptive Junk mail controls turned on and set to move these emails into the accounts junk folder, thunderbird should remember which folder they were marked as Junk from. That would allow thunderbird to move them back into the right ( originating ) folders rather than just INBOX if/when those emails are manually marked as 'not junk'

Reproducible: Always

Steps to Reproduce:
1.run Junk mail check on a non-INBOX folder
2.emails that thunderbird considers as Junk are moved into the Junk folder for that specific account/mailbox
3.goto the Junk Folder
4.mark some of those emails as 'Not Junk'
Actual Results:  
Thunderbird will move these emails that were manually tag'd as 'Not Junk' into the accounts INBOX

Expected Results:  
The emails should be moved back into the folder they originated from and not into the INBOX. They should only be moved into the INBOX when the originating folder no longer exists or the user is no longer subscribed to it.

This issue is reproduceable even when emails were marked as Junk manually and thunderbird moved them into the Junk folder. There appears to be no knowledge retained in the emails about where they came from.

Updated

9 years ago
Depends on: 466041
Looks like this is a straight dup of bug 466041.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
No longer depends on: 466041
Resolution: --- → DUPLICATE
Duplicate of bug: 466041
You need to log in before you can comment on or make changes to this bug.