Support for video content area to be clickable play/pause button

VERIFIED FIXED in mozilla7

Status

()

enhancement
VERIFIED FIXED
10 years ago
8 years ago

People

(Reporter: jboriss, Assigned: jaws)

Tracking

unspecified
mozilla7
x86
All
Points:
---
Dependency tree / graph
Bug Flags:
wanted1.9.2 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

Reporter

Description

10 years ago
Currently missing video behaviors:

- When autoplay is off, a play button should display in the center of the video and the entire content area should be a clickable play button.  The video should fade partially to black.

- While the video is playing, the content area should be a clickable pause button.  Clicking it to pause should produce the same play button as above, and the video should fade similarly to black.

The reason for adopting this already widely-used video interaction is that the clickable area for the most common two tasks - play and pause - is as large as possible and therefore faster and easier to click.  It also means that if the video is autoplaying and the user does not want it to play, they don't need to hover over the video and wait for the UI pause/play button to appear. 

This should work the same in fullscreen mode as standard play mode.
Component: General → Video/Audio
Product: Firefox → Core
QA Contact: general → video.audio
Target Milestone: Firefox 3.6 → ---

Updated

10 years ago
Flags: wanted1.9.2?
OS: Mac OS X → All
This doesn't seem like something we'd take on branch for 1.9.2.
Flags: wanted1.9.2? → wanted1.9.2-

Updated

10 years ago
Duplicate of this bug: 488000

Comment 3

10 years ago
One issue need to be considered:-
If the web developer is not using VIDEO tag just as normal player, 
but something other then that, this feature will be a trouble to him.
example at http://www.double.co.nz/video_test/video.svg you can click and drug
the video. Here we dont want the pause and play action when user click it to
drag.

One option, this feature should available only when controls are enabled.

Updated

10 years ago
Duplicate of this bug: 488003
Yes, this should definitely only happen when controls are enabled!
Component: Video/Audio → Video/Audio Controls
Product: Core → Toolkit
QA Contact: video.audio → video.audio
Version: Trunk → unspecified
Assignee: nobody → jwein
Status: NEW → ASSIGNED
This bug has been broken up into two bugs.

This bug will stay as the bug for making the video content area a large play/pause button, while bug 666306 is now the bug for making the video initially show a large play button if autoplay is off.
See Also: → 666306
Posted patch Patch for bug 518008 (obsolete) — Splinter Review
The video content area is now clickable to play/pause the video.
Attachment #541120 - Flags: review?(roc)
I forgot to add that the patch for this bug only enables this ability if the video controls are visible.
Attachment #541120 - Flags: review?(roc) → review?(dolske)
Comment on attachment 541120 [details] [diff] [review]
Patch for bug 518008

Review of attachment 541120 [details] [diff] [review]:
-----------------------------------------------------------------

I'm not a toolkit peer.
Attachment #541120 - Flags: review?(gavin.sharp)
Attachment #541120 - Flags: review?(dolske)
Attachment #541120 - Flags: review+
Attachment #541120 - Flags: review?(gavin.sharp) → review?(dolske)
Based on our conversation offline, I have changed the button back to a spacer and am now using the click handler. This works just as well and will probably not introduce any weird a11y issues.
Attachment #541120 - Attachment is obsolete: true
Attachment #541422 - Flags: review?(dolske)
Attachment #541120 - Flags: review?(dolske)
Bah, I typed my comment for our conversation in a tab but never saved it:

From a quick chat: It's probably lightly better to just add a onclick handler to the spacer, instead of making it a <button>. It's kind of a weird case where we literally are not interested in anything other than the click (and so have to do extra stuff to make the button invisible).

The slight difference that made onclick win out for me is that for A11Y we actually don't want the button showing up at all. It's redundant with the existing play/pause button (which is accessible), and would probably just be annoying to show up as a separate thing anyway.
Comment on attachment 541422 [details] [diff] [review]
Patch for bug 518008 - version 2

I hate to bikeshed, but I think I'd rather keep it named controlsSpacer.

r+ with that simple rename!
Attachment #541422 - Flags: review?(dolske) → review+
Changed the name of the spacer back to controlsSpacer.
Attachment #541422 - Attachment is obsolete: true
Attachment #541872 - Flags: review?(dolske)
:Dolske, with the above rename, can you land this for me?
Comment on attachment 541872 [details] [diff] [review]
Patch for bug 518008 - version 3

No re-review needed, but r+ anyway. :) I'll just flag this checkin-needed lest I not get to it this weekend.
Attachment #541872 - Flags: review?(dolske) → review+
http://hg.mozilla.org/mozilla-central/rev/fcc6c92e9b93
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla7

Comment 17

8 years ago
A little problem, rightclick will trigger it as well, normally you rightclick because you want to see the context menu other than play/pause it.
(In reply to comment #17)
> A little problem, rightclick will trigger it as well, normally you
> rightclick because you want to see the context menu other than play/pause it.

Thanks for catching that. I have logged bug 667323 for this issue.
Depends on: 667323
No longer depends on: 668398

Comment 19

8 years ago
Using the steps from the description and a youtube video it's enough to verify this bug?
Thanks
(In reply to Vlad [QA] from comment #19)
> Using the steps from the description and a youtube video it's enough to
> verify this bug?
> Thanks

This bug only applies to HTML5 <video> when controls are enabled, therefore youtube videos will not apply.

Comment 21

8 years ago
I've verify this on o youtube video with html5 enabled. If I right-click on the video, in the context menu I have "About html5" so I guess it ok.

The whole video acts like a play/pause button.

It's enough to verify this?

thanks

Comment 22

8 years ago
Back again :)
I've now tested this bug on this test page:
http://dolske.net/mozilla/tests/video/tests.html#

Everything is working as expected.

Setting resolution to Verified Fixed on Mozilla/5.0 (Windows NT 6.1; rv:7.0) Gecko/20100101 Firefox/7.0 beta 3
Status: RESOLVED → VERIFIED
This really should be left to end developers to implement in JavaScript. See: https://bugzilla.mozilla.org/show_bug.cgi?id=693014
No longer blocks: 693014
Depends on: 693014
You need to log in before you can comment on or make changes to this bug.