Closed Bug 520457 Opened 12 years ago Closed 12 years ago

Customize Toolbar leads to doubled account list in menu File > Get new Mail

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0rc1

People

(Reporter: Thunderbird_Mail_DE, Assigned: bwinton)

References

Details

(Whiteboard: [no l10n impact])

Attachments

(2 files)

A similar bug was in 3.0 b1 builds:
https://bugzilla.mozilla.org/show_bug.cgi?id=456940

STR:
Open the Customize Toolbar dialog. Exit the dialog with "Okay". Open menu File > Get new mail. The accounts list now is doubled - this iterates. The account list in the "Get mail" buttons drop down, doesn't duplicate this time.

BTW:
This bug is independent from Lightning.
Thunderbird 3.0pre 20091004
This WFM on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.4pre) Gecko/20091004 Shredder/3.0pre + enigmail.

Alexander does it happen in safe-mode too ?
Shredder 3.0pre 20091005

Yes, it happens in safe-mode too. The account list in File > Get all mail is doubled, too. Maybe this was all the time since bug 456940 fixed the problem for the buttons account list. But I'm not sure. The fix in 456940 uses DOM to fix only "button-getmsg".

The related fix:
https://bug456940.bugzilla.mozilla.org/attachment.cgi?id=358264
If I undestrand well your problem here is WFM with

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20091006 Lightning/1.0pre Shredder/3.0pre ID:20091006032243

I have only this issue here: bug #518586
I've now tested this in a linux VM using OpenSUSE 11.1 and Shredder 3.0pre 20091006 build:

This bug occurs there too.

To make it clear: this bug is about the accounts list in the _File menu_.
Alexander could attach here a screenshot of the problem, please?
I'm sorry: you are right confirmed also here!
I really don't see that on the Mac. Anything missing in the STR ?
(In reply to comment #9)
> I really don't see that on the Mac. Anything missing in the STR ?

Here it seems that comment #0 is complete:

1. click on main toolbar with mouse rx button;
2. select "custumize..." item;
3. when "custumize toolbar" window is open, click on "done" button;
4. goto menu-->File-->get new messages for
5. all account are duped.

I have 5 account: 3 in local folders and 2 others.
I try also in safe-mode on Windows XP professional sp3.

Maybe it is only Windows related?
I see it on linux. (Only after second time though??)
Flags: blocking-thunderbird3+
Target Milestone: --- → Thunderbird 3.0rc1
Whiteboard: [no l10n impact]
Blake, can you take a look at this, since you've got some Customizate Toolbar experience?
Assignee: nobody → bwinton
Yeah, sure.  It should fit right in with the work I'm doing on bug 518586.
Status: NEW → ASSIGNED
I don't really know why the menu is getting re-created after customization, keeping its children but not its fields, but with this patch we clear out the generated entries, and it all looks good.

And it's based on top of the patch for 518586, because that fixes a lot of other related bugs.
Attachment #405195 - Flags: superreview?(bienvenu)
Attachment #405195 - Flags: review?(mkmelin+mozilla)
Will the patch cause the "Get All New Messages" option to be added back in as well? I believe that currently gets lost at the moment (which I think has been reported elsewhere).
Depends on: 518586
Attachment #405195 - Flags: superreview?(bienvenu) → superreview+
This patch won't, but I believe the patch for bug 518586 will.  (Or rather, it will stop the option from being removed in the first place.)
Whiteboard: [no l10n impact] → [no l10n impact][patch up, needs r]
Comment on attachment 405195 [details] [diff] [review]
A patch to remove the old items from the menu.

I'm not a mailnews/ peer but i can confirm it works.
Attachment #405195 - Flags: review?(mkmelin+mozilla) → review+
Comment on attachment 405195 [details] [diff] [review]
A patch to remove the old items from the menu.

(In reply to comment #17)
> I'm not a mailnews/ peer but i can confirm it works.

D'oh, that's very true.  I suppose I should ask asuth for an additional review, then.

(I felt like I was asking him for a lot of reviews, and wanted to try to spread it around a little.)

Hopefully knowing that it works will make his review job at least a little easier.

Thanks,
Blake.
Attachment #405195 - Flags: review?(bugmail)
Attachment #405195 - Flags: review?(bugmail) → review+
Keywords: checkin-needed
Whiteboard: [no l10n impact][patch up, needs r] → [no l10n impact]
Keywords: checkin-needed
Whiteboard: [no l10n impact] → [no l10n impact][waiting for 518586 to land]
Keywords: checkin-needed
Whiteboard: [no l10n impact][waiting for 518586 to land] → [no l10n impact]
http://hg.mozilla.org/comm-central/rev/0f7ad55e29c3
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Depends on: 534448
Blocks: 871266
You need to log in before you can comment on or make changes to this bug.