[vi] Choose search plug-ins for Fennec in Vietnamese

RESOLVED DUPLICATE of bug 1380866

Status

RESOLVED DUPLICATE of bug 1380866
9 years ago
a year ago

People

(Reporter: stas, Unassigned)

Tracking

({productization})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bootstrapped][twitter])

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
You've indicated an interest in participating in the localization of mobile Firefox (aka Fennec). We want to ship Fennec with a good list of search engines for Vietnamese. As the technical details of implementation are being worked on, we'd like to start the discussion about the choice of search engines. This bug is about agreeing on a set of search engines, and will not tackle the implementation (at least not yet).

First, the localization team and Staś will look at the market for the locale and come up with a good set of search providers. The guidelines for making recommendations are on https://wiki.mozilla.org/L10n:Mobile/Productization. You're welcome to suggest engines already shipped in desktop Firefox for Vietnamese, if they fit well in the categories outlined on the wiki.

For en-US, we currently use the following set, which may serve as an inspiration:
Google, Wikipedia, Amazon, Yahoo, Twitter.

Note that according to the guidelines, for some categories it may be better to leave them empty than to ship with en engine that's irrelevant or unavailable in your region.

After we decided on a particular search engine, we will need to test it in Fennec. You can test on a mobile device and on the desktop (download the builds from <http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/>). Staś will help with testing on a device, too. If the service works fine, Staś will contact the owner and ask for permission, and for specifics like proper search flags. We'll likely need your help to at least get the contact information if we don't have them already.

We don't know the implementation details yet, so for now, please don't create patches nor land anything. We will keep you posted as we figure out the how's and when's.

Thanks.

Comment 1

9 years ago
Hi Guys:  Just a friendly reminder, as we move closer to the general availability date for Fennec in mid-December, has your team had any chance to consider search providers?  Thanks!
(Reporter)

Comment 2

9 years ago
Created attachment 414645 [details] [diff] [review]
Bootstrapping search engines with Google, localized Wikipedia and Twitter

Here's a patch resetting the mobile/searchplugins/ directory to a minimal set of search engines that we would like to ship your locale with. Please read this comment carefully before you land this patch.

*Important*: There has been a change to how we use the  <Description/> elements present in the plug-ins (see bug 528655 and bug 529869). We want to emphasize that the search is integrated with the browser to better reflect what a search plugin is and what it does. You will need to edit the Wikipedia plug-in before you commit this patch. Please read <https://wiki.mozilla.org/L10n:Integrated_Search_Instructions> for detailed instructions.

For Google and Twitter, we don't have to copy the XML files to your mobile/searchplugins/ directory. Plugins identical to en-US are pulled from source automatically. It's enough to put the engine's name in list.txt for this to work (which I did). I also updated the Wikipedia plug-in to use a bigger icon, see bug 517997 for details.

Please edit the Wikipedia plug-in and commit this patch before you opt-in in the mozilla.dev.l10n newsgroup. Opt-ins without this patch will not be taken. This does not mean that we don't want to include other search engines. On the contrary, the work and the discussion will continue in this bug until we choose a good set of search engines for your locale. Then, you will be able to opt in again, so that in the final release we include more search engines than the mineral set from this patch.

This patch is simply meant to reset your mobile/searchplugins directory so that we keep the repository clean and happy.

Thanks for understanding!
(Reporter)

Comment 3

9 years ago
Hung, thanks for landing the patch! For reference, the landing was http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/vi/rev/69a41a07c064.
Whiteboard: [bootstrapped][twitter]
Hello,

We'd like to suggest these sites for Fennec search plugins:
vietbando.com: a map site.
1tudien.com: a dictionaries site.

Just wonder which versions of those sites should we choose: Full or WAP versions?
And btw, may we remove Twitter plugin?

Comment 5

6 years ago
Hi,

Is this bug still relevant in the current release?

Comment 6

6 years ago
Hi everyone.  Is this bug still relevant?
(In reply to Duong H. Nguyen from comment #6)
> Hi everyone.  Is this bug still relevant?

Hi Duong,

Yes, this bug is still relevant. It would be fantastic if you and the vi team could identify some search engine providers for Fennec. Please review these wiki guides to know how to proceed:

-https://wiki.mozilla.org/L10n:Mobile/Productization
-https://developer.mozilla.org/en-US/docs/Productization_guide

Thanks!
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1380866
You need to log in before you can comment on or make changes to this bug.