Closed Bug 522208 Opened 10 years ago Closed 7 years ago

Some parts of Account Configuration dialog have small width

Categories

(MailNews Core :: Account Manager, defect)

1.9.1 Branch
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: JasnaPaka, Unassigned)

References

()

Details

(Whiteboard: [gs])

Attachments

(5 files)

If you are on Windows you can see in Account Configuration dialog that some sections have too small width. Whan I can see problem is Windows only. On Linux it's ok. So you can set some width in AccountManager.dtd  but dialog has different width on Windows and Linux.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.5pre) Gecko/20091013 SeaMonkey/2.0pre
It's AccountWizard.dtd for the new account dialog, and AccountManager.dtd for the account manager. If you're using ch units for the width, it usually should work reasonably for all operating systems, as ch adopts to the actual width of the fonts used, while em is the font height, actually, so it should only be used for window heights.
I know we still have an em width for account wizard even in en-US, a bug should be filed on that.
This bug is about AccountManager size in en-US version. See the screenshot.

http://hg.mozilla.org/comm-central/file/df3840aff5bf/suite/locales/en-US/chrome/mailnews/pref/AccountManager.dtd

and there is the "ch" unit. 

"If you're using ch units for the width, it usually should work reasonably for all operating systems" ... It looks like it does not.
We had discussion about this on IRC (#seamonkey). On Windows Vista there is a problem with default theme (Aero is disabled). GUI use font "Segoe UI". When I switch to Windows Classic theme then dialog is ok for me. This theme use "Tahoma" font. If you need some more info just ask.

CCing Ludovic because Thunderbird 3 has the same problem. This should be fixed before final version I think.
Duplicate of this bug: 505977
Moving to Thunderbird because this problem is shared with Thunderbird.
Component: MailNews: Account Configuration → Account Manager
Product: SeaMonkey → Thunderbird
QA Contact: mailnews-account → account-manager
Version: Trunk → 3.0
(In reply to comment #5)
> Moving to Thunderbird because this problem is shared with Thunderbird.

If it is shared, then you should move it to MailNews Core.
Product: Thunderbird → MailNews Core
QA Contact: account-manager → account-manager
Version: 3.0 → unspecified
I add some screenshots (based on discussion on #maildev).
Perhaps we want to fix this in the same bug?
Some data which indicate change between TB 2 and TB 3.

Dialog width (in px)
======================
TB 2: 667 px
TB 3: 589 px

Both on Windows Vista with default theme (no Aero).

Dialog size as defined in AccountManager.dtd (see comment#2)
=============================================================
key: accountManager.size

TB 2: "width: 55em; height: 50em;"
TB 3: "width: 97ch; height: 49em;"

So you can see there is change: "em" -> "ch".
(In reply to comment #11)
> Created an attachment (id=407591) [details]
> Similar mis-sizing issue, but with height instead of width.
> 
> Perhaps we want to fix this in the same bug?

Yep would be nice.
Duplicate of this bug: 526225
seeing this (the mostly hidden managing identities button) in 3.0rc1-build2

Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.1.5) Gecko/20091117 Thunderbird/3.0 ID:20091117170600
Changing platform to "All", based on comments 14 & 15 (and my own experience).
OS: Windows Vista → All
Hardware: x86 → All
Duplicate of this bug: 516472
Is this still a problem in current versions?
Version: unspecified → 1.9.1 Branch
Does this still happen in a clean profile of a recent TB?
Everything looks good with latest release and new profile. I'll vote for fixed.
This also works for me on both Linux and Windows. Resolving.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.