Closed Bug 522243 Opened 12 years ago Closed 11 years ago

Master password is prompted several times, if first prompt was left alone.

Categories

(Thunderbird :: Security, defect)

x86
Windows XP
defect
Not set
major

Tracking

(thunderbird3.1 beta2-fixed)

RESOLVED FIXED
Thunderbird 3.1b2
Tracking Status
thunderbird3.1 --- beta2-fixed

People

(Reporter: dmitry.s.mukhin, Assigned: standard8)

Details

(Whiteboard: [fixed by bug 338549, bug 557622 and bug 557625])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: mozilla thunderbird version 2.0.0.23 (20090812)

I use master password for my accounts.
Master password is prompted upon application start. If prompt is unanswered for some (long) time, entering password does nothing and another master password prompt pops up. Sometimes it is repeated several times.


Reproducible: Always

Steps to Reproduce:
1. setup master password
2. start thunderbird
3. leave master password prompt unanswered (no cancel either)
4. wait
5. enter master password
Actual Results:  
master password is prompted once again

Expected Results:  
master password is accepted, prompt disappears

my accounts are set to check for new mail every 5 minutes. i think that master password is asked on startup and than on every mail check once per 5 minutes. maybe it is more appropriate not to check for new mail before initial master password prompt is closed (despite 5 minutes setting).
Version: unspecified → 2.0
I see the same effect in Firefox 3.5.5. When Firefox starts two addons try to login and the masterpassword prompt appears for the first addon. This prompt is centered on the screen. Then the second prompt appears and it is positioned in the topleft corner of the screen. 
This is always reproducable.
The two addons are "Weave 0.8" and "Wave for Firefox".

Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5

Should I file this bug for Firefox separately? Or should this be changed to be a Gecko bug?!

Anoying sidenote: When I start to enter the password into the first prompt and then the second one pops up, it takes the focus and the rest of the masterpassword is entered into the second dialog.
I'm seeing similar behavior ... I have my accounts secured with a master password.

. I launch TB 3.0
. A modeless dialog opens asking me for the master password.
. Main window opens
. Another, modal, dialog asking me for the master password opens ... this one is tied to the main window.

The first password dialog seems to be associated with other mail and/or calendar accounts, although I'm not 100% sure.


Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070604 Thunderbird/2.0.0.4 Mnenhy/0.7.5.0
(In reply to comment #2)
> I'm seeing similar behavior ... I have my accounts secured with a master
> password.

Sorry, I just noticed this bug was associated with TB 2.0 and not 3.0.  I'll do a better search next time.
note, password system is changed in version 3, so what's broke in this area in v2 may not get fixed, or fixed quickly.
Summary: Master password is prompted several times, if first prompt was left alone. → Master password is prompted several times, if first prompt was left alone. [TB2]
the issue appears in TB3 too.
Severity: normal → major
Version: 2.0 → 3.0
Summary: Master password is prompted several times, if first prompt was left alone. [TB2] → Master password is prompted several times, if first prompt was left alone.
Component: General → Security
QA Contact: general → thunderbird
dupe of bug #275547?
This is fixed in Thunderbird 3.1 builds - we now stack the calls to the master password prompt for pop & imap so that you won't get the multiple prompts.

The fix will be in Thunderbird 3.1 beta 2, however it isn't something that we can backport to older versions of Thunderbird.

[fixed by bug 338549, bug 557622 and bug 557625]
Assignee: nobody → bugzilla
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Whiteboard: [fixed by bug 338549, bug 557622 and bug 557625]
Target Milestone: --- → Thunderbird 3.1b2
This bug is not fixed in linux build!
(In reply to comment #8)
> This bug is not fixed in linux build!

Please file a new bug with exact details of what you are running (accounts, extensions, version etc). Comments on closed bugs are likely to get missed.
I created bug 590441 as this one is indeed closed.
(In reply to comment #8)
> This bug is not fixed in linux build!

What version? 3.1.x or lower?
all 3.1.x (0-2). 3.0.6 works fine.
Version 3.1.2 Windows 7. Problem still exists
(In reply to comment #13)
> Version 3.1.2 Windows 7. Problem still exists

Please do not put comments like this on RESOLVED bugs. Please file a new bug with details of your setup, e.g. imap/pop/news accounts and what extensions you use.
You need to log in before you can comment on or make changes to this bug.