Closed Bug 525716 Opened 10 years ago Closed 10 years ago

Implement ESC keyboard shortcut to remove quicksearch filter

Categories

(Thunderbird :: Search, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bugzilla2007, Unassigned)

References

(Blocks 1 open bug)

Details

Quick filtering is and will continue to be one of the most important ways of searching for messages. We should provide an easier way to remove an active quick search filter from folder display.

Steps to reproduce
1 be in your inbox with 1000s of msgs
2 use e.g. "Subject, From, or Recipient" filter, type in search terms to filter for "what you want"
3a don't find "what you want" and want to remove filter *via keyboard* to try sth. else OR
3b browse matching messages (focus in msg list)
4 you're done and want to remove the filter *via keyboard* to do sth else

Actual result
- (3a) in cases of focus and cursor in qs bar, need to select search terms (ctrl+a)
- (3b) need to focus on qs bar (ctrl+k if you happen to know that)
- need to remove filter terms manually (DELete etc)
-> using keyboard only, it's always a two-step operation

Expected result
- from whereever your focus is (most likely in the msg list, or cursor-focus in qs bar), just press ESC and the active filter will be removed (all msgs show)
- this would be really nice in terms of workflow

Implementation details

- we are currently using ESC for stopping dataflow while getting messages, but I doubt any person is ever using this (first, because it's unknown, second, why would you stop downloading messages, third, at DSL speed, this will practically be impossible in many cases)
-> we could use PAUSE/BREAK key instead (next to PrintSCR key) for stopping dataflow (which is probably even more intuitive for that purpose than ESC)

I discussed this this with Wayne, and he also liked the idea:
> I certainly would like a one key combo to clear search filters.
Bug 545955 will implement this.
Blocks: filterbar
No longer blocks: filterbar
Implemented by bug 545955.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
There is now no way of stopping a message from loading.  The scenario where this functionality was useful is e.g. loading an RSS message with an image coming from an unresponsive server.  You used to be able to just press ESC to stop the attempt to load the image and then you could read the text.  With the current behavior, there's really no way of reading the message unless you wait for the timeout.

Ideally, one could use the Stop button instead of ESC.  However the stop button is non-functional ( bug 239616 )

Bug 579576 was filed because of this fix.
Depends on: 239616
Depends on: 579576
No longer depends on: 239616
I've added documentation for this in "Keyboard Shortcuts", major revision 5658 (1), as documented in bug 721666.

(per bug 579576)
- removed "Stop: [ESC]"
- added:

|-
|Clear current Quick Filter; hide Quick Filter Bar||{key Esc} (as often as needed)
|-

(1) https://support.mozillamessaging.com/en-US/kb/keyboard-shortcuts/revision/5658
Depends on: 714041
You need to log in before you can comment on or make changes to this bug.