Bottom border of SELECT pull down is not drawn in windows without HWA

RESOLVED DUPLICATE of bug 545685

Status

()

defect
RESOLVED DUPLICATE of bug 545685
10 years ago
3 years ago

People

(Reporter: alice0775, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(firefox27 affected, firefox28 affected, firefox29 affected, firefox30 affected, firefox-esr24 affected)

Details

Attachments

(4 attachments)

Reporter

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2b3pre) Gecko/20091109 Firefox/3.5.1 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2b3pre) Gecko/20091109 Namoroka/3.6b3pre ID:20091109051912

In windows classic default theme.

Bottom border of SELECT pull down is not drawn


Reproducible: Always

Steps to Reproduce:
1.Start Namoroka with new profile
2.Open test case
3.Popup pull down of SELECT

Actual Results:  
Bottom border of SELECT pull down is not drawn


Expected Results:  
Draw border
Reporter

Updated

10 years ago
Version: unspecified → 1.9.2 Branch
Reporter

Comment 1

10 years ago
Posted file Test case
Reporter

Comment 2

10 years ago
Posted image Screen shot
Reporter

Comment 3

9 years ago
It still happens on Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.14pre) Gecko/20110103 Firefox/3.6.14pre ID:20110103033208

However, It does not happen on latest m-c nightly.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20110107 Firefox/4.0b9pre ID:20110107030356
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

8 years ago
I have just been encountering the same bug, and have my own minimal test-case which will attach in a moment.

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
	<title>Select menu bug test-case</title>
</head>
<body>
	<div style="line-height: 2em;">
		<select style="font: 99% arial;">
			<option></option>
			<option>B</option>
		</select>
	</div>
</body>
</html>

In that code, deleting either of the two style attributes, or putting a letter in the first option, causes the full border to be rendered.

Also, if I go to Options -> Options -> Contnet -> Default font and change Verdana to Times new roman, the it starts rendering the full boarder.

Emailing the test file to a colleague, he did not initially see the problem until he changed his default font options to Verdana/16 to match mine. 

As part of testing this, I just upgraded from Firefox 5.0 to 6.0, and the bug happens with both. That is, I am now reproducing the bug with

	Mozilla/5.0 (Windows NT 6.1; rv:6.0) Gecko/20100101 Firefox/6.0

Clearly this is a horrible, difficult to reproduce bug. Good luck whoever decides they are brave enough to work on it ;-)

Let me know if I can provide any more useful information.

Updated

8 years ago
Attachment #553507 - Attachment mime type: text/plain → text/html

Comment 6

7 years ago
Posted file New testcase
I have come upon a bug I believe is the same as the one reported here.

using: Mozilla/5.0 (Windows NT 5.1; rv:15.0) Gecko/20100101 Firefox/15.0.1

Updated

7 years ago
Attachment #664507 - Attachment mime type: text/plain → text/html
Reporter

Comment 7

5 years ago
I can reprosuce the problem with attachment 411417 [details] on Windows8.1 without HWA.

https://hg.mozilla.org/mozilla-central/rev/41d962d23e81
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140311030201
Summary: Bottom border of SELECT pull down is not drawn in windows classic default theme. → Bottom border of SELECT pull down is not drawn in windows without HWA
Version: 1.9.2 Branch → Trunk
See Also: → 545685

Updated

3 years ago
See Also: → 429302
Reporter

Comment 8

3 years ago
https://hg.mozilla.org/mozilla-central/rev/70dfd4254cf977be2000b41f7a6b97eaada8e2a0
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0 ID:20160507030302
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME

Comment 9

3 years ago
The issue is not resolved... If you look at the original test case I made you'll see that the border is still missing (using FF 46.0.1)

Comment 10

3 years ago
(In reply to Jago P from comment #9)
> The issue is not resolved... If you look at the original test case I made
> you'll see that the border is still missing (using FF 46.0.1)

I mean the "New testcase", 2nd drop down.
I can confirm that it's still broken on Windows 7, though to me it looks like it's unrelated to hardware acceleration. I.e. the bottom border line is invisibile with and without HWA.

Though there are several other bugs reported for this[1], so I consolidate them now.

Sebastian

[1] Bug 545685, bug 924068, bug 994923
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 545685
See Also: 545685
You need to log in before you can comment on or make changes to this bug.