Closed Bug 531489 Opened 10 years ago Closed 10 years ago

weave lost bookmarks with same url

Categories

(Firefox :: Sync, defect, critical)

defect
Not set
critical

Tracking

()

VERIFIED FIXED

People

(Reporter: mozdiav, Assigned: Mardak)

References

Details

(Keywords: dataloss)

Attachments

(3 files, 3 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20091127 SeaMonkey/2.1a1pre
Build Identifier: 

When I have some bookmarks with same url, but in different locations, or/and different fields, after 2 sync, some of bookmarks removed.

Reproducible: Always
Severity: normal → critical
Keywords: dataloss
Attached file profile1 log
Attached file profile2 log
http://yfrog.com/j5capture20091128053608px
there is a slideshow with screenshots of 2 browsers.

First we have 2 profile in sync. Then I copy bookmark named "linux.org.ru" to toolbar, and rename it to "lor"
After sync on 1 host appears only new bookmark named "lor" on toolbar. Then on source host boolmark "linux.org.ru" lost from original folder, but on toolbar appears 2 bookmarks named "lor".

Then I rename one of pair to "lor renamed". and bookmark in first profile appers as "lor renamed".

screenshot names ends with timestamps, it can help to place screenshots on log file timeline.
Maybe, flickr hosting will be more comfortable
http://www.flickr.com/photos/shtripok/sets/72157622889934260/
i have the same situation, i have 3 computer to sync: computer A and B are in company, computer C is at home, A is windows, B is linux, C is windows, and i keep firefox on A running 7x24 for some reason. i got the bookmark D in directory E and F, i find sometime thers is no D in E, and sometime two D in E, even sometime D appear in the place it shouldn't be(eg. directory G).
when i use xmarks, it is ok.
Ed, is this a dupe?
Duplicate of this bug: 535525
the only solution i have got is change the url, eg. i use one as "?order=dateline&action=spacenews" and the other "?action=spacenews&order=dateline",or i use one as "abc.com/bbs" and the other "abc.com/bbs/", may this will help you.
confirmed. 

This is how I reproduced with bookmark of http://www.linux.org.ru

1) Visit the site on client A.
2) bookmark the page by clicking the star twice and putting it in the bookmarks menu folder under the default Mozilla Firefox folder.
3) open the library and copy then paste said bookmark into the Bookmarks tool bar folder.
4) Sync to cloud on client A
5) sync from cloud on client B

tested results:
The bookmark of LINUX.ORG.RU is not present on client B's Bookmark toolbar.  The bookmark is present in the Mozilla Firefox folder on client B

Expected results:
Both copies of the bookmark are present in the same locations on client B as they are on client A.

Tested from Mac 10.6 (client A) to Win XP (client B)

Testing in the other direction, the bookmark appears on the toolbar but not in the Mozilla Firefox folder upon sync from WinXP to Mac 10.6
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
Attached file activity logs of 10.6 and WinXP (obsolete) —
Are you sure you were syncing from os x to win xp? The logs seem to indicate weave creating a linux.org.ru bookmark on the os x side. Could you turn on Debug logging for bookmarks?
Attached file 10.6 to XP sync (obsolete) —
I set extensions.weave.log.logger.engine.bookmarks -> Trace on both clients.  I can't tell, nor do I know what differences should appear in the log.
Attachment #423065 - Attachment is obsolete: true
Attached file 10.6 to XP sync bookmark Trace on (obsolete) —
Attachment #423092 - Attachment is obsolete: true
sorry, didn't select plain text last time
Attachment #423096 - Attachment is obsolete: true
(In reply to comment #14)
> sorry, didn't select plain text last time

(For future reference, you don't actually have to re-post in this situation -- you can just click "details" next to the attachment, and change the "MIME Type" field to say "text/plain")
http://hg.mozilla.org/labs/weave/rev/a154534ae332
Do dupe detection for bookmarks like how we do folders/separators but check against the url/title. Add parentName to bookmark records, so bump version.
Assignee: nobody → edilee
Status: NEW → RESOLVED
Closed: 10 years ago
Component: General → Sync
QA Contact: general → sync
Resolution: --- → FIXED
Target Milestone: --- → 1.0
Duplicate of this bug: 541915
Duplicate of this bug: 532607
Status: RESOLVED → VERIFIED
Flags: in-litmus?
removing in-litmus flag, it no longer exists
Flags: in-litmus?
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.